Overclockers UK Forums Click here for more details
Free Shipping for Loyal Forum Members - CLICK HERE

Go Back   Overclockers UK Forums > Hardware > Laptops & Tablets

Reply
 
Thread Tools
Old 30th Jul 2013, 13:07   #1
stvmor
Gangster
 
Joined: May 2005
Posts: 323
WARNING: Nice laptop, shame about the w8 build :{

Has anybody else bought the MSI GT70 2OC-281UK 17.3" True HD LED, Intel i7-4700MQ, 8GB DDR3, 750GB HDD, NVIDIA GTX 770M 3GB, DVD-RW - Windows 8 Laptop?
Just a warning that u may have to spend several days on google etc and waiting for your laptop to "sort itself out" b4 u can use it!
If u are not reasonably competent with fairly in depth computer diagnostics and repair, you may end up rma'ing one of these as startup and closedown times in the region of hours may be a little alarming.
Now I have the damn thing running it's very impressive but what a bloody mess MSI w8 builds are.

IMPORTANT: The MSI website is a nightmare of incorrect information. DO NOT download the MSI Live Update software as it destroys your machine. Sometimes there is a warning against this option for laptop users but not always as i found out to my cost.

X2 4400 on ASUS Premium @ 2.63 GIG, 6870. Seasonic 600, Sonata and 4 Gb Standard Crucial (gave up on Ballsistiks!)
stvmor is offline   View trust for Reply With Quote
Old 30th Jul 2013, 13:39   #2
SarGara
Hitman
 
Joined: May 2012
Location: Nottingham
Posts: 669
What do you mean by "sort itself out" exactly?

I bought an MSI GE40 last month and I cant say I've had any issues with this MSI Windows8 build compared with other manufacturers and their bloatware?
SarGara is offline   View trust for Reply With Quote
Old 30th Jul 2013, 16:34   #3
stvmor
Gangster
 
Joined: May 2005
Posts: 323
The laptop was taking hours to shutdown and boot up and errors cropping up all over the place especially from some of the preinstalled MSI utilities. The main culprit appears to have been a combination of windows 8 removing language packs which were not even showing as installed and MSI's own "Live Update" software. I spent many, many hours looking through forums and eventually got things going but it was no fun at all. Just wondered whether anybody else had these problems seeing as OC had them on special last week so probably sold a few.
I also wanted to warn ppl not to use Live Update!

X2 4400 on ASUS Premium @ 2.63 GIG, 6870. Seasonic 600, Sonata and 4 Gb Standard Crucial (gave up on Ballsistiks!)
stvmor is offline   View trust for Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 09:23.


Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Overclockers UK (Ocuk Ltd)