Overclockers UK Forums Click here for more details
Free Shipping for Loyal Forum Members - CLICK HERE

Go Back   Overclockers UK Forums > Hardware > Graphics Cards

Reply
 
Thread Tools
Old 28th Apr 2011, 14:22   #1
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
6870 stuttering

Hey there, I need some help with a computer I built a couple weeks ago. Yesterday I started getting constant stuttering in movies and games that my ancient nvidia card used to run with no problems at all, and some sporadic texture flickering. I don't remember doing anything special that might've caused this, haven't oc'd any component yet either. Modern games (bfbc2, crysis) appear to run alright, card goes to 100% and performs as it's expected to, it just seems to relax too much when it's running older stuff.

I've tried five or six driver versions, played with all the settings in Catalyst, tried a different HD and ran a couple of memtest86 passes, and the problem's still there. PSU is 750W, brand new, but I suppose I can't rule it out as the cause. Here are 3dmark vantage results (slightly lower than I expected, but mostly alright) and a gpu-z log, in case they're of some use. Thanks!
Last edited by girafferider; 28th Apr 2011 at 14:24.
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 15:11   #2
straxusii
Mobster
 
straxusii's Avatar
 
Joined: May 2003
Posts: 4,737
Something else will most likely be running, use task manager and start killing off apps that dont look essential and see if it stops.

3930K | Titan X + EVGA Hybrid Cooler | Acer Predator 4k G-sync
16GB Corsair DDR3 1600Mhz | Asrock Extreme4-m X79
Samsung 840 SSDs: 250MB Pro , 1TB Evo | Windows 10 64 bit
straxusii is offline   View trust for Reply With Quote
Old 28th Apr 2011, 15:17   #3
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
No luck.
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 15:34   #4
HAz
Capodecina
 
HAz's Avatar
 
Joined: May 2003
Location: Torquay Devon
Posts: 10,172
downgrade

Gigabyte Z77X-UD5H, i5 3570K ivy @ 4.8GHZ, 16GB Corsair Ballistic 1600, Msi 980 ti, 2x m4 128gb, custom water cooled, 2meg ATTH (aluminium to the home)
HAz is offline   View trust for Reply With Quote
Old 28th Apr 2011, 15:52   #5
Bizarre
Wise Guy
 
Joined: Jun 2005
Location: Newcastle
Posts: 1,143
According to the GPUZ screens you posted, the cards core and mem clocks are jumping all over the place. I'm not sure if that's normal as I'm not up to par with ATI's latest parts but I wouldn't be suprised if it was the cause of the stuttering.
Bizarre is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:11   #6
Jack Bauer
Wise Guy
 
Jack Bauer's Avatar
 
Joined: Nov 2005
Location: Oxford
Posts: 1,591
Quote:
Originally Posted by Bizarre View Post
According to the GPUZ screens you posted, the cards core and mem clocks are jumping all over the place. I'm not sure if that's normal as I'm not up to par with ATI's latest parts but I wouldn't be suprised if it was the cause of the stuttering.
It is normal, or at least the same thing happened with my 6950. Downclocked its self when not in use/high load. Didnt stutter tho, at least not for that reason.
Jack Bauer is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:18   #7
Bizarre
Wise Guy
 
Joined: Jun 2005
Location: Newcastle
Posts: 1,143
I realise that it's normal to down clock itself when in 2D mode but is it normal to be jumping between 100MHz, 900MHz and 775MHz all in the space of 27 seconds?
Bizarre is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:19   #8
Emphacy
Wise Guy
 
Emphacy's Avatar
 
Joined: Nov 2010
Location: <?php $_SERVER[] ?>
Posts: 1,850
Don't tell me even the latest gen of ATI cards have PowerPlay?
If this is the case, it's easily fixed, but it's a ****** for causing stutter.


I pushed your mum onto my stack.
Emphacy is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:26   #9
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
No idea what powerplay might be, but it's worth a try I guess. What should I do to fix it?

Edit: did some googling and it does indeed appear in the 6870's specs:
AMD PowerPlay™ power management technology

* Dynamic power management with low power idle state
* Ultra-low power state support for multi-GPU configurations
I suppose that's what's causing the clocks to jump all over the place, haven't found how to disable it though. Setting clocks in afterburner didn't help
Last edited by girafferider; 28th Apr 2011 at 16:32.
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:31   #10
Emphacy
Wise Guy
 
Emphacy's Avatar
 
Joined: Nov 2010
Location: <?php $_SERVER[] ?>
Posts: 1,850
LINK

This works with AMD Catalyst Control Centre 2 as well. You just have to create a new Preset in the same way as a profile.
It's well worth a try...


I pushed your mum onto my stack.
Emphacy is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:32   #11
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
On it.
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:49   #12
CAT-THE-FIFTH
Capodecina
 
Joined: Nov 2009
Location: Planet Earth
Posts: 11,782
What is the model number of your PSU??
CAT-THE-FIFTH is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:51   #13
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
Well the stuttering's not gone, but it's much better now. I'll see if the CPU has some similar power saving mode, disable it and report back
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 16:53   #14
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
PSU is an antec tp-750, should be able to run two cards like mine
girafferider is offline   View trust for Reply With Quote
Old 28th Apr 2011, 17:00   #15
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
I just happened to find this. Is this normal or is Windows trolling me? Don't really think I need 4GB's of slow virtual vram
girafferider is offline   View trust for Reply With Quote
Old 29th Apr 2011, 08:26   #16
Bizarre
Wise Guy
 
Joined: Jun 2005
Location: Newcastle
Posts: 1,143
That's normal for either Vista or Win 7. It's kinda like a pagefile for the video card, and as far as I know it cannot be disabled. Shared system memory is controlled by the WDDM driver which is included with Vista and Win 7, it's also included with the Catalyst and Nvidia driver packages.
Bizarre is offline   View trust for Reply With Quote
Old 29th Apr 2011, 11:52   #17
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
Okay I did a clean install to remove the dozen drivers I must've tried, followed this trick to set clocks to 1/3 of full power and it's smooth as silk now.
I really like this card now that it's working alright, but I want to try some of what the AMD engineers were having when they wrote up the drivers. Default 10% underscan on the HDMI output and a power saving system that makes the clock jump several times a second? Give me a break.
Thanks a lot for helping, been scratching my head at this for a long time
girafferider is offline   View trust for Reply With Quote
Old 29th Apr 2011, 12:04   #18
Emphacy
Wise Guy
 
Emphacy's Avatar
 
Joined: Nov 2010
Location: <?php $_SERVER[] ?>
Posts: 1,850
Quote:
Originally Posted by girafferider View Post
Okay I did a clean install to remove the dozen drivers I must've tried, followed this trick to set clocks to 1/3 of full power and it's smooth as silk now.
Is your card now then running at 1/3 of it's full capability?
I want to make sure I don't get this 'stutter' when I come to buy a new 6XXX series card, I've had enough trouble with my 4890.


I pushed your mum onto my stack.
Emphacy is offline   View trust for Reply With Quote
Old 29th Apr 2011, 12:11   #19
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
I made a bunch of custom profiles, 10% power for web browsing and work, 30% for old games and 100% for maya rendering and new games, and it appears that the stuttering's gone. Haven't done much testing yet, I'll write again tonight and tell you if it's working alright
girafferider is offline   View trust for Reply With Quote
Old 29th Apr 2011, 23:17   #20
girafferider
Associate
 
Joined: Apr 2011
Posts: 30
I restarted and for some god-forsaken reason the card started switching between the profiles, and I was back to square one. The only way I've found to tame it is to use a single profile and edit the values in it when I want to change clocks. Annoying as hell, but it works, with the caveat that if the card's under heavy load it likes to jump to full clocks, but it never goes below the value you set. I'd definitely prefer full control, but this gets rid of the stuttering all right, so it'll have to do till they release a halfway decent driver.
Ignoring the misguided software the card's remarkably good, powerful, efficient and silent, but I can't recommend buying a gaming card that doesn't allow easy and precise clock control. And I might be claiming victory too early, I've no idea if it's gonna start doing more antics when I fire it up tomorrow. If I'd known I would've gone for nvidia.
girafferider is offline   View trust for Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 00:21.


Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Overclockers UK (Ocuk Ltd)