400D USB cable

Associate
Joined
9 Oct 2004
Posts
1,376
Location
Paris
Hey all,

I've been having some trouble transferring photos from my 400D on to my PC for a while now (nothing comes up on camera in My Computer, it says "busy" on the camera for a few secs then nothing). So i looked at my USB cable and suddenly realised it looked a lot like the one I used for my S5600 and sure enough, it fits.

So is that the reason i've been getting these problems, or aren't these cables universal?

Cheers :)
 
Caporegime
Joined
25 Jul 2005
Posts
28,855
Location
Canada
Yep Universal, quite useful as I have about 6 pieces of electronics (compact, mp3, 400D...) that all use the same USB cable. :D
 
Associate
Joined
9 Oct 2004
Posts
1,376
Location
Paris
Okay thanks everyone. I actually found the Canon one, which ofc is exactly the same but white (thought it was my ipod cable at a glance). Took me like 20 times to power on and off before I eventually got it to work =/
 
Soldato
Joined
20 Mar 2006
Posts
8,214
Yep had this issue, it seems to occur once you have a lot of data on the memory card of if you have taken a lot of shots in RAW.

Card reader is the best bet.
 
Soldato
Joined
26 Dec 2003
Posts
16,522
Location
London
What card readers are you all using ?

I use Sandisk Extreme III CompactFlash card and would prefer a card reader.

I bought a Sandisk SD card that came with its own reader that's only slightly bigger than the SD card, which is neat. I did have a dedicated card reader, but it doesn't support SD cards >=2GB which is pretty useless.
 
Top