1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

About to install Windows 10 onto PCIe 4 NVMe on Gigabyte X570 AORUS ELITE - advice please?

Discussion in 'Motherboards' started by RaMDOM, Jun 7, 2020.

  1. RaMDOM

    Wise Guy

    Joined: Nov 20, 2005

    Posts: 1,666

    Location: Birmingham

    Hi all. I have components arriving this week for a new build and have decided to go the AMD route with a 3600X. I have also decided to install a 1TB NVMe PCIe4.0 M2 drive which I would like to boot Windows from. This is a first for me and so I have been looking into the science behind this beforehand so I have some idea what I am doing (hopefully). So far it seems to be pretty simple:

    1. Confirm or set the M.2 SSD as the first boot option
    2. Confirm (or set) the Storage Boot Option Control to “UEFI”

    and then I should be set.

    The questionable part, from what I have been reading, is the CSM. From my internet investigation some people have had issues installing and then booting with CSM enabled and then have not been able to disable it afterwards, however others have had no problem; the MoBo type has not been that specific, but they have been talking about x570 bpards.

    Looking at the Aorus Elite Manual by default CSM support is enabled (enables UEFI CSM). Whereas 'Disabled' disables UEFI CSM and supports UEFI BIOS boot process only. Should this be disabled? I am not sure. All other UEFI options seem to be defaulted to enabled.

    Would appreciate some advice on this and anything else that I may need to consider.

    Thanks in advance.
     
  2. The Old School Gamer

    Hitman

    Joined: Feb 22, 2019

    Posts: 568

    Location: The Twilight Zone

    CSM should be disabled.

    You only really need to enable it for an incompatibility.
    E.G Your graphics card is too old to support UEFI etc.
     
  3. RaMDOM

    Wise Guy

    Joined: Nov 20, 2005

    Posts: 1,666

    Location: Birmingham

    Thanks for the response. Why would this be enabled by default, I would have thought that it should be the other way around. Unless there is no issue with it being enabled?
     
  4. Gray2233

    Mobster

    Joined: Oct 25, 2010

    Posts: 2,721

    I'd recommend only having the NvME connected (no other storage drives) while doing the installation, Windows 10 sometimes likes to put parts of itself on other drives for some reason and it can cause problems.

    Plug your other ssd's etc in once you're done.
     
  5. RaMDOM

    Wise Guy

    Joined: Nov 20, 2005

    Posts: 1,666

    Location: Birmingham

    Yep that is what the internet has advised. With 1 Tb I will not be in a hurry to install any other drives for a little while.
     
  6. The Old School Gamer

    Hitman

    Joined: Feb 22, 2019

    Posts: 568

    Location: The Twilight Zone

    It's just an legacy support mode for older equipment.
    Hence it's going to cause far less problems compatibility wise being enabled by default than disabled (from a manufacturers support point of view).

    But there are certain options only available from a pure UEFI environment.
    GPT, fast boot, secure boot etc.

    But if all your parts are new there really is no need to run in a mixed legacy mode.
     
    Last edited: Jun 10, 2020
  7. random_matt

    Wise Guy

    Joined: Jul 30, 2012

    Posts: 1,015

    You don't actually need to mess with bios, just go straight to boot menu and select the USB. Enter bios will be one button, boot menu will be another, should tell you in the manual.