Artic Liquid Freezer 2 - constant noise from pump

Associate
Joined
7 Apr 2016
Posts
11
Hi,

So I have just upgraded from the 240 version to the 360 version (following a case upgrade for my gaming PC and a failing air cooler which the 240 has replaced on a PC I mainly use for work related stuff)

The 240 was (and is) very quiet, barely a sound from the pump. However, the 360 is emitting a constant clicking/rattling noise.

The radiator is top mounted and I've tried the usual tricks to get rid of any potential air bubbles in the pump but the noise persists. I've also tried stopping the VRM fan, so ruled that out.

Has anyone else had this issue with the Freezer 2? Was I lucky with the 240 or could the 360 be faulty.

It's driving me mad!
 
Associate
Joined
20 Jun 2013
Posts
1,830
is it from the pump, the fans, or the rad?
Check your fan attatchment see if anything is touching the blades, or the frame itself has flexed.
 
Associate
OP
Joined
7 Apr 2016
Posts
11
is it from the pump, the fans, or the rad?
Check your fan attachment see if anything is touching the blades, or the frame itself has flexed.

It's from the pump. During investigation I stopped all of the case and rad fans and the noise was still there and defiantly sounded like it was coming from the pump assembly.
(my HDs are all SSDs so no vibration/noise coming from there either).
 
Associate
Joined
20 Jun 2013
Posts
1,830
So it's coming from inside the pump?
I'd take it out the computer, give it a quick shake, and see, but if something is inside and blocking your flow then maybe best to rma it
 
Associate
OP
Joined
7 Apr 2016
Posts
11
So it's coming from inside the pump?
I'd take it out the computer, give it a quick shake, and see, but if something is inside and blocking your flow then maybe best to rma it

Ok thanks, will give that a try, if it makes no difference then I guess it's an RMA as I've tried everything else.

my 360 only really makes noise when the PWM fans kick in

Thanks, yes same as the 240 version I have, nice and quiet. I thought I would see if anyone else had a similar issue with the 360, but if giving the pump a shake doesn't work I'll RMA it.

Thanks all.
 
Soldato
Joined
14 Aug 2018
Posts
2,760
I had the 360 and now the 280 (as it cools better in my case). Neither of them made any annoying pump noise. I'd definitely RMA it without hesitation.
 
Top Bottom