ASUS Chromebook C201P won't boot, recovery mode fails

Associate
Joined
31 Jan 2021
Posts
1
Hi,


I've acquired an ASUS C201P Chromebook that will not boot, and attempts at system recovery result in an error.

The laptop boots into the developer mode screen, but will not go any further. Specifically:
  1. Press power button -> 'Welcome to developer mode!’ followed by various Ctrl+ options
  2. Press Ctrl+D to ‘Boot from internal storage’ -> ‘Welcome to recovery mode! Ctrl+D: Enable developer mode (if possible). Please insert an external recovery media.’
  3. Press Ctrl+D to ‘Enable developer mode (if possible)’ -> nothing happens
  4. Insert Chrome OS Recovery USB (or reboot with USB attached) -> verification of recovery media integrity passes, system recovery process starts (with a message at the bottom saying ‘Chrome OS verification is turned off’), but eventually (~5 mins) it fails with message ‘An unexpected error has occurred’ (I've tried this with 2x USB flash drives and 1x microSD card so it's definitely not a medium failure)
The only suggestion left on Google's support page was to contact ASUS—they offered to repair it, but given the age of the device I don't think it would be worth paying for that, so I'd like to know if I can fix it myself or if it is well and truly bricked (in which case I'll just get rid).

Backstory-wise, the previous user says they successfully flashed the device with libreboot (as in, they could boot Chrome OS afterwards) and then attempted to replace the OS with Arch, at which point I'm assuming they managed to corrupt the bootloader. Also, I've tried to boot from an Ubuntu LiveUSB, but the machine just made a loud beep and nothing happened (which I gather is some sort of OS verification mechanism, rather than POST-related).

Finally, here is the information shown when pressing Tab/Ctrl+I at the developer mode prompt:

HWID: SPEEDY G2Q-Z6J-Q2I-A8O
recovery_reason: 0x00 / 0x5b Recovery not requested
VbSD.flags: 0x00004e54
VbNv.raw: 70 00 00 00 00 02 5b 00 00 00 00 00 00 00 00 25
dev_boot_usb: 0
dev_boot_legacy: 0
dev_default_boot: 0
dev_boot_signed_only: 0
dev_boot_fastboot_full_cap: 0
TPM: fwver=0x00020003 kernver=0x00030002
gbb.flags: 0x00000000
gbb.rootkey: e645f9b25bf76aabae9a5cb975c3c22ab7a6c208
gbb.recovery_key: f5d635d26e3a9bd2ce876d57cca9b14598403b24
kernel_subkey: 73fa3bcbe921f62b395132ce23a8514a537bdfa6

read-only firmware id: libreboot-r20160907
active firmware id: libreboot-r20160907
 
Top Bottom