Asus RT-N66U, rubbish or faulty?

L33

L33

Associate
Joined
1 Apr 2003
Posts
1,867
I've just changed my ultra reliable rock solid but ageing DLink router for one of these and so far it has been a frustrating experience - the UI is poor, inconsistent and buggy.

Port forwarding sometimes works, sometimes doesn't and even more worryingly sometimes forwards to the wrong IP address :confused:
The 'client list' and various drop-down lists of devices are inconsistent, sometimes missing devices and sometimes showing DNS/netbios names, sometimes not. The DHCP reservation list doesn't show names or have anywhere to even manually type in a name (like anybody can remember which mac address is which device). And the PPTP VPN is just flaky - works some times and no others (confirmed from mac, windows, iphone and android). I've not even bothered with the more advanced features as these basics are so unreliable.

Is this a common thing or is mine just faulty? I'm running the latest firmware and have factory-defaulted a few times.
 
Don
Joined
21 Oct 2002
Posts
46,520
Location
Parts Unknown
Asus are starting to annoy me, sound card drivers released late and often in .rar packages.

Half working router firmware that should be sorted in the testing stages. They seem to rely on the customer to find their issues for them.
 
Soldato
Joined
15 Dec 2004
Posts
5,756
Location
Hudds, UK
running 220 version of firmware since day one and rock solid so far.
Only prob I had was with the USB printer dropping off, but no biggy as I hooked it into my NAS instead
 
Soldato
Joined
7 Dec 2007
Posts
3,939
Location
Swansea, Wales
FFFFFFFFFFFUUUUUUUUUUUUUUUUUUUUU

running 220 version of firmware since day one and rock solid so far.
Only prob I had was with the USB printer dropping off, but no biggy as I hooked it into my NAS instead

Latest firmware has broken WIFI

Use Merlins version and it fixes this.

;)

was about to make a new thread but decided to hijack this one instead ;)

So far this router was awesome for me! rock solid wired connection, nice interface (compared to the virgin rubbish) and pretty damm good wifi....or so i thought.

I got my router and set it up. did a wireless speedtest with my phone and was getting about 40-50mb through.... pretty good... the i updated from the .220 to .260 firmware... was fine at first... but i noticed wifi hangs/reconnections a day or so after (only had it on saturday). now when I use wifi it's absolute dog s*** :mad:

i'll do a speed test next to the router and the ping will be fine but then i'll only get a 500kbps connection instead of the 50mb....upload does nothing.... then if i close and try again it just doesn't work!!! was on the laptop and trying to load web pages with apparently full signal it was only download web content up to 40KBps..... which is stupid as i have a 63MB connection now and bought this router to utilise it!!! Is it simple enough to roll back the firmware? i.e. dl it from the asus site and then just repatch through the router menu?

thanks in advance :D

TL/DR: was on fw .220, then went to .260...wifi now rubbish, dodgy firmware? easy enough to roll back?

(PS ontop of that my laptop is now dead :( )
 
Soldato
Joined
15 Dec 2004
Posts
5,756
Location
Hudds, UK
The absolutely latest firmware 360 borkes WiFi bud.
My advice is switch to the latest Merlin firmware or downgrade to 320.

Also note due to nvram changes it's worthwhile completely resetting the router if upgrading from older 2xxx firmware
 
Soldato
Joined
7 Dec 2007
Posts
3,939
Location
Swansea, Wales
The absolutely latest firmware 360 borkes WiFi bud.
My advice is switch to the latest Merlin firmware or downgrade to 320.

Also note due to nvram changes it's worthwhile completely resetting the router if upgrading from older 2xxx firmware

360/320?? you mean 260 and 220? xD

completely resetting.... as in pin in the back/holding reset button jobby? or is there something more complex i have to do? ....also what wizardry is this merlin you speak of ;) ??
 
Soldato
Joined
15 Dec 2004
Posts
5,756
Location
Hudds, UK
Yes sorry mate, meant the new 260 firmware sucks. Its well documented on the support forums that its borked the WIFI.

You only need to do a complete hard reset (yes, pin in the back) if you upgraded from 220 or earlier firmware.

No need to downgrade - just install the latest merlin firmware from here and it fixes it - much more reliable and some sexy new features ;)

http://www.lostrealm.ca/tower/node/79
 
Top