1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asus USB-AC56 wifi dongle tweaks

Discussion in 'Networks & Internet Connectivity' started by Type_R, Nov 5, 2016.

  1. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    I have been using this dongle for the last few months in Win 10 and find that it loves to disconnect/reconnect, randomly drop out, switch from 5 Ghz to 2.4 Ghz etc. So I started looking for some tweaks and found some excellent ones that have made it very stable indeed, I thought they might be useful to someone on here.

    My Setup:

    • Router: Asus RT-AC66U 1750
    • Dongle: Asus USB-AC56 1300

    Physical Setup:

    The router is connected to the master socket via an ADSL faceplate filter in the lounge.
    The computer is upstairs a fair distance away from the router with a direct line of sight passing through at least 2 interior walls and one brick wall. The dongle is connected directly to a USB 3.0 port (with latest mboard USB 3 drivers installed)

    Software Setup:

    Router: I am using the latest Merlin software - As found here
    I have setup the 2.4 Ghz and 5.0 Ghz wireless channels with different SSIDs.
    2.4 Ghz channel: 11 (extension below)
    5.0 Ghz channel: 44 (auto 20/40/80) (auto up or down extension)

    *channels are always dependent on what is going on at a local level, e.g. interference from neighbours and home devices. These are just what worked well for me.

    Windows 10: Connected the dongle. Installed latest Asus drivers found here
    I also installed the asus utility found in the same place but this is not essential. It gives real time connection speed with the router and search facility to see which networks in your area are using which channels.

    Tweaks: In order to get stability in the system - despite the utility giving me full signal at both 5Ghz and 2.4Ghz I had to make the following changes:

    Start > Device Manager > Network Adapters > Asus USB-AC56 802.11ac wireless USB adapter - right click on this > Properties > Advanced

    You will see the following menu:

    [​IMG]

    Then I changed the following settings from default:

    • BeamCap - VHT BEAM TX/RX
    • EnableAdaptivity - Auto
    • High Adhoc Mode - Disable
    • HLDiffForAdaptivity - 7
    • L2HHForAdaptivity - F5
    • LdpcCap - VHT LDPC TX/RX & HT STBC TX/RX
    • Preferred Band - 3. 5G first
    • QoS Support - Auto
    • StbcCap - VHT STBC TX/RX & HT STBC TX/RX
    • USB SF Mode - Disable
    • USB Switch Mode - Auto
    • VHT 2.4G - Disable (**This will disable connection at 802.11n - 2.4 Ghz - only use this if you are confident of a decent 5G signal)
    • WiFi Config - Performance
    • Wireless Mode - IEEE 802.11ac

    Finally I switched off power saving on the USB device:

    Start > Device Manager > Network Adapters > Asus USB-AC56 802.11ac wireless USB adapter - right click on this > Properties > Power Management

    Uncheck: 'Allow the computer to turn off this device to save power'

    Since making these changes the wifi connection has been rock stable. No dropouts, connection issues or otherwise.

    Please feel free to use these settings and report back on how they have worked for you. If anyone knows what the *cap settings are all about it would be interesting to know.
     
    Last edited: Nov 6, 2016
  2. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    I have now enabled this and seem to be getting a faster 5Ghz connection :)

    VHT 2.4G - Disable (**This will disable connection at 802.11n - 2.4 Ghz - only use this if you are confident of a decent 5G signal)
     
  3. Nexus18

    Capodecina

    Joined: Jun 4, 2009

    Posts: 23,527

    Tried this out as my 5GHz is extremely broke on windows 10 64 bit (works flawlessy on w7), connects and just disconnects randomly, could be fine for a few hours or just a few minutes.

    Unfortunately didn't work for me, seemed a bit better though.

    My adaptor is the TP link archer AC1200 dual band adapter
     
  4. moogle

    Wise Guy

    Joined: Nov 4, 2006

    Posts: 2,395

    Location: London

    I found this issue is not only with the ASUS wifi dongle and Win10, but others. Before W10 I used the BT 900 AC Dongle on Win7 and it was rock solid. Only after upgrading the OS (installing the W10 drivers too) was when the issues started.
     
  5. Nexus18

    Capodecina

    Joined: Jun 4, 2009

    Posts: 23,527

    Yup, when googling windows 10 5GHz disconnecting, there are tons of reports on the issue, some have done various fixes and said they work but for myself, nothing has given me a 100% stable disconnect free connection compared to 2.4GHz :(

    Problem seems to be on microsoft's end.
     
  6. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    So I guess the question is, is there a way of disabling win 10 from managing the wifi connection and allowing asus to do it?
     
  7. Nexus18

    Capodecina

    Joined: Jun 4, 2009

    Posts: 23,527

    No idea, haven't seen anything mentioned about that in my search for a fix.
     
  8. pc-guy

    Wise Guy

    Joined: May 29, 2005

    Posts: 1,277

    what sync speed and data transfer rate you are getting on that dongle OP?
     
  9. lude1962

    Wise Guy

    Joined: Feb 27, 2014

    Posts: 2,152

    services ->wlan auto config
    set to disabled
    use connection manger supplied by manufacturer
     
  10. Overlag

    Capodecina

    Joined: Oct 18, 2002

    Posts: 10,993

    Location: Romford/Hornchurch, Essex

    I was fine with Windows 10, but after the anniversary update it totally killed 5ghz stability on BOTH my Wifi dongles (Asus and CSL) on 3 PC's!
     
  11. pc-guy

    Wise Guy

    Joined: May 29, 2005

    Posts: 1,277

    not sure if it helps anyone but I have netgear A6210. I was using mediatek's firmware initially when W10 rolled out as Netgear didn't have driver for W10. subsequently I updated to netgear driver. but about 1 month ago, i noticed the speed of the dongle starting to wane and suffered random disconnects which i never had. thus I uninstalled the netgear driver and rolled back to the mediatek driver. now it is working really well. I just done some tweaks as suggested, I get sync rate around 500mbps and transfer rate upto 250mbps that's with the router downstairs and my pc upstairs next to a wall which is probably the worst.

    however the data rate does fluctuate during the transfer between 90mbps and 250mbps but average is around 150-170mbps
     
  12. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    Thanks. Unfortunately seems like Asus's utility cannot handle the connection without W10 services running :(
     
  13. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    Asus reports a connect of 720 Mbps from my dongle to the router.
     
  14. Type_R

    Soldato

    Joined: Oct 18, 2002

    Posts: 6,080

    Location: EGBB

    So just a quick update...I decided to start messing about a bit with settings...always wanting more speed! After reading up on a few things I changed some settings that have definitely made the connection faster (and continues to be stable!).

    The Asus RT-AC66U is still running Merlin software @ 380.66.4 (latest) and is in the same position it always was (downstairs - several walls away).

    First thing I did was change the driver Win 10 was using for the Asus. There were reports the 2015 or even the 2013 driver was more stable/faster than the 2016 I was running.

    Start > Device Manager > Network Adapters > ASUS USB-AC56 802.11ac Wireless USB Adapter > Driver (tab) > Update Driver > Browse my computer > Let me pick from a list:

    [​IMG]

    All three drivers should be installed if you have installed the ASUS USB-AC56 Utility 2.1.1.5 For Windows (https://www.asus.com/uk/Networking/USBAC56/HelpDesk_Download/)

    Once installed, this then gives you different network adapter settings to play with:

    [​IMG]

    I haven't tried changing power levels for 5G (doesn't seem to make any difference to performance so left them alone)

    These settings increased my connection to 867 mbps (channel remained at 40)

    Antenna Diversity Type: Fixed
    BeamCap: VHT BEAM TX/RX
    EnableAdaptivity: Enable
    High Ad-hoc Mode: Disable
    HLDiffforAdaptivity: 7
    L2HforAdaptivity: F1
    LdpcCAp: VHT LDPC TX/ HT LDPC TX
    Preferred Band: 3. 5G first
    QoS Support: Support QoS
    StbcCap: Disable
    USB SF Mode: Disable
    USB Switch Mode: USB Mode 3 (So these modes determine what sort of USB port you are connected to USB1 for Mode 1 / USB2 for Mode 2 / USB3 for Mode 3)
    VHT 2.4G: Disable
    VHT 2.4G IOT: Disable
    Wifi Config: Performance
    Wireless Mode: IEEE 802.11 ac

    Hope that helps someone!
     
  15. 7stars

    Associate

    Joined: May 1, 2013

    Posts: 23

    the issues with these dongles are the 5ghz channels...
    there are the U-NII rules for indoor only use (typically channels 36-40-44-48)

    so, apart from the drivers matter, the main router must be manually set to range 36-48 (as correctly reported) and not left to "auto"

    in fact, suppose you want to bridge one router with another...if the main router is set to auto and goes over 48, while the other router is restricted to 48, this never will see the 1st router and the scan doesn't work....so you can't do a bridge and you could think that's a wifi performance issue but really the routers can't see each other on a different range of channels (above all if on the DFS range, where other kind of interference can come into play)