• Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

Boost performance on a gaming laptop 4k screen with HDMI dummy plug?

Associate
Joined
22 Feb 2019
Posts
8
Hi guys,

I have a MSI GS73 8RF Stealth laptop which has an integrated Intel UHD 630 and a dedicated 1070 Max-Q GPU. What I noticed is when I plug in a HDMI cable and work on a 4k monitor on 60 Hz, everything is lightning fast. Unfortunately, that isn't the case when I'm using the laptop screen (also 4k, 60 Hz). On the attached laptop screen, Windows animations, as well as, Windows performance itself is slower, and better not to mention games.



What I noticed is that Windows is automatically using the "full power" of the integrated card when running those tasks (especially when playing games), and only 30-40% of the dedicated card. When I'm connected to an external monitor, the integrated GPU performance in task manager is literally at 0% and everything is run through the Nvidia card. That's why everything works so flawlessly (as it should).



Since I paid good money for this laptop, I contacted the MSI help center with the same question - how to improve performance when not connected to an external monitor. This is the reply I got:



"Dear ***********,

It is normal that the performance is poor while using 4K resolution.
I suggest you use the 1080P or 2K resolution.

Thanks & Best Regards,
MSI Notebook Technical Application Department"



Then I asked them are they fuc*ing kidding me with that kind of answer and they referred me to FAQ which, of course, explains nothing.

That's why I'm asking if any of you know a way how to force only Nvidia card for everything? (not talking about Nvidia Control Panel; also don't have that option in BIOS even though I haven't flashed the new version). I also read somewhere that HDMI dummy plug should do the trick. I have it inserted but it changes nothing...



Please help me to unleash the full potential of my laptop.
Thanks!
 
Soldato
Joined
28 Dec 2017
Posts
6,620
Location
London/Beds
resolution.
I suggest you use the 1080P or 2K resolution.

Thanks & Best Regards,
MSI Notebook Technical Application Department"
I find it funny and saddening that MSI's own support team think that 2k is any different from 1080p.

Interested to see what the solution is but can't help, sorry
 
Associate
Joined
20 Apr 2015
Posts
2,182
Location
.
Will it let you disable the intel GPU in the bios? It may force the laptop to use all the 1070 resources.
 
Soldato
Joined
3 Jan 2006
Posts
24,262
Location
Chadderton, Oldham
Lower res on a screen will looks a blurry mess no? If it's Optimus there isn't anyway to bipass the integrated graphics.

Possibly a driver issue?

I find when I plug in my external monitor, it's a laggy mess, not sure why, it's fine when both monitors are operational, I find a restart seems to fix it.
 

HRL

HRL

Soldato
Joined
22 Nov 2005
Posts
2,502
Location
Devon
Disable the onboard graphics in device manager?

Sounds simple I know.
 
Associate
OP
Joined
22 Feb 2019
Posts
8
Will it let you disable the intel GPU in the bios? It may force the laptop to use all the 1070 resources.
No, there's no option for that in BIOS, as i wrote in OP. Thanks anyway.

Lower res on a screen will looks a blurry mess no? If it's Optimus there isn't anyway to bipass the integrated graphics.

Possibly a driver issue?

I find when I plug in my external monitor, it's a laggy mess, not sure why, it's fine when both monitors are operational, I find a restart seems to fix it.

It's not so much a blurry mess as it is noticable that the 4k screen is presenting full HD graphics. Anyway, it is Optimus. Tried everything with the drivers - updating to the latest, full erase and then reinstall, using the earlier ones that MSI wants me to use. Nothing helped.

When I plug in my 4k external monitor or TV, everthing runs great. And I noticed that integrated GPU is at 0% all the time while the external monitor is connected. My problem is with the laptop screen which is slow at 4k graphics because Optimus uses way too much of the integrated GPU and way too little of the 1070.

Disable the onboard graphics in device manager?

Sounds simple I know.
Tried it. It only made things worse. Thanks for the idea anyway!
 
Last edited by a moderator:
Associate
Joined
22 Jun 2018
Posts
1,341
Location
Doon the watah ... Scotland
In that Nvidia control.panel settings you can specify whether it uses the igpu or the dedicated card by default for everything.

You can also specify to use the igpu by default but the dedicated card for specific programs that need it on a program by program basis. May also be related to the power plan youre running

Could it just be the display itself showing poor refresh ?
 
Last edited:
Soldato
Joined
18 Oct 2002
Posts
3,243
Location
Andromeda
I think it might be possible to set to GPU in display settings > graphics settings, but Im not too sure about that. Some games allow you to choose the GPU in options, falling that you could always disable the intel GPU or there could be some software that will do it.
 
Associate
OP
Joined
22 Feb 2019
Posts
8
In that Nvidia control.panel settings you can specify whether it uses the igpu or the dedicated card by default for everything.

You can also specify to use the igpu by default but the dedicated card for specific programs that need it on a program by program basis. May also be related to the power plan youre running

Could it just be the display itself showing poor refresh ?

Thanks, but as I said in the OP, the Nvidia Control Panel doesn't help. Even if I force only Nvidia, it really doesn't change anything. Only when an external monitor is connected.
The display itself is a 4k @ 60 Hz so it should run smoothly.

I think it might be possible to set to GPU in display settings > graphics settings, but Im not too sure about that. Some games allow you to choose the GPU in options, falling that you could always disable the intel GPU or there could be some software that will do it.
Tried that also. Nothing changes...
I'm not aware of any software apart from Nvidia Control Panel that could do that....
 
Last edited by a moderator:
Associate
Joined
4 Apr 2019
Posts
2
Have you tried a 4k dummy plug?

Hi guys,

I have a MSI GS73 8RF Stealth laptop which has an integrated Intel UHD 630 and a dedicated 1070 Max-Q GPU. What I noticed is when I plug in a HDMI cable and work on a 4k monitor on 60 Hz, everything is lightning fast. Unfortunately, that isn't the case when I'm using the laptop screen (also 4k, 60 Hz). On the attached laptop screen, Windows animations, as well as, Windows performance itself is slower, and better not to mention games.



What I noticed is that Windows is automatically using the "full power" of the integrated card when running those tasks (especially when playing games), and only 30-40% of the dedicated card. When I'm connected to an external monitor, the integrated GPU performance in task manager is literally at 0% and everything is run through the Nvidia card. That's why everything works so flawlessly (as it should).



Since I paid good money for this laptop, I contacted the MSI help center with the same question - how to improve performance when not connected to an external monitor. This is the reply I got:



"Dear ***********,

It is normal that the performance is poor while using 4K resolution.
I suggest you use the 1080P or 2K resolution.

Thanks & Best Regards,
MSI Notebook Technical Application Department"



Then I asked them are they fuc*ing kidding me with that kind of answer and they referred me to FAQ which, of course, explains nothing.

That's why I'm asking if any of you know a way how to force only Nvidia card for everything? (not talking about Nvidia Control Panel; also don't have that option in BIOS even though I haven't flashed the new version). I also read somewhere that HDMI dummy plug should do the trick. I have it inserted but it changes nothing...



Please help me to unleash the full potential of my laptop.
Thanks!
 
Associate
OP
Joined
22 Feb 2019
Posts
8
Soldato
Joined
14 Apr 2009
Posts
4,554
Location
Cheshire
Yes, I've seen posts like that but still someone here was talking that problem could be resolved by using HDMI dummy plug. I really don't know how, but still I bought it.

What do you mean a case for return? How can I return a laptop almost 1 year old because it has Optimus? + it was bought in the US. I live in Europe...

I must had missed that in your OP, or assumed it was a new laptop. I can't help but think I would have noticed this pretty quickly. That is no dig at you, just why I assumed it was new.
 
Associate
OP
Joined
22 Feb 2019
Posts
8
I must had missed that in your OP, or assumed it was a new laptop. I can't help but think I would have noticed this pretty quickly. That is no dig at you, just why I assumed it was new.
First I thought it may be because of the drivers. But now I see they're not the problem...
 
Associate
Joined
4 Apr 2019
Posts
2
I use an i7 7700k, 24gb RAM, and 3 samsung SSDs . 1x m.2 nvme, 1x m.2 and 1x 2.5" sata 6gb/s , on a GE63 7RF MSI laptop, 1080p only tho. But even extending to a 4k monitor I dont have performance issues with disable or enabled Intel graphics. Unless I'm running element 3d in after effects for renders, I'll have to turn off Intel graphics.

My Intel 630 graphics is a 24.20.100.6286
Nividia 419.67 for my gtx1070

Running all nividia control, and win 10 64 bit display settings to high graphics, and power set to high performance. Even selected the programs in the windows display/graphic settings, that I want to use the highest settings for my nvidia card And have 8gb dedicated to memory, nvidia cuda enabled.

I run msi afterburner/rivatuner to overclock, and msi kombustor 3 / gpushark v13 to monitor and stress test + task manager

My current set up runs the nividia at 90% and Intel at 30% when stress testing Getting almost 200fps on plasma 1m particle . Without being plugged in to external or being overclocked.

Running Doom 2016(all I had at the momment) off another m.2 ssd from my steam library, was hitting 60-77fps.

To answer you, Theoretically a 4k hdmi dummy plug should enable the GPU in whatever application your running on. Wish i could be more help!

First I thought it may be because of the drivers. But now I see they're not the problem...
 
Associate
OP
Joined
22 Feb 2019
Posts
8
I use an i7 7700k, 24gb RAM, and 3 samsung SSDs . 1x m.2 nvme, 1x m.2 and 1x 2.5" sata 6gb/s , on a GE63 7RF MSI laptop, 1080p only tho. But even extending to a 4k monitor I dont have performance issues with disable or enabled Intel graphics. Unless I'm running element 3d in after effects for renders, I'll have to turn off Intel graphics.

My Intel 630 graphics is a 24.20.100.6286
Nividia 419.67 for my gtx1070

Running all nividia control, and win 10 64 bit display settings to high graphics, and power set to high performance. Even selected the programs in the windows display/graphic settings, that I want to use the highest settings for my nvidia card And have 8gb dedicated to memory, nvidia cuda enabled.

I run msi afterburner/rivatuner to overclock, and msi kombustor 3 / gpushark v13 to monitor and stress test + task manager

My current set up runs the nividia at 90% and Intel at 30% when stress testing Getting almost 200fps on plasma 1m particle . Without being plugged in to external or being overclocked.

Running Doom 2016(all I had at the momment) off another m.2 ssd from my steam library, was hitting 60-77fps.

To answer you, Theoretically a 4k hdmi dummy plug should enable the GPU in whatever application your running on. Wish i could be more help!

Both of my GPU's work all the time, but Intel's load is 80-90% when playing games and Nvidia's is 20-30%. Whatever I do, I can't change that.
I did all the things you did in various options....
 
Top Bottom