Google Earth VR not working on Vive anymore

Soldato
Joined
29 May 2007
Posts
4,694
Location
Dublin
I haven’t played it in a while but it’s not working now (it worked fine last time I used it, months ago).

Google Earth VR does load up and it seems to be working fine on the mirror to my monitor and it is tracking on the monitor when I move the headset but it does not display anything on the Vive headset – it’s just black everywhere (apart from chaperone bounds). Even the loading and ‘building world’ that shows on the monitor does not appear on the headset. All my other apps are working fine on the headset.

I’ve tried tweaking the mirror settings and updating gpu drivers etc. but it’s not displaying on the headset (in Google Earth VR only). I have also updated steam, Steam VR and the firmware for controllers etc. but Google Earth still does not display on the headset.

Anyone know how to fix this?
 
Soldato
Joined
14 Sep 2008
Posts
3,635
Location
Nottingham
Wireless?

Ill spin it up later and check myself, but that's the only reference I can find with your exact issue. Could be a drive issue, there's a post in the steam forum saying try an older driver 18.5.1.
 
Soldato
Joined
29 May 2007
Posts
4,694
Location
Dublin
No still wired.

I updated to the most recent AMD drivers. OK I can try an older driver.

It's a weird issue, it's obviously working on the mirror but just not displaying on Vive for some reason :confused:
 
Soldato
Joined
14 Sep 2008
Posts
3,635
Location
Nottingham
Worked fine when I tried it last night, Nvidia card though. I've seen a few people posting AMD issues on Reddit, hopefully the roll back works. Google will no doubt fix any issues, but might be slow in doing so.
 
Top Bottom