1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! Installing XP on Asus P5N32-SLI Deluxe

Discussion in 'Motherboards' started by Flanno, 21 May 2006.

  1. Flanno

    Mobster

    Joined: 18 Jun 2005

    Posts: 3,434

    Hi,

    I am having a problem installing XP with my SATA drive, this problem is really making me bang my head against a wall. Not a noob to this sort of thing, but this is my first P4 mobo.

    I just cant seem to get past trying to install the drivers, here is exactly whats going on.

    Turn on computer
    Press any key to Boot from CD...

    Press F6 to install any third part SCSI or RAID drivers (i press F6)
    Setup is loading files........ (loads for about 1 minute)

    Press S to specify additional Device
    Insert floppy > Press enter
    screen loads with 2 options
    -NVIDIA RAID Class Driver
    -NVIDIA NForce Storage Controller

    I press enter choose the first option NVIDIA RAID Class Driver
    it starts loading nvraid.sys (takes about 5 seconds)

    then the screen goes to:
    Setup will load support for the following mass storage devices
    - NVIDIA RAID Class Driver

    To specify additional press S, so i do so and select the NVIDIA NForce Storage Controller
    it loads nvatabus.sys (takes about 5 seconds)
    then it goes back to the screen saying
    setup will load support for the following devices
    - NVIDIA RAID Class Driver
    - NVIDIA Storage Controller
    Press enter to continue
    Setup is loading files...... (Takes about 1 minute)
    Setup is starting windows
    Screen gives me the usual 3 options of installing windows, recovery or exit.
    i choose install window xp.

    loads saying
    setup did not find any hard disk drives installed on your computer. Make sure any hard disk drives are powered on and properly connected to your computer and that any disk related hardware configuration is correct. this may involve running a maufacture-supplied diagnostic or setup program
    setup cannot continue press F3 to quit.

    I also tried the raid class driver and the storage controller separately. Also, my bios has the sata ports turned on and nvidia raid turned on.

    Finally I decided to try the Silicon Image port instead, so connected my drive to the sil image port, and enabled sata2 for that port in the bios, and repeated the steps above except with the sil driver. Same result. Can't get Xp installed with the sil ports either.

    If I installed XP and the nvidia chipset drivers onto an ide disk, and then ghosted that onto my sata drive - would it work ? Last thing I can think of.
     
    Last edited: 21 May 2006
  2. kadams1010

    Associate

    Joined: 18 Feb 2005

    Posts: 57

    Location: Hereford

    sata

    have you set your drive boot priorty
     
  3. Flanno

    Mobster

    Joined: 18 Jun 2005

    Posts: 3,434

    I sussed it. My dvdrw is a sata one, and the only way to enable sata boot device in my bios is to turn on nvraid. When you do that XP is expecting to find a configured raid array after you hit F6 and load the drivers from the floppy. As I only have 1 drive it can't see it. The solution is to disable nvraid and xp emulated the sata drive as a pata drive. You don't even need a driver diskette. The problem though is by turning off nvraid the sata dvdrw is also turned off. Luckily I had a standard ide dvdrw lying around. Problem now solved and build continues.

    Lesson is, that sata dvdrw's can not be used to install xp on nforce4 mobos unless you are using a raid array. pants.
     
  4. kleox64

    Gangster

    Joined: 28 Jul 2005

    Posts: 403

    another reason to stick with at least one IDE drive, I gave up trying to boot my XP CD on my Plextor SATA drive. I tried the SI3132 controller and also the nvidia, there is no solution. You need a driver even to see the drive, you cant load the driver because you cant boot the CD? is that the right way round?
     
  5. Flanno

    Mobster

    Joined: 18 Jun 2005

    Posts: 3,434

    I was able to boot windows off the plextor sata dvdrw no problem, from both the sili and the nv controller. problem was with either of these enabled xp would not see any of my hard drives as it was expecting a raid array. back to ide.