Help Me Get 5.1 In games. XF-I Titanium

Associate
Joined
15 Oct 2007
Posts
2,124
Location
Bedfordshire, UK.
Have recently gotten a, Creative Sound Blaster X-Fi Titanium 7.1 Sound Card. I have it attached to my Sony A/V Amp via a Digital Optical cable, but im unable to get it to select 5.1 set, just 2 speakers. Can someone tell me how to enable 5.1 with this card through my amp? There seems to be a few options, one is SPDIF out and "What U Hear" S/PDIF, but for both options in there own tabs i only see 2 channel modes, no mention of 5.1 channels. Any help??
 
Soldato
Joined
16 Jan 2003
Posts
9,959
Location
Nottingham
Do you have dolby digital live enabled in the driver control panel?

dolbyinstall_017.jpg
 
Associate
OP
Joined
15 Oct 2007
Posts
2,124
Location
Bedfordshire, UK.
No its turned off, theres also a DTS option aswel, but when i click on either it says that it was unsuccessful in enabling it, try later or reinstall application. Im just going to uninstall all the programs and reinstal with the supplied cd
 
Associate
OP
Joined
15 Oct 2007
Posts
2,124
Location
Bedfordshire, UK.
Ok completely removed all creative components. And installed the latest drives and progs using the creative auto updater. I have now managed to get my amp to switch to 5.1 mode, but where you have DD Live, i only have DTS connect, any ideas??
 
Soldato
Joined
16 Jan 2003
Posts
9,959
Location
Nottingham
Ok completely removed all creative components. And installed the latest drives and progs using the creative auto updater. I have now managed to get my amp to switch to 5.1 mode, but where you have DD Live, i only have DTS connect, any ideas??

It's not my screenshot it's from the creative knowledge base, are you on the latest drivers? The X-Fi Titanium should have DD live by default, only the older cards had to purchase it seperateely.
 
Top Bottom