High FPS But Not Smooth.

Associate
Joined
21 Apr 2013
Posts
1,350
Hi guys, had this problem for a while now and it's driving me crazy.
I have high FPS in most games but even at high FPS the games don't feel smooth, it's hard to explain really. I may have 120FPS but it feels more like 40-50, especially when looking around. It's sort of like screen tearing but not really and I wouldn't really class them as stutters either, it's just not... smooth, feels choppy. I don't know how else to describe it. Sorry I can't be more precise.

I've recently upgraded my PC to a 5600x and 3070 graphics card and the problems still persist.

Rest of my specs are:

B550 A-Pro Motherboard
16gb 3200mhz Corsair Vengeance DDR4 RAM
Corsair RM750 Power Supply
1TB 970 EVO M.2 Drive.

I even have a G-SYNC monitor, it's a DELL S2716DG 144hz. I have noticed that if the FPS goes higher than 144hz it goes really choppy which is weird.

Things I have tried:

Updated the BIOS.
Put V-SYNC on in Nvidia CP and off in the actual game.
Downloaded RivaTuner to cap FPS so it never dips below a certain number.
Lowered my monitor refresh rate to 120hz - funnily this seemed to have a positive effect but if it dips below 120 it starts to feel choppy again - this was alongside VSYNC being on in Nvidia CP by the way.
Checked RAM is running on XMP.
Monitored frametime using RivaTuner - the spikes are definitely correlating with choppiness on the screen.

So yeah, I'm at a loss and it's really getting me down that I've spent all this money and it's not smooth. Really frustrating.

Anyone have any suggestions?

Appreciate any help, cheers.
 
Associate
Joined
17 Jan 2022
Posts
5
Location
United Kingdong - City of Lodnon
As far as I know, you have to enable your 144hz option. When I bought my monitor, its a Samsung 144hz, I do not remember the exact model. I had to enable 144 hz option, firstly I had to download the drivers and then to enable 144hz option. You can easily find how to do it on google, hope this is going to help you
 

bJN

bJN

Soldato
Joined
23 Nov 2009
Posts
3,670
Location
Norwich
What games are you having issues with? I don't recall having vsync enabled on Nvidia control panel, just enabled GSync for full screen and borderless window modes for all game applications. There is an option to show an indicator that GSync is functioning too.

I was having similar feelings with a select few games, I've since doubled my RAM to 32GB and it's alleviated the issues I was having. Not saying that is the case here, but just may be useful depending on what games you were having issues with - mine were most noticeably Escape from Tarkov and BF2042.
 
Associate
Joined
21 Apr 2013
Posts
1,350
What games are you having issues with? I don't recall having vsync enabled on Nvidia control panel, just enabled GSync for full screen and borderless window modes for all game applications. There is an option to show an indicator that GSync is functioning too.

I was having similar feelings with a select few games, I've since doubled my RAM to 32GB and it's alleviated the issues I was having. Not saying that is the case here, but just may be useful depending on what games you were having issues with - mine were most noticeably Escape from Tarkov and BF2042.

I have had Vsync off mostly, read up that turning it on could fix it and did see a small improvement to be fair on Warzone so have left it. GSYNC is definitely enabled enabled in NVidia, have triple checked many times. I have noticed that sometimes I get a notification from Windows saying it's activated and sometimes not though.

Interesting about the RAM but really don't want to spend any more than I have, feel like my set up shouldn't be having problems really.

The games I am experiencing it in is Tarkov (like yourself), DayZ, Warzone and Halo Infinite. Haven't tried any other games yet but it's 4/4 so far so it can't just be a game problem.
 
Associate
Joined
21 Apr 2013
Posts
1,350
so it is a proper fps drop.
Check if CPU usage looks different in these spikes
It is a proper drop but not like a massive one. For example - the FPS going from 90 to 78 or something, I can feel it. It's not like it's dipping a huge amount. I seem to be able to notice every little change in FPS which is ruining the experience. Will check CPU usage next time I'm on.
 
Associate
Joined
8 Oct 2020
Posts
1,122
Are you running the games in fullscreen or windowed/borderless windowed? Try changing that.

I have the DELL S2721DGFA connected via DP and response time (on the monitor) set to "fast". Check a couple reviews to figure out what the best option for you is. Hardware Unboxed usually do full reviews and optimised settings.

On the software side, I have GSYNC and Low Latency mode enabled in CP. I didn't set VSYNC or a frame cap in CP, which is apparently best practice, but this works better for me.

As a last resort, maybe check the cable you're using.
 
Associate
Joined
11 Dec 2016
Posts
1,548
Location
Oxford
It is a proper drop but not like a massive one. For example - the FPS going from 90 to 78 or something, I can feel it. It's not like it's dipping a huge amount. I seem to be able to notice every little change in FPS which is ruining the experience. Will check CPU usage next time I'm on.
You feel it through a less responsive mouse/camera movement.
So it will have to do with CPU
 
Associate
Joined
21 Apr 2013
Posts
1,350
Also in the games you are playing what sort of frametimes are you experiencing.

Have you checked Gsync is working correctly, by using something like https://www.nvidia.com.tr/coolstuff/demos#!/g-sync

I have only played around with it briefly today. Just got the overlay up and noticed when a big spike happened I'd see a drop in frames in game. Do I need to look in to that further?

What will that demo do exactly you linked mate?
 
Soldato
Joined
15 Oct 2019
Posts
8,384
Location
Uk
Have you tried locking the GPU core clock in afterburner at a set frequency like 1900mhz @ 0.950mv etc?
 
Associate
Joined
21 Apr 2013
Posts
1,350
Are you running the games in fullscreen or windowed/borderless windowed? Try changing that.

I have the DELL S2721DGFA connected via DP and response time (on the monitor) set to "fast". Check a couple reviews to figure out what the best option for you is. Hardware Unboxed usually do full reviews and optimised settings.

On the software side, I have GSYNC and Low Latency mode enabled in CP. I didn't set VSYNC or a frame cap in CP, which is apparently best practice, but this works better for me.

As a last resort, maybe check the cable you're using.

Full screen. Read that is the best way? Also got my monitor set to Fast in the monitor settings. I believe I have Low Latency enabled also but will double check.

Going to try changing out the DP cable as well.
 
Associate
Joined
21 Apr 2013
Posts
1,350
Have you tried locking the GPU core clock in afterburner at a set frequency like 1900mhz @ 0.950mv etc?
I haven't done anything like that. Get a bit scared with messing around with that side of things truth be told!

My 1080ti had exactly the same issue so I don't think it's the card.
 
Associate
Joined
11 Dec 2016
Posts
1,548
Location
Oxford
5600X is a very capable CPU, should be more than enough.

So something else is hitting it. Some background process or a bad setting
 
Soldato
Joined
15 Oct 2019
Posts
8,384
Location
Uk
I haven't done anything like that. Get a bit scared with messing around with that side of things truth be told!

My 1080ti had exactly the same issue so I don't think it's the card.
It's safe to do as your actually lowering the cards voltage, just press CTRL + F on msi afterburner to bring up the voltage curve then on the main msi screen set the core clock to -500 and hit apply which should bring the curve right down then back on the voltage / frequency screen find the point at 0.950mv and drag it up to 1900mhz and hit apply which should flatten the curve.
 

bJN

bJN

Soldato
Joined
23 Nov 2009
Posts
3,670
Location
Norwich
May be worth having Afterburner running in the background with the data graphs, play a game for a bit and let it happen, tab out and take a look. I have mine set for things like FPS, frametime, CPU usage, GPU usage, RAM usage, VRAM usage, clock speeds, memory speeds. It all helps to get an idea of what may be causing it. Is it a Founders Edition 3070? I've found mine was hitting power limits quite easily and that was also lending itself to microstutters ingame.
 
Associate
Joined
21 Apr 2013
Posts
1,350
It's safe to do as your actually lowering the cards voltage, just press CTRL + F on msi afterburner to bring up the voltage curve then on the main msi screen set the core clock to -500 and hit apply which should bring the curve right down then back on the voltage / frequency screen find the point at 0.950mv and drag it up to 1900mhz and hit apply which should flatten the curve.

What will this do?

May be worth having Afterburner running in the background with the data graphs, play a game for a bit and let it happen, tab out and take a look. I have mine set for things like FPS, frametime, CPU usage, GPU usage, RAM usage, VRAM usage, clock speeds, memory speeds. It all helps to get an idea of what may be causing it. Is it a Founders Edition 3070? I've found mine was hitting power limits quite easily and that was also lending itself to microstutters ingame.

Yeah I can do that and see what I find.

I do have the 3070 founders edition. Really? That doesn't fill me with confidence haha. I did have this issue with my old card though so don't think it's card related but could be wrong.
 
Top Bottom