How crap is the Asus site?

Soldato
Joined
3 Apr 2007
Posts
7,237
Location
South of the Watford Gap!
Jesus, when I had a Gigabyte mobo I thought their site was rubbish but the Asus site beats it by a slow country mile.

It's just taken me half an hour to eventually get to what I want to download and now that I've got there it's going to take 12.5 hours to download a 302mb file. Also what's the point of having a download link from China if it does nothing?

Where is that AsusRep rep guy who posted here a few days ago? If you're reading this you also need to know that there are other screen resolutions beyond 1024 * 768 :mad:

Any rant over, I'm over to calm down in the Motors section :D

EDIT: Hmm, rant over, the DLM links now seem to work and that's only going to take 15 mins to hopefully bring the file down.
 
Last edited:
Soldato
Joined
27 Feb 2006
Posts
3,019
Location
East Sussex
Hi, I have done alot of downloading from the Asus site in the past and now just yesterday and I found it has improved greatly. However, like NV, Realtek etc, who are just as bad if not worse, it will always suffer because of the huge number of people wanting to access it...
Chris
 
Soldato
Joined
2 Sep 2006
Posts
13,483
Location
Portland, OR
It is miles better than it used to be although the site does still get swamped on occasion.

Last year I remember downloading drivers at 1-2kb/sec though :(
 
Soldato
Joined
15 Nov 2007
Posts
13,014
Location
Enfield
It's always been slow and carp for me. They redid the front consumer end but the support section is still slow.
 
Associate
Joined
2 Aug 2006
Posts
406
Location
Jersey Channel Islands
It's got better used to be much worse. You would have thought that they would have a better website for such a big company though. I haven't found it too slow lately, but last year it went offline quite a lot :(.
 
Associate
Joined
29 Jul 2009
Posts
294
Yep, slow as **** for me aswell. Just happy I don't have to use it very often and tend to keep my Mobo Dl's backed up.
 
Associate
Joined
26 Jan 2009
Posts
1,462
Location
Salisbury, Wilts
Was only slow downloading latest BIOS from the update section on the mobo disk. The first reccomendation from where to download had rediculous d/l times. Switched to the next one and it took 2 mins at most.
 
Associate
Joined
2 Oct 2009
Posts
462
Location
United Kingdom
What are you trying to download? Is your bandwidth being taken up by something else?

Getting ~1mb here at the moment...
 
Soldato
OP
Joined
3 Apr 2007
Posts
7,237
Location
South of the Watford Gap!
To the guys getting good download speeds could you post a link from where you download?

Using the DLM link sorted it for me in the end.

I was trying to download the latest version of Express Gate SSD by the way.
 
Associate
Joined
2 Oct 2009
Posts
462
Location
United Kingdom
The website was updated recently to become more user friendly, though there is still a lot of work that needs to be done in other areas. (Bringing the support site up to date).

I always find the DLM links work fastest for me.
 

AMG

AMG

Soldato
Joined
18 Aug 2008
Posts
4,700
Location
lincs, spalding
the asus website is sometimes slow for me...

gigabytes website partly crashes firefox with the damm scripts it has :(
 
Soldato
Joined
14 Sep 2009
Posts
8,999
Location
Northumberland
Both Asus and Gigabyte are fine for me.

I use Google Chrome. I hate Internet Explorer, too slow, and I just don't seem to be able to use firefox as easily. And never us safari.

Well, the safari for my phones, but then again I have no choice :)
 
Top Bottom