Installing a Corsair H80 on a Gigabyte X79-UD5. HELP!

Associate
Joined
13 Jun 2007
Posts
946
Location
Dorset
I am trying to in stall a Corsair H80 on a Gigabyte X79-UD5.

On the MB the holes are sealed. Corsair supply two types of bolts.

Ones that goes through the MB to connect to the Back Plate and ones that connect just to the top plate.

It looks as though the MB is designed not to use the Back Plate.

Is the Back plate absolutely necessary for the H80. It will mean I will need to drill/ break the holes.
 
Associate
OP
Joined
13 Jun 2007
Posts
946
Location
Dorset
How long have you had your H80 for? If you bought it recently it should come supplied with socket 2011 back plate.

Just bought it. I have the back Plate that is not the problem.

The problem is that the holes on this MB are sealed which means you either have to break the seals to use the B.Plate or do not use the back plate.

Corsair supply bolts for both ways.
 
Soldato
Joined
25 Sep 2009
Posts
8,417
Location
Billericay, UK
Just bought it. I have the back Plate that is not the problem.

The problem is that the holes on this MB are sealed which means you either have to break the seals to use the B.Plate or do not use the back plate.

Corsair supply bolts for both ways.

Can you take a photo and show us? Sounds like they messed up when manufacturing the board.
 
Associate
OP
Joined
13 Jun 2007
Posts
946
Location
Dorset
Sounds like they messed up when manufacturing the board.


You would think that but then why would corsair included and extra set of bolts that do not use the back plate.


Can you take a photo and show us?

Sorry I could not wait, I got a screwdriver and pushed through the holes. I was then able to put the back plate on in the normal way.

All this guess work could be eliminated if manufacturers included descent instructions.
 
Top Bottom