Linx Tablet drivers and BIOS downloads

Associate
Joined
18 Dec 2010
Posts
1,436
Location
W. Yorkshire
Hi guys,

A few people on here have bought the new Linx 7", 8" and 10" windows tablets that have just come out. They're really good value.

I've had a few issues with mine, and ended up reinstalling windows only to find a lot of missing drivers. I emailed their customer services and they've given me links to updated drivers and BIOS files.

I hope this will be useful to a few people on here:


7” updates
https://www.dropbox.com/l/zpGVxajqWyXsohu4UewERr

8” updates
https://www.dropbox.com/l/6ErTBteGPxeN9voDvbjthq

10.1” updates
https://www.dropbox.com/l/uK6NX18O4RPOVEXuehkrgp
 
Man of Honour
Joined
13 Oct 2006
Posts
91,820
Thanks for that.

You should be able to pull most of the drivers through Windows update, the rest are fairly generic Intel, Realtek, etc. devices that can be grabbed from the respective web sites.

The Kionix sensor stuff might be a bit harder to find on the web.
 
Associate
OP
Joined
18 Dec 2010
Posts
1,436
Location
W. Yorkshire
Thanks for that.

You should be able to pull most of the drivers through Windows update, the rest are fairly generic Intel, Realtek, etc. devices that can be grabbed from the respective web sites.

The Kionix sensor stuff might be a bit harder to find on the web.

After I reinstalled windows I had a shed load of unknown devices, including the wifi and the touchscreen. Even after plugging an old Wifi dongle in, windows didn't automatically find some of these drivers.
 
Associate
Joined
16 Oct 2008
Posts
413
Hi guys,

A few people on here have bought the new Linx 7", 8" and 10" windows tablets that have just come out. They're really good value.

I've had a few issues with mine, and ended up reinstalling windows only to find a lot of missing drivers. I emailed their customer services and they've given me links to updated drivers and BIOS files.

I hope this will be useful to a few people on here:


7” updates
https://www.dropbox.com/l/zpGVxajqWyXsohu4UewERr

8” updates
https://www.dropbox.com/l/6ErTBteGPxeN9voDvbjthq

10.1” updates
https://www.dropbox.com/l/uK6NX18O4RPOVEXuehkrgp

Very handy, I only just flattened my Linx 7 to do a clean install of windows 8.1 pro and have a few driver issues so these could be a life saver!

Any idea what's changed regarding the bios update?
 
Associate
Joined
8 Dec 2014
Posts
2
i have just formatted my linx8 with pro 8.1, and the drivers you provided this helped a lot thanks.

Did anyone take a backup of the recovery partition? i wonted to play around with the wimboot but i formatted before hand doh!

looking at making more of a customized image.

cheers again!
 
Associate
Joined
16 Oct 2008
Posts
413
i have just formatted my linx8 with pro 8.1, and the drivers you provided this helped a lot thanks.

Did anyone take a backup of the recovery partition? i wonted to play around with the wimboot but i formatted before hand doh!

looking at making more of a customized image.

cheers again!

I do have a backup of the recovery partition which was created when I performed a usb recovery drive before force deleting the damn thing which is why I ended up doing a fresh install in the first place (well that and I wanted remote desktop which isn't available with the crippled bing version of 8.1). If I can work out a useful way of extracting and posting the recovery partition I will let you know. The drivers worked like a charm btw so this thread has saved me a shedload of work! (I tried other drivers previously but the screen orientation was arse about elbow). Just finishing up a few install issues and I'll see what can be done regarding the backed up recovery partition.
 
Last edited:
Soldato
Joined
14 Apr 2009
Posts
4,821
Location
Cheshire
any one suffering the wifi dropping on the 10"? Will not reconnect.

I rebooted yesterday to solve the problem, today I disabled the realtek wifi adapter and re-enabled it from device manager...
 
Associate
Joined
19 May 2007
Posts
1,228
Location
The Now
The wifi on my 10 is fine even with low signal.

Edit: The wifi turns off when the screen powers off, would be nice if there was a way to disable that!
 
Last edited:
Associate
Joined
15 Dec 2014
Posts
4
Thank you so much for the drivers! Couldn't stand W8.1 with Bing!!
Everything works perfectly, except for the "Windows Key/Button" on the bezel. Anyone know how to get this working on Linx8.

Thanks again.
 
Associate
Joined
28 Mar 2006
Posts
1,202
Location
South Glos
Thanks so much for this! I've been spending ages trying to locate drivers for the 10" version we have at work and depending on whether we could actually find the drivers would decide if we buy another load. Looking like we will now!

I don't suppose anyone who has updated their bios would be able to check to see if the new version has added PXE boot support? I'm assuming not but would be nice to know for sure.

TIA chaps :)
 
Associate
Joined
8 Apr 2009
Posts
40
I'm glad to see a forum where people actually have these devices as I'm a little stuck...

I bought a Linx 10 and I'm not sure how but Windows screwed up on mine so decided to re-install it... I'd already made a recovery USB stick (using the built in tool) and removed the recovery partition to increase available space.

When I try and boot from USB I get a blue screen asking for language selection (US is the only available english language) so I select that, then I get a choice of what I want to boot from so I select UEFI Sandisk (my USB drive) but it just goes in a loop from there on in, it appears to boot from the stick as the blue light flashes rapidly but then takes me back to the same boot menu.. .anyone have a clue as to what I am doing wrong or how I can get Windows re-installed? :(

Is this something to do with secure boot? I know little of it.

Thank you for any help.

R.
 
Associate
Joined
15 Dec 2014
Posts
4
Hi Radial,

I had the same problem when I started trying to reinstall Windows.
Try this:

Select US English in the language selection.
Then rather than selecting to boot from USB, go to "Troubleshoot"
Now Select "Reset Your PC"
Then following the prompts.
That should do it!

Best Wishes.
 
Associate
Joined
3 Jun 2007
Posts
2,277
Location
Essex
Guys those of you who installed full fat 8.1 pro is it 64bit version or 32bit?

I noticed the 8.1 the 8 inch comes with is 32bit and I have a spare 8.1 pro 64bit key at home so wondered if it was worth installing that..

Just to Add according to the Intel website the CPU these use do have 64bit extensions
 
Last edited:
Associate
Joined
8 Apr 2009
Posts
40
Well that went horribly wrong :(

It got to the point where it was completely unbootable, it refused to boot from my recovery drive and just looped from BIOS to a Blue screen telling me something had gone wrong and I needed to use a recovery drive :(

I took it back to Argos today, they refunded me no questions asked so think I might get a Dell Venue from the Outlet instead, prices are reasonable.
 
Associate
Joined
15 Dec 2014
Posts
4
Hi,

The bios will not allow you to install 64-Bit OS yet.
I have given up and gone back to the original OS as Windows 8.1 Pro was using far too much space (I was down to 9gb remaining after doing Windows Updates) despite deleting temp files etc.

Best Wishes.
 
Back
Top Bottom