Associate
Joined
11 Dec 2020
Posts
3
Hi all,

Just trying to complete my first build and all has gone well apart from that the GPU is not showing up in the bios under pci-ex16 slot.

I can plug a monitor in via the I/O area directly on to the motherboard but nothing when I plug it into any of the video inputs on the gpu.

The gpu lights up and both fans spin.


I have a gigabyte z490 UD AC mb and a gigabyte GeForce GTX 1650 4 GB GDDR5 gpu.

I’ve tried plugging the gpu into the pcie slot underneath but then the machine won’t even boot... i went ahead and installed windows to see if there was anything noticeable but also nothing.

Any ideas?
 
Soldato
Joined
7 Dec 2010
Posts
6,170
Location
Leeds
You may need to initialise the PCIe GPU (GTX) as first video device in the BIOS, seems you have the motherboard and cpu video out set as default, that's why you get video from the motherboard. Check for a setting that picks the GTX as the first video device not the IGPU (intergrated graphics).
 
Associate
OP
Joined
11 Dec 2020
Posts
3
Thanks.

So in the bios the initial display output is set to be the PCIe slot one already.

And also in the bios settings where it lists dram, sata, m.2. And PCIe status all are as they should be except the PCIe where it says N/A.

Is this likely to be a comparability issue? Seems unlikely to me. What about an out of date bios or firmware or something?
 
Soldato
Joined
7 Dec 2010
Posts
6,170
Location
Leeds
Thanks.

So in the bios the initial display output is set to be the PCIe slot one already.

And also in the bios settings where it lists dram, sata, m.2. And PCIe status all are as they should be except the PCIe where it says N/A.

Is this likely to be a comparability issue? Seems unlikely to me. What about an out of date bios or firmware or something?


Well I would try updating your motherboard BIOS first then. After that clicking default settings and see if it shows.
 
Associate
OP
Joined
11 Dec 2020
Posts
3
Thanks all.

I managed to download new bios and install it and that immediately rectified the issue.
 
Top Bottom