MSI B450 Gaming Pro Carbon AC - no POST after BIOS flashback

Soldato
Joined
5 Feb 2006
Posts
3,524
can some one confirm please if I just put on the ISO file onto the USB or do I need to 'unpack' the contents onto the usb ?
 
Soldato
Joined
5 Feb 2006
Posts
3,524
downloaded it from microsoft's website

As a side note, here's my current problem. PC starts turning on. If I try and get into the BIOS it is absolutely squiffed and looks like this https://imgur.com/QhZQkK9 and then turns all chinesey

Trying to F11 it looks like this https://imgur.com/kiPneOb presumably there is a menu there and I want to select my usb stick but I can't see anything. The mouse works though .... so there's that
 
Soldato
Joined
5 Feb 2006
Posts
3,524
i did wonder, just because ...

that all seems to be a touch relevant as now after posting 50 times in a row it seems it won't get past the ram ?? light, second one down. Looks like a reflash tomorrow
 
Associate
Joined
22 Jul 2010
Posts
257
I have a different mobo (b450m mortar) I have no components connected just CPU when I do the flash the led strip at the back of the board comes on and so does the CPU debug light - my flash back led flashes for 5 mins or so then everything turns off and after a second or two the CPU debug light comes back on.

I'm a little hesitant to start putting everything together at this point I have no clue why that CPU debug light is on and ofc MSI is next to useless for explaining what these debug lights actually mean.

Has anyone experienced something similar?
 
Soldato
Joined
18 Oct 2002
Posts
11,767
Location
West Midlands
Well given yesterdays adventure helping someone I though was pretty good with computers out, I guess anything is possible.

Brand new 3700X, brand new B450 Tomahawk, says he can't figure out what is wrong and why the system isn't working. So I got him to show me step-by-step what he was doing, and it seemed fine, nothing installed on the board, just the 8-pin and 24-power plugged in and even did it on the the bench rather than in a case. Add's components after the flashing and nothing, just red a light.

So I asked him which BIOS he was using, he got his laptop and pulled up the file, it was also correct. Grabbed the USB stick plugged that in, file was named MSI.ROM, so that was good. I said just for good measure re-download the file, format the USB drive and try again, as he was doing that he copied the file to the USB stick then wen to re-name it, but he DIDN'T EXTRACT it from the .zip container.

I didn't know whether to laugh or cry after he told me he this was how he had tried it several times. Such a simple silly mistake as he was too busy looking forward to a new system rather than read the instructions that he though he knew. As always RTFM what a plank. :p

Oh yeah, it worked fine once he'd done it properly, no issues with re-boots or cold boots and he now owes me several rounds at the pub. Ha. :D
 
Associate
Joined
15 Apr 2019
Posts
1,140
Well given yesterdays adventure helping someone I though was pretty good with computers out, I guess anything is possible.

Brand new 3700X, brand new B450 Tomahawk, says he can't figure out what is wrong and why the system isn't working. So I got him to show me step-by-step what he was doing, and it seemed fine, nothing installed on the board, just the 8-pin and 24-power plugged in and even did it on the the bench rather than in a case. Add's components after the flashing and nothing, just red a light.

So I asked him which BIOS he was using, he got his laptop and pulled up the file, it was also correct. Grabbed the USB stick plugged that in, file was named MSI.ROM, so that was good. I said just for good measure re-download the file, format the USB drive and try again, as he was doing that he copied the file to the USB stick then wen to re-name it, but he DIDN'T EXTRACT it from the .zip container.

I didn't know whether to laugh or cry after he told me he this was how he had tried it several times. Such a simple silly mistake as he was too busy looking forward to a new system rather than read the instructions that he though he knew. As always RTFM what a plank. :p

Oh yeah, it worked fine once he'd done it properly, no issues with re-boots or cold boots and he now owes me several rounds at the pub. Ha. :D
Lol, anything really is possible.

On a separate note, that's another successful B450 Tomahawk + 3rd gen Ryzen CPU paired together. I wonder what is causing all the issues people seem to be having.
 
Soldato
Joined
19 Apr 2003
Posts
13,474
but he DIDN'T EXTRACT it from the .zip container.
As always RTFM what a plank. :p
Useful post.

It's errors like this that are muddying the waters of the true scope of the problem of the B450. Obviously there are issues with the juvenile BIOS - some of the problems are too erratic to be user error in nature.

I've done a couple of 'virtual' flashbacks and been really meticulous in my explanation of the process - but errors were still made as the user had either skipped ahead a process (unaware) or assumed too much (again unintentionally) - one even described what they were doing but didn't actually do it (in this instance different sized pen drive.). And again, like in your example, they weren't completely component illiterate - which may have been part of the problem as, like in your example, they were eager to jump to next stage. Add these errors to the complete novices updating (who conversely may take more care/prep due to being terrified) and you've probably got quite a healthy curve of user error.

*Again, i'm not disputing that there's issues with the b450s/16MB eeprom BIOS for anyone scanning this post.

MSI have put a few guides together but need to pull them all together and compile the definitive 'IDIOTS GUIDE' to flashing the B450. Not a video, or a series of flashy pics - just a good old fashioned step-by-step process on their main website.

@Journey - have you had ANY boards fail on you using these boards? I've helped 2 friends of friends over discord both initially had problems and my friends kindly :/ offered my services. Both were easily fixed, and both were user error - although the trying of a smaller USB stick was lack of experience. And in each case if i could have reached through the ether and smacked them round the head with their eventual working board, i would have!
 
Last edited:
Soldato
Joined
18 Oct 2002
Posts
11,767
Location
West Midlands
It's errors like this that are muddying the waters of the true scope of the problem of the B450.

Exactly this, I know there will be legitimate issues for a good number of people, but I found that is seems to be the one off builders, who buy and build every 5 years, and spend the rest of their life on Reddit or a forum that seem to be making the problem look bigger than it actually is. No real experience and as soon as something goes wrong it is straight to the keyboard to vent/rant rather than taking a methodical logical approach.


@Journey - have you had ANY boards fail on you using these boards? I've helped 2 friends of friends over discord both initially had problems and my friends kindly :/ offered my services. Both were easily fixed, and both most user error - although the trying of a smaller USB stick was lack of experience. And in each case if i could would have reached through the ether and smacked them round the head with their eventual working board, i would have!

I'm yet to come across a single board I could not get working, but my sample size is only 7x MSI boards, 3x ASRock boards, and 2x Asus boards, I've not had anyone with a Gigabyte board as of yet. The worst thing I've had happen is the Asus B450-F Strix Gaming kill a 3900X, stone dead. AMD have shipped a replacement but I've not had any form of fault report as of yet, the board still worked fine with the 2700 (non-X) that was in it before hand.
 
Top