MSI's X570 Tomahawk May Become Go-To OC Board??

Associate
Joined
13 Jun 2012
Posts
272
Are there any other notable benefits rolled in with agesa 1.2.0.6c than CPU support?

No intention of upgrading CPU's 5800X/5700G, but there have been a lot of AMD CVE's recently...

[edit]

I suppose it comes down to whether those 'performance' improvements are in any way significant for a 5800X or 5700G:

https://wccftech.com/msi-agesa-1-2-...5800x3d-cpu-support-performance-improvements/
the new AGESA 1.2.0.6C BIOS firmware adds a new security patch for AMD Raven Ridge & Picasso APUs while offering support for Vermeer-X CPUs too. It is also stated in the changelog that there are certain performance improvements made over the AGESA 1.2.0.4 and 1.2.0.5 releases.

AGESA 1.2.0.6C:
  • Security Patch for Raven Ridge / Picasso APU.
  • Support Vermeer-X CPU (Ryzen 7 5800X3D).
  • Performance Improvements.
 
Last edited:
Soldato
Joined
26 Feb 2004
Posts
4,548
Location
Hampshire, England.
Hi guys,

I've just noticed that some of my system fans aren't spinning up from cold?

Capture.jpg


My curve is set to 40% speed at 30 degrees, and system temp is never anywhere near that from cold...

No biggy but any ideas?
 
Soldato
Joined
11 Oct 2009
Posts
15,357
Location
Greater London
Pretty much, gets rid of the chipset fan, not that mine ever spins up under daily usage.

Thanks. I have the same board, also noticed the fan doesn't spin apart from boot. Just helping a friend with a new build and he wants to go AMD since the Intels chucks out too much heat for his liking.

Noticed it also has Wi-Fi 6E but I doubt many even have routers/APs that supports that :p.
 
Soldato
Joined
23 Jun 2004
Posts
3,485
Location
blackburn
Ive never installed Dragon Center as Ive heard of all the issues it causes. Is it still a pos and something to avoid or have the issues with it been sorted out over time?
 
Soldato
Joined
5 Nov 2010
Posts
22,635
Anybody else have the bug with this board that if you set CR to 1T then Geardown mode will grey out as Auto and be enabled. i.e. you cannot set 1T and disabled geardown mode?
 
Soldato
Joined
23 Jun 2004
Posts
3,485
Location
blackburn
Anybody else have the bug with this board that if you set CR to 1T then Geardown mode will grey out as Auto and be enabled. i.e. you cannot set 1T and disabled geardown mode?

I have funny quirk with mine where if I set 1T command rate the board doesn't post but if I enable XMP which in turn sets 1T command rate and then change command rate to auto it posts fine and 1T is still enabled.

I havent bothered checking it its fixed with newer bios' though cos its a pain to reset CMOS on this board so I've kept on doing the above.
 
Last edited:
Soldato
Joined
11 Oct 2009
Posts
15,357
Location
Greater London
Huh, just noticed Windows isn't detecting TPM when I upgraded to the 5800X3D. Currently using the stable 1.2.0.6 BIOS, tried turning it off, reboot, then back on, reboot but still nothing. Noticed the BIOS doesn't see it either, says no security device found. Going to try the beta 1.2.0.7 tomorrow to see if that fixes it, it does mention something about the default settings for secure boot, but Windows detects that fine.

EDIT: Decided why not and flashed the BETA BIOS. TPM is now detected. If anyone else is using the 5800X3D with Windows 11 I suggest using this BIOS.
 
Last edited:
Associate
Joined
13 Jun 2012
Posts
272
Download
AMI BIOS7C84v1A1 (Beta version) 2022-05-24 17.95 MB
  • Description:
    - Update to AGESA ComboAm4v2PI 1.2.0.7.
  • - Change the default setting of Secure Boot.

No longer listed as a beta (and lacking the final "1" in the version id):

AMI BIOS7C84v1A 2022-05-31 17.95 MB
  • Description:
    - Update to AGESA ComboAm4v2PI 1.2.0.7.
  • - Change the default setting of Secure Boot.
Update - this has been running running under load and idle for 30+ hours now...
 
Last edited:
Soldato
Joined
26 Feb 2004
Posts
4,548
Location
Hampshire, England.
Anyone experience any system issues with the current build of bios? I'm sure my recent sluggish (occasional bsod) startup problems coincided with me updating...
 
Soldato
Joined
11 Oct 2009
Posts
15,357
Location
Greater London
I'm on the beta version of the current BIOS but no issues here either. I have however noticed it lowered my all core boost on my 5800X3D by about 50MHz odd even with PBO Tuner...
 
Soldato
Joined
13 Mar 2007
Posts
11,620
Location
South Yorkshire
Latest bios version got updated and 're'released yesterday:

AMI BIOS7C84v1B1(Beta version)2022-07-0417.95 MB

Description:
- Update to AGESA ComboAm4v2PI 1.2.0.7.
- Change the default setting of Secure Boot.
 
Top Bottom