1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Nvidia GTX 1050ti keeps failing to install drivers

Discussion in 'Windows & Other Software' started by Halpinator, Aug 5, 2017.

  1. Halpinator

    Associate

    Joined: Aug 5, 2017

    Posts: 2

    When I first got my PC six months ago I installed its drivers without issue. However recently I have tried to install more recent drivers. For some reason it uninstalled my old drivers and then failed to install the new one and I could not find a solution on the internet to fix it. In the end I had to wait and let Windows install and older one by itself. If anyone has a solution to this it would be greatly appreciated.

    My parts are:
    - CPU: Intel i3 6100
    - Motherboard: Asus H110M-R HDMI Motherboard
    - RAM: 8GB DDR4 2400MHz
    - Graphics Card: Nvidia GTX 1050ti 4GB
     
  2. opethdisciple

    Capodecina

    Joined: May 18, 2010

    Posts: 18,763

    Location: London

    Sounds like the issue I had. It's because when you uninstall the graphics drivers, windows kicks in and goes and start installing drivers from the net. At this time you are probably in the process of installing drivers you have downloaded. You end up with conflict and a right mess.

    And your left not being able to install any drivers at ll.

    What I did, was reformated PC with a clean install of windows. I know disconnect my ethernet cable before I install any drivers.
     
  3. Halpinator

    Associate

    Joined: Aug 5, 2017

    Posts: 2

    Ye thats true but is there a way to do it without having to format my pc?