1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Your Help! FPS Drops & Stuttering on High-End PC

Discussion in 'Graphics Cards' started by Knower, Apr 8, 2018.

  1. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    UPDATE 5

    I've already done all the necessary tests in new Windows 10 1803 (17134.1) Build. There are no performance improvements even with new "Ultimate Performance" power plan.

    UEFI Main Settings:
    - BIOS 1301 update
    - "Sync All Cores" at [47]
    - XMP at 3,200 MHz
    - PCIE3_4 and M.2_2 slots at X4 speed
    - Custom fans curve and disabled unnecessary EXT FANS
    - Disabled SpeedShift/SpeedStep, C-states, Spread Spectrum, Fast Boot and ASUS MultiCore Enhancement

    Windows 10 1803 global Google Drive folder with all results: https://drive.google.com/open?id=1VI-D62fRZ2AfNZ2NZqKtFXAEoM5tibdJ

    MSI Afterburner Hardware Monitor games logs: https://drive.google.com/open?id=1z_EPdYovV_swrAm3El-gRJ87RZtrXvq3

    Windows and other settings: https://drive.google.com/open?id=14a6vfGqZhDp6z6V-CFoBdpHR161pXKy8

    All diagnostic info including GPUView Merged.etl trace file, MSINFO32 and Speccy snapshot: https://drive.google.com/open?id=1h3oCMaw5_odOSO1972Tqn6_RwYZz6vy3


    If you can or know how to correctly analyze all the data, please, help me find the culprit of these frametime spikes and stuttering. Thank you a lot!


    UPDATE 4

    I did all the suggestions from HOWIEJC troubleshooting guide, but it wasn't helpful in anyway.

    I did the following actions:
    UEFI:
    - Install 1301 update and cleaned CMOS
    - Customize fans curve and disable unnecessary EXT FANS
    - Disable FastBoot
    - Set X4 speed for PCIE3_3 and M.2_2 slots
    - Set XMP 3,200 MHz
    - Disable TurboBoost, SpeedShift/SpeedStep, C-states, Spread Spectrum and ASUS MultiCore Enhancement
    - Set "Sync All Cores" to [37]

    Windows:
    - Completely reinstall Windows 7 and change to Ultimate SP1 version
    - Install all drivers
    - Disable Windows Update, Defender and Firewall
    - Set High Performance Mode
    - Set Windows Timer Resolution to 0.5ms with TimerTool and did all tests with it been enabled in the tray
    - Disable Core Parking & Frequency Scaling with ParkControl form BitSum
    - Set almost ALL (except of Intel SMBUS A2A3) PCI devices to use MSI instead of traditional IRQ channels - Set mouse polling to 1,000 MHz

    NVIDIA Control Panel:
    - Set Max Pre-Rendered Frames to "1"
    - Set Prefer Max Performance (even tried Optimal Power as you said in some of your posts)
    - Set Threaded Optimization to "ON"
    - Disable G-\VSync and AA

    MSI Afterburner:
    - Completely reinstall it
    - Check and correct all AB settings to have the perfect config

    Games:
    - Do tests with MAXIMUM and MINIMUM possible graphics settings (TLDR: wasn't helpful)
    - Change render quality
    - Change screen resolution to MAX and MIN

    Settings and games logs in Windows 7 Ultimate SP1 with no updates:
    https://drive.google.com/open?id=1DJw9FySD7Hw4sAGckB8cqjWYJLCqyxv9

    Can you help me with any working advice?

    Because I'm completely disappointed about these issues on the TOP ~5K$ RIG. =(
    I really want to know what is the culprit, software or what worse — hardware. And how I can figure out the source of all this c**p?

    P.S.
    1. Have you any similar issue on your PC? If yes, how are you get rid of issues on your rig? Do you removed stuttering completely?
    2. What are the most valuable tweaks for your PC?
    3. Do you notice issues after set UEFI and Windows settings to default?
    4. Do you play and have any issues in PUBG, CS:GO or games that I've tested?
    5. Does Steam (running in the tray) affect games performance?
    6. Is it better to run games without Steam if possible or there are no noticeable changes?

    P.S. 2
    I'll retest games with 43 or 47 CPU multiplier and TurboBoost enabled.

    UPDATE 3:

    BAD NEWS!

    Windows 7 HP SP1 didn't help in anyway. =(

    I did a fresh install of Windows 7 with formatting previous OS drive (C:), then installed all the necessary Win7 (x64) service updates and drivers: GPU, LAN, Audio, Chipset, SATA, NVMe SSD, DirectX & Visual C++. Configured NVIDIA driver to previous Win10 config, reinstalled MSI AB & RTSS and load custom profiles from my backup.

    Also, I've cleared CMOS and reconfigured UEFI with the following "Custom Default" settings:
    - Enabled #1 XMP, Sync All Cores "Auto"
    - Configured fans
    - Change PCIEX4_3 & M.2_2 to X4 speed
    - Disable unnecessary SATA ports, fans, lights and other garbage

    Windows 7 changes:
    - High Performance Mode
    - Disabled all the startup items
    - Disabled built-in AV and firewall
    - Disable all reminders in Action Center

    In GTA 5 (no FPS cap) I've noticed the same issues with frame time spikes and drops when pressing RMB when being in a vehicle. With capped FPS there were no problems as before installing Win7.

    In The Witcher 3 I noticed almost constant 100% GPU utilization and the same spikes. On Win10 there weren't such a frequent MAX GPU utilization, only in high loaded areas.

    Now, I'm pretty scared of all this cr*p even in well run Win7 OS.

    GTA 5 logs: https://drive.google.com/open?id=15NAhU33h4mXKBqXfU6aOGq4aMlPRBFgs

    The Witcher 3 logs: https://drive.google.com/open?id=1-9U66th5eAAnMJd9hrkjZCHxTUISKG-T

    Any advice, if possible in such a creepy situation?



    UPDATE 2:


    So, I have recently retested GTA 5 performance with the following tweaks:
    - Downclock the CPU to 3,700 MHz
    - Disable Hyper Threading and Intel VT
    - Disable ASUS Multi-core Enhancement
    - Disable all the C & P states
    - Disable Base Clock & PCI-E Spread Spectrum
    - Disable HPET using cmd command and the Device Manager
    - Enable Threaded Optimization in NVIDIA Control Panel

    I noticed more frametime spikes and long stuttering after applying mentioned tweaks without any FPS lock.
    But, with 150 FPS lock there was no drops or any similar issues in GTA 5.

    MSI AB Hardware Monitor Logs (with & without FPS lock): https://drive.google.com/drive/folders/1jmoWxPj0rZ73qYA4noabaeDX_PSw840j?usp=sharing

    LatencyMon during game without FPS cap: https://drive.google.com/drive/folders/1gim1F9ypbhXzjr4GxSER56b_rapZBDaO?usp=sharing


    UPDATE 1:

    Just an hour ago I did:
    1. Disconnect my Aorus GTX 1080 Ti physically from the motherboard.
    2. Uninstall NVIDIA Driver 391.35 with Display Driver Uninstaller.
    3. Switch to the Intel's Integrated Graphics, download and install the latest Intel VGA driver.
    4. Lower all GTA 5 graphics settings to minimum and set 800*680 screen resolution.
    5. Start playing.

    The average performance was about 72 FPS. But drops and frame time spikes still happened at lowest possible graphics settings with 800*680 resolution! I'm really disappointed. Issue didn't go away even WITHOUT GPU and NVIDIA driver.

    Then I opened the Latency Monitor and started playing GTA 5 again. After 5 minutes of gameplay I switched to LatencyMon and noticed that highest DPC latency was about 202 ms (instead of normal 30-90 ms) for this driver "Wdf01000.sys - Kernel Mode Driver Framework Runtime, Microsoft Corporation". I think that WIndows 10 is the culprit but not 100% sure.

    You can check the MSI Afterburner GTA 5 log.hml available in the Google Drive folder: https://drive.google.com/drive/folders/14DrbFKVLNyiAG4zBtAWWF6soUT91ApyY?usp=sharing



    Hi community,

    It's sad to say, but there are serious FPS drops/spikes/freeze and micro stuttering in almost all the games on my new self-built high-end PC with Intel i7 8700K + Aorus NVIDIA GeForce GTX 1080 Ti.

    Please Note:
    1. PC specifications, Windows 10 & Software configurations are below in this topic.
    2. I use Google Drive for image/docs hosting instead of other specialized sites in terms of security (sorry Imgur fans).
    3. All images, screenshots and documents mentioned in this topic are stored in the shared Google Drive folder available at the following link: https://drive.google.com/drive/folders/1PYf2NOVn0sOlgkVLgBFN7rZHDgm9ZUM9?usp=sharing
    4. If you don't see some items in Google Drive folder, try signing in with your Google account. I hope you have it.
    5. If you can't open links or view spoilers in this topic, try signing up.

    Warning:
    I figured out that only with NVIDIA 388.13 Driver MSI Afterburner's "Power" monitoring option cause enormous FPS drops and especially stuttering in absolutely any game every time MSI AB refresh values in hardware monitor. This depends directly on hardware polling period in AB settings. Therefore, I recommend you to disable "Power" monitoring feature to prevent issue with future or other NVIDIA drivers.

    Introduction

    FPS drops/stutters are very noticeable in GTA 5, The Witcher 3 and War Thunder (very laggy hangar). There are almost no drops in recently released World of Tanks 1.0. Every game's graphics settings are set to Max/Ultra values without any type of sync or FPS lock.

    All PC hardware have been purchased from trusted local vendors with original seal and warranty from the official manufacturer. PC was precisely built by me without any mistakes, with all the manual/PC building guides requirements.

    Enough intro, let's dig in!

    GTA 5 — FPS Drops/Stuttering

    I have read that I'm not the first player who catch these kinds of issues. But this Rockstar child is especially laggy on my rig. FPS drops occur after each 1-2 minutes of gameplay with high average FPS, particularly noticeable when flying and aiming at the police helicopters on the background of the skybox.

    Also I know that GTA 5 game engine doesn't allow more than 188 FPS. For the first time, I thought that the game is just the culprit because of the 188 FPS engine lock and Grand Theft Auto 5 porting from consoles. But now I'm think that troubles arise due to software or much worse hardware fault.

    FPS Drops: https://drive.google.com/drive/folders/1n8XO6bJQ_77TaC5ZGGTidgfrHH75Pkwa?usp=sharing

    MSI Afterburner Graphs: https://drive.google.com/drive/folders/1jEWidv5I0g7j0B2S7dEbiR2vRi6fduFC?usp=sharing

    GTA 5 Graphics Settings: https://drive.google.com/drive/folders/10aCAmFWNARyXWZbNvzcq4PhYH_3L6egV?usp=sharing

    The Witcher 3 — FPS Drops/Stuttering

    Well, I didn't expect any problems with this CD Projekt great-optimized masterpiece game due to very positive feedback on all game platforms and tons of articles like "The most optimized game ever". Unfortunately, of course, not on my rig.

    Drops are rarely and less noticeable compared with Grand Theft Auto but they ARE, and this an issue. Usually, I notice them while moving, Roach riding or fighting with monsters and guards. And the biggest sorrow is that there is no workaround for this awesome game.

    FPS Drops: https://drive.google.com/drive/folders/1c6ELIfJnD3CEdkKHOQplR_SUPPYtI0xM?usp=sharing

    MSI Afterburner Graphs: https://drive.google.com/drive/folders/1Vm0KTIQtvVrbtmIPP9dZtcoeO3fFlil-?usp=sharing

    The Witcher 3 Graphics Settings: https://drive.google.com/drive/folders/1Vxd6FRMoedT-lvn7F38-CnkPNZULEp85?usp=sharing

    World of Tanks 1.0 — FPS Drops Only

    What about this MMO, I didn't catch any spikes up to yesterday evening, when I decided to play a test battle to show that only one game can run smoothly on my high-end PC without any issues. But what was my disappointment when I found out that WOT wasn't as seamless as I expected.

    I noticed only one drop to 18.7 FPS after 8 minutes of battle. It's the first huge FPS drop
    in the last month playing WOT. Till this moment the maximum frames drawdown wasn't below 53.8 FPS and it only happened after my tank was destroyed.

    WOT graphics settings was set to Ultra preset and 100% 3D Render Resolution without any other changes. Screenshots are not needed there. Also, I missed a moment of FPS drop and didn't have time to take a screenshot, so there are only MSI AB graphs.

    MSI Afterburner Graphs: https://drive.google.com/drive/folders/1VFcBiO9sL62leixwwPKJiEGzta9K6SaS?usp=sharing

    What I tried to do and that DID NOT HELP any game:

    1. Marts_Sum's method with EmptyStandbyList on GeForce Forum: https://forums.geforce.com/default/...dows-10-creators-update/post/5235141/#5235141
    2. Set UEFI (BIOS) and Windows 10 to default settings.
    3. Roll back to Windows 10 Anniversary Builds 1703, 1607 and fresh reinstall of 1709.
    4. Disable/Enable: Windows Defender, Firewall, Cortana, Game DVR/Game Bar/Game Mode, all unnecessary services/drivers/startup items, indexing, consumers features, power modes (Balanced/High performance/Power saver), hibernation, SWAP & PAGE files, Fast Boot (in UEFI as well) and LAN by unpluging an Ethernet cable.
    5. Reinstall/Reconfigure all possible old/new drivers and firmwares from official sites. Also tried to use DDU.
    6. Overclock/Downclock GPU, CPU and turn on/off XMP Profile (3,200 MHz).
    7. Install other overclocking software.
    8. Uninstall all Windows 10 built-in apps.
    9. Uninstall MSI Afterburner & RTSS.
    10. Paused MSI AB Hardware Monitor and disable "Power" monitoring option.
    11. Reinstall game from M.2 SSD to 7,200 RPM HDD and vice versa.
    12. Lower down/max out graphics settings, screen resolution and refresh rate.
    13. Run as Administrator and disable/enable Fullscreen Optimization.
    14. Switch to integrated Intel® UHD Graphics 630.
    15. Install GTA 5 and The Witcher 3 on NASA computer in the hope of getting rid of FPS drops and stuttering. :)

    What I tried to do and that SOMEHOW HELPS (unfortunately only for GTA 5):

    1. Lock up to 150 FPS and less using the Rivatuner Statistic Server.
    2. Enable VSync. But I rarely notice some drops down to 32 FPS, better than falling down to 5-8 FPS but not worth it. Also, high input lag doesn't make this method a pill from all the illnesses.
    3. Hope it will be soon thanks to your helpful tips.

    Conclusion

    I hope that I gave you enough information to find out the reason. Unfortunately, I still haven't found any permanent way to play games without these killers of the game experience.

    Let it be a software fault, because I really don't want to send my hardware to a service center, and I definitely don't know which part of the PC causes problems.

    Questions

    1. So, dear readers, do you know any advices, workarounds and working fixes?
    2. Or, maybe, any official confirmation from NVIDIA, Microsoft and Intel that is 100% related to their software failure instead of hardware defect?
    3. If FPS drops and stuttering caused by hardware, сan you roughly determine what is the culprit and where to dig?

    Thank you very much for the attention!
    I will be very grateful for any of your help!


    With deepest respect,
    "Happy" High-End PC Owner




    Hardware and Software Configurations

    PC specifications:

    MB: Asus Maximus X Hero
    CPU: Intel i7 8700K Kaby Lake
    Cooler: Noctua NH-D15
    GPU: AORUS GeForce® GTX 1080 Ti 11G
    RAM: HyperX Predator 3200MHz DDR4 16GB (2x8GB in Dual Channel)
    SSD: Samsung 960 EVO NVMe M.2 250GB
    HDD: Western Digital Black 1TB (7200rpm 64MB)
    PS: Seasonic Prime 850W Platinum
    LCD: Acer Predator XB271HU (27", 2560 x 1440, 144 Hz, G-Sync)
    KeyB: HyperX Alloy Elite MX Blue (1,000 MHz)
    Mice: A4Tech Bloody V2 (1 ms, 1,000 MHz)
    Case: Corsair Graphite 780T
    Fans: (X5) Noctua NF-A14 PWM (140mm) & (X1) Noctua NF-S12A PWM (120mm)
    UPS: APC Back-UPS Pro 1200VA/720W

    DxDiag: https://drive.google.com/file/d/1SuSemQ4Q6vDD01HSIjq3PLPQW8xTAF7n/view?usp=sharing

    Windows 10, UEFI (BIOS) and Software settings: https://drive.google.com/drive/folders/1CN1N33vfbgKA1TBAtKW63BjSmKfu78It?usp=sharing

    NVIDIA Control Panel settings: https://drive.google.com/drive/folders/1f_ZOY9XTqAJ1uOYuswf53iMOq5upNj8p?usp=sharing

    Benchmarks results: https://drive.google.com/drive/folders/18sr4PuAD-0df5neNf-9sgyfEIyJ6jtCk?usp=sharing



    P.S. Dear Administration, I'm new to this forum. If something is wrong with this topic or its location, please, correct it and let me know. Thank you!
     
    Last edited: May 5, 2018
  2. melmac

    Soldato

    Joined: Dec 19, 2010

    Posts: 6,200

    Try doing a memtest and a CPU stress test.

    did you try playing games with Gsync disabled?

    And, are you saying that there are still frame drops, freezing and micro stutter even if you reduce the graphic settings to low in games?
     
  3. HRL

    Hitman

    Joined: Nov 22, 2005

    Posts: 816

    Location: London

    Got your games stored on the SSD or HDD?
     
  4. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    Tried to:
    Didn't help. =(
     
  5. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    1. I did memtest. No errors were found. CPU stress test in AIDA64 show good results. Max temp was 72C with 4.7 GHz.
    2. Yup. I tried. No changes.
    3. Yeah. Even with 1280*720 and minimum settings I notice issue.

    =(
     
  6. HRL

    Hitman

    Joined: Nov 22, 2005

    Posts: 816

    Location: London

    Got another SSD you can install the games on other than your OS SSD?

    Installing them onto the HDD is never going to help because even with non-gaming activity on the M.2, it will still be faster than the HDD.
     
  7. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    Think that's not helpful. I haven't more SSDs. And installing OS on the HDD won't be a great idea.
     
  8. HRL

    Hitman

    Joined: Nov 22, 2005

    Posts: 816

    Location: London

    I agree but that wasn’t what I was suggesting.

    I’ve got my OS, Win 10, on a single SSD, and all of my games on another larger capacity SSD.

    Shame you don’t have another SSD laying about to test with.
     
  9. String

    Capodecina

    Joined: Jan 6, 2013

    Posts: 11,182

    At least we know your keyboard is working fine.
     
  10. docsonic

    Wise Guy

    Joined: Aug 26, 2010

    Posts: 1,389

    .
     
    Last edited: Apr 9, 2018
  11. String

    Capodecina

    Joined: Jan 6, 2013

    Posts: 11,182

    Actually, having ploughed through the wall of text:

    Are you sure the games aren't running borderless instead of full screen?

    Also, set vsync to on in Nvidia control panel and off in game.
     
  12. HRL

    Hitman

    Joined: Nov 22, 2005

    Posts: 816

    Location: London

    :D
     
  13. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    Hah. Nice but hopeless joke.
    I think the same about peripherals. =)
     
  14. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    1. 100% sure that they're running in FS mode. Checked it twice.
    2. Tried it. Hopeless. Only GTA 5 game VSync option help a bit but don't destroy FPS drops completely. =(
     
  15. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    Of course I do.
    bcdedit /deletevalue useplatformclock cmd command doesn't help. :(
     
  16. LegendaryDread

    Gangster

    Joined: Nov 10, 2009

    Posts: 433

    Location: Southampton

    Last edited: Apr 8, 2018
  17. Meddling-Monk

    Gangster

    Joined: Sep 2, 2013

    Posts: 462

    That seems to be an unbelievably low amount of RAM you have there for a modern rig.

    Are you able to check how much memory you have whilst you run those games? It may be running short and resorting to using the page file. That can cause chopping too.
     
  18. BS Dave

    Mobster

    Joined: Oct 19, 2004

    Posts: 2,553

    Location: London

    I would try to use in game FPS locks at 140 FPS if possible. If not use DSR to bring them down g-sync isn’t pretty over 141 FPS. Also turn off fair works in Witcher 3.
     
  19. Knower

    Associate

    Joined: Apr 8, 2018

    Posts: 79

    Location: LA

    I tried to run it during OS idle. I guess, running during the load it'll showing wrong results because a game remain all hardware power and LatencyMon will performance parasite. LatencyMon while gaming it's like playing game with other 3rd part app running in the background. If wrong — correct me with proofs.
    Nope. =)
    Do you think that 16 GB is not enough for today's requirements? It does not. I have used maximum 9GB of RAM playing one hardware demand game (Witcher 3 if I'm right).
    Not all games have built-in FPS lock. Better to use RTSS for capping frames. Oh, if it would be useful. I tried it, no changes. Even tried to enable GTA's frame scaling to maximum value — didn't help.
    About Witcher, I tried to do this. But there was no changes.
    I'm really disappointed with these issues on top PC. I don't even know why quality testing is so poor nowadays. :(
     
  20. Glanza

    Sgarrista

    Joined: Mar 13, 2007

    Posts: 9,499

    Location: South Yorkshire

    Are you using the supplied DP cable from your monitor to GPU?