New build - but none of the USB ports can be used (rear or front)

Associate
Joined
25 Jan 2021
Posts
4
I just completed my new build PC. When power is turned on, it gets to a screen that basically asks for inserting a bootable device, which is expected as I need to install Windows onto the drive. But the keyboard is not working at all. I have tried all the USB ports on the motherboard (as well as the front panel USB port), none of them seem to work. I don't have PS/2 ports nor PS/2 keyboard/mouse.

Here are some of the things I have tried to figure out the issue - but ends up still not resolved:
- Switch the RAM sticks, or using only one of the two sticks - none worked
- Completely rebuild everything - I even took out the CPU, RAM, etc. - still not working

And so looking for helps here - if anyone has had similar problems before and how to get it resolved please?

My build is:
- Gigabyte B550i Aorus Pro AX
- AMD Ryzen 5600X
- Crucial Ballistic 32GB (16x2) 3000MHz CL15
- WD SN850 1TB M.2 PCIe Gen4
- Gigabyte RTX 3070 VISION OC
- Corsair SF750 750W (SFX)
- NZXT H210i case + Kraken X53 AIO
 
Top Bottom