1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not powering up

Discussion in 'General Hardware' started by Mortah, 5 Jun 2006.

  1. Mortah


    Joined: 17 Apr 2006

    Posts: 139

    All my new gear has arrived... put in the mobo (Asus A8R-MVP), graphics card and PSU (Tagan 530W modular) but nothing else. Connected it to the case. Turned on the mains... turned on the PSU switch... little light comes on on the mobo but nothing happens when I press the power switch...

    I have another case and a PSU that definitely work (PC i'm typing this on)... should I try using the other cases power switch to see if that works? What about the PSU?

    Or does anyone have any bright ideas for something I could have done wrong without thinking :|
  2. Logan09


    Joined: 20 Oct 2004

    Posts: 719

    Location: Rainford, nr St Helens

    What, no CPU?!? :eek:

    Seriously though you should try it with the other PSU.
  3. Blue Cypher

    Wise Guy

    Joined: 5 Dec 2005

    Posts: 1,683

    Location: Sheffield

    Make sure the power switch is wired to the motherbaord corectly, secondly check that your motherboard isnt touching anything metal like the back plate of the case that it is screwed to as this could lead to a short circuit. Failing that yes do try the other psu and case.
  4. Mortah


    Joined: 17 Apr 2006

    Posts: 139

    was just about to say I've put in the CPU and RAM too...

    The motherboard is mounted on the case using the spacers (eclipse case)... i notcied there were little bits of red felt attached to some of the screws... couldn't find anything that mentioned that I should use these and even read on a mobo installation guide that if there is metal on the mobo then the mounting should be metal to ground it... should I have used the felt bits? :(
  5. Mortah


    Joined: 17 Apr 2006

    Posts: 139

    Ok... PSU deffo works as I've tried it in my other PC. Case power switch also works for the same reason...

    Anyone got any other thoughts? Could it be the supports for the motherboard not having the felt bit?
  6. Mortah


    Joined: 17 Apr 2006

    Posts: 139

    Ahha! I love some motherboard sites...
    Specifically picture 12. It suggests using a pen on the power pins to turn on your computer... it worked. So now all i got to do is work out why its not working!


    Oh holy crap I'm a muppet! I had connected the power switch to the wrong pins!

    X X X X X
    X X X X X
    PWR   RST
    I had the power smack bang next to reset :D
    Last edited: 5 Jun 2006
  7. split


    Joined: 2 Nov 2002

    Posts: 3,534

    Location: Dorset

    Is it one of these?

    O you mean this.

    Forget it..just noticed you fixed it :)
  8. Mortah


    Joined: 17 Apr 2006

    Posts: 139

    hmm... I just noticed that I haven't got the ATX 12V connected up... yet its powering up. In the manual it says "The ATX 12V must be connected or it will not boot"... I'm guessing I should connect it up anyway? :)

    [EDIT] It's fine now... connected, working, yay! :D
    Last edited: 5 Jun 2006