• Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

Nvidia drivers? or crysis god hate me?

Associate
Joined
2 May 2007
Posts
186
Location
Managua, Nicaragua
HI
Im having some problem since a few days ago.. I was playing crysis normally with minors bugs but then when I was entering to the mission assault, my PC start to behave weird. all levels before this work fine... in this When I load the game.. some sort of artifacts start all over the place and then crash to desktop with the nvlddmkm driver thing... and sometimes after the artifact im able to enter the mission (with no artifact in the mision) but later on the same mission the game crash.... any solution... I already try this:

Change drivers: 169.04, 169.09, 169.12 (properly uninstalled and using driver swap)
Uninstall X-fi xxx.004 drivers.....
re-install the game
re-install windows

Its not an overheat problem.. my temp is fine. But i had some problem with COD4 too.. not artifacts but the game crash just a few minutes after I enter some missions... But I kinda solve this... uninstall my X-fi drivers and finish the game without a problem...

Its very intresting because the sound drivers didn't fix crysis just cod.... then when I try to install my xfi driver (xxx.004) the PC stop responding with some "artifact" look alike and freeze. I had to reboot and try t install the drivers again and worked....

I also was watching a serie using the dual monitor, my pc monitor and my TV.. when I start to notice the "artifact", then Stop using the dual monitor and use my PC monitor and problem solve without a reboot......

I called artifacts because I dont know what else to call it. artifacts are small dots, this are big ones in top of my screen usually.

It this nvidia drivers problems? X-fi drivers problem? or both? My PC was working fine few days ago... suddenly after new nvidia and x-fi drivers my pc is a disaster....

Anybody with the same experience???
 
Associate
Joined
2 May 2007
Posts
186
Location
Managua, Nicaragua
forgot to put my Spec:

Q6600 OC @ 3.0ghz on water very stable
P5B deluxe wifi-ap
MSI 8800 Ultra-OC edition @ Stock
4GB OCZ reaper @ stock
X-fi Xtremegamer Fatal1ty pro series
Thermaltake toughpower 750w
2- 80Gb RAID-0
2- 250GB storage
Windows Vista Ultimate Spanish x64bits (legit)
Crysis (legit)
COD4 (legit)
 
Last edited:
Associate
Joined
7 Jun 2005
Posts
538
Location
Leeds, UK
It this nvidia drivers problems? X-fi drivers problem? or both? My PC was working fine few days ago... suddenly after new nvidia and x-fi drivers my pc is a disaster....
...go back to your old drivers then?

I've gotta say from personal experience, Creative drivers are bloody awful. I'm still running my Audigy 2 on out of the box drivers because if I even attempt to update them my system goes absolutely loco.

I'd say go back to previous drivers if these problems occured after you installed new ones.
 
Soldato
Joined
20 Feb 2007
Posts
4,386
Location
Staffs, UK.
Ahh the dreaded TDR or timout detection and recovery error, could be numerous things.

There's a big thread all about it here

Just a quick suggestion though, one of my friends had the very same video card as you and he had to downclock the memory on it to get rid of his TDR's, if all else fails you could try that.
 
Top Bottom