OC Titan Oynx - bunch of weird system issues - ideas?

Associate
Joined
29 Dec 2005
Posts
82
Hi,

So I bought a Titan Oynx from Overclockers about 15 months ago. At the time I was very happy with it, but over the past few months I've been getting some weird behaviour.

I'd welcome any suggestions as to how to fix this or even where to start. Ideally without going through the hassle of say a system re-install, especially as it seems like it could be hardware related.

So here is the list of weirdness, in order of events

Audio CD
About 5 months ago I tried to play a music CD, prior to this I don't remember playing a CD on the Titan before. Things didn't go well. The audio was very slow and stuttery, occasionally playing correctly for a second, before going very slow again (at least 1/2 speed) and sounding really distorted.

I tried a number of audio players (windows media player, winAmp etc) and all had the same problem. Yet DVD's play fine.

StarForce
One thing i did notice, I got some dammed StarForce dlls installed, in my 64bit windows system, which I cannot remove. None of their un-installers work and it looks like the install mistakenly placed them in the 64bit stuff instead of 32bit. Hmm I wonder if that might explain the CD audio issues?

I could probably remove them, but according to the window logs they aren't being loaded because they are not for the system, though I guess something else of Star Force could be installed and messing up the system.


The Belkin KVM (kill) Switch
Around this point i bought a Belkin KVM switch, not a great decision. It was usb based and for some reason whilst it worked with the Titan it didn't with my older Dell. I couldn't be bothered to re-connect everything so I just left the titan on it. A couple of weeks later the PC wouldn't start up. I no longer remember the exact details, whether the PC started but there was no display, but I do remember as soon as I plugged the titan directly to mouse/keyboard and monitor it started up fine.

I assume the KVM switch went bad or was just rubbish to begin with. I've not tried it since.


The dreaded BSOD
A few months back I was testing a project i'd made using Unity3D with a new feature called 'substances' which are procedural textures that can be quite taxing on the system. Unfortunately doing so led to a number of BSOD, a few times in the editor but mainly when running the project as an exe, both in 32bit and 64bit versions. Sometimes the exe would crash within a few minutes, other times up to an hour.

The BSOD itself was inconsistent in its reports, I created mini-dumps and analysed them, but it never seemed to be the same cause twice. I was also unable to recreate the problem on other machines, neither were Unity Technologies, suggesting it was something specific to my hardware.

The most obvious thing to do would be to update drivers but at the time iI was in the middle of a client project, so couldn't take the risk.

I did however run the windows memory test and that came up negative.


The Titan Dies
This was a big one, one morning ( a good month after the last BSOD) turned on the PC and nothing happened! The lights came on, so did all the fans, but other than that nothing, no beeps, no keyboard lights etc.

I was resigned to pulling it apart, but for some odd reason, after i'd pulled it out from under the desk and having disconnected all external devices/cables, I just thought, why not try it one more time. To my relief it started up, although there was still some weirdness. I think the bios had become corrupt or settings lost as when I eventually got in to look things seemed to have reset themselves to when I got the machine.

I came here and started a thread about it, but didn't get any useful replies. It goes into great detail about the event and what happened afterwards.

Without doing anything apart from changing a few bios settings back to normal, the system seemed to almost fix itself.

I since carried out HD check (SMART) and monitored other hardware such as temps on cpu/gpu etc, but nothing out of the ordinary appeared.


The Disappearing Desktop
Last week I turned on the machine and I think it failed to start up. I restarted and when I got to the desktop it wasn't there anymore! I had the login screen, but after that I just had the plain blue desktop and nothing else.
Eventually I got it back after going into safe mode (which did show all my desktop icons etc), but again bit weird.


Upgrading nVidia GPU
So a few hours ago I felt it was time to upgrade my nvidia drivers for my GTX465. Mainly so I could have a go with the substances project again.
The install went ok for a minute, then suddenly the signal to the monitor stopped and my monitor went black. Nothing could get the signal back and eventually i did a restart.

Thankfully the system was still working and when checking the nvidia device i could see that the graphics drivers had been updated to version 280. However the nvidia control panel couldn't launch as there was an error.
So I re-installed the 280 drivers again. This time the install went smoothly no problems.

Just to be sure I restarted the machine again and its still working, along with all the nvidia drivers and updates now being installed.



So there you go. Is there a single cause to all these woes?
Hardware or software?
What would you do to try and get to the bottom of the problem?

cheers
 
Last edited:
Top Bottom