Potential fix for USB 2.0 hitching/stuttering on Gigabyte/Aorus B550 and X570 motherboards

Associate
Joined
10 Dec 2007
Posts
1,553
Seems to be an issue with recent BIOS. It's been brought up often enough that this isn't just some boards, it's a pretty big amount of them having issues.


Anyway if you want the quick tl;dr

BIOS > Advanced CPU Settings > Global C-state control > Disabled

Also reports of MSI suffering from this too judging by the comments on that video.
 
Associate
Joined
10 Oct 2015
Posts
218
Location
Essex
That's really going to help a lot of owners out there. Thanks a lot for posting :)

I spent months searching through Reddit etc looking for a fix and ended up going with Asus due to the lack of a clear fix. If I had known a fix was in sight I would have stayed with the AORUS PRO AC.
 
Associate
Joined
18 Oct 2019
Posts
341
Location
U.K.
*sigh*. video uploaded the day after I pulled a trigger on an MSI B550 board for exactly this concern with the Aorus B550 boards... :(
Only Buildzoid can turn a single BIOS setting into an eight minute ramble.

Now if only Gigabyte could actually get the V2 boards out in the U.K. I'd have cancelled the order and gone with the Pro instead.
 
Associate
Joined
3 Apr 2007
Posts
1,690
Location
London
V. odd. I've been through various BIOS versions on my X570 Aorus Pro and never seen anything like the issue he had there.
Though would need to look at what's plugged in where at the back of the PC and will now keep an eye out for this issue.

Couldn't tell from the video what BIOS version he was on but interestingly the latest BIOS for my board has this listed....

F31l - 2‎020/11/25 - 3. Improve connection stability for USB 2.0 ports of USB hub

So wonder if the issue is now fixed?
 
Soldato
Joined
29 May 2005
Posts
4,290
has anyone tried settings in Power Option in control panel?

there is a setting called USB selective suspend and also PCIe Link State Power Management.
 
Top Bottom