PS5 120Hz Issues

Man of Honour
Joined
29 Jun 2004
Posts
20,915
Location
Oxfordshire
Hey all,

Have a PS5 hooked up to a LG 65CX via a Denon 2700H AVR and can’t seem to get 120Hz to be displayed as a possible output on the PS5 display screen

Last month I bought 5 HDMI 2.1 cables from Amazon. They were the Amazon Choice at the time, and still are by the looks of it and had solid reviews from people using them with PS5’s or an XBX and getting 120Hz. “Ibra 2.1 HDMI Cable 8K, IBRA 2m Ultra HD Lead High-Speed Cord 48Gbps | Supports [email protected] [email protected]” was the description for the cables if anyone wants to check

I’ve got HDMI deep colour on on the TV and the Denon set to 8K Enhanced for the PS5 input. These are the only two settings that I can see that should affect whether I see 120Hz or not.

Anyone had similar and was able to fix it? Short of buying more cables, I’m not sure what else to try.

Thanks and Merry Christmas all
 
Soldato
Joined
26 Jan 2005
Posts
5,390
Hey all,

Have a PS5 hooked up to a LG 65CX via a Denon 2700H AVR and can’t seem to get 120Hz to be displayed as a possible output on the PS5 display screen

Last month I bought 5 HDMI 2.1 cables from Amazon. They were the Amazon Choice at the time, and still are by the looks of it and had solid reviews from people using them with PS5’s or an XBX and getting 120Hz. “Ibra 2.1 HDMI Cable 8K, IBRA 2m Ultra HD Lead High-Speed Cord 48Gbps | Supports [email protected] [email protected]” was the description for the cables if anyone wants to check

I’ve got HDMI deep colour on on the TV and the Denon set to 8K Enhanced for the PS5 input. These are the only two settings that I can see that should affect whether I see 120Hz or not.

Anyone had similar and was able to fix it? Short of buying more cables, I’m not sure what else to try.

Thanks and Merry Christmas all
Silly suggestion maybe, but have you plugged the HDMI cable into the 8K port? I initially made the mistake of plugging it into the Game port, not realising that the 8k port is the only HDMI 2.1 port on the amp. That'll teach me for not reading the amplifier's specs properly!
 
Man of Honour
OP
Joined
29 Jun 2004
Posts
20,915
Location
Oxfordshire
Silly suggestion maybe, but have you plugged the HDMI cable into the 8K port? I initially made the mistake of plugging it into the Game port, not realising that the 8k port is the only HDMI 2.1 port on the amp. That'll teach me for not reading the amplifier's specs properly!

I love you, what a guy! I did not know that either, I assumed they were all 2.1?

Plugged it in to the 8K port and now have 120Hz! Slightly annoyed that I didn’t know that. Likewise though, not fully reading the specs on this amp has left me disappointed on a couple of things
 
Soldato
Joined
26 Jan 2005
Posts
5,390
Yeah tell me about it! I honestly could’ve sworn I read that they were all 2.1. I was about to return the amp and get an exchange or have it repaired :eek:

Glad that it sorted it for you :)
 
Top Bottom