Quiet mic on Hyper x cloud 2

Soldato
Joined
16 Jun 2013
Posts
5,437
I'm using the USB inline controls as the splitter doesn't fit the Corsair front panel :(.

Both Teamspeak and Discord people have to turn me up to full boost despite the mic being at full volume(I am also boosting input in TS and Discord).

I basically have to be eating the mic before people can hear me well. If it's more than an inch from my mouth people apparently can't hear me well.

I've contacted Kingston support and they're sending me a new USB controller but I'm not overly hopeful.

Any ideas?
 
Soldato
Joined
18 Oct 2009
Posts
11,169
Very unlikely it is a hardware problem. I've seen a few comments about quiet USB microphone, which can be fairly common.

With USB microphones, there is no gain setting control in Windows 7 onwards. Some USB headsets might come with their own software suite which allows this, or some microphones, such as Blue, might have a gain control on the device itself.

Microsoft have changed something since Vista, as I've seen some people say they could set the gain control in Vista, but 7 onwards it's missing.

Some people have managed to get round the problem by using 3rd party software. Have a look at this video:

 
Soldato
Joined
16 Jun 2013
Posts
5,437
Thank you for the video.

Sadly it doesn't seem to have any effect on my PC :(.

I have had some limited success removing Kingstons USB drivers and installing the bog standard Microsoft ones. Nowhere near as quiet now. Still far from ideal but I suspect until I swap to 3.5mm and a soundcard I'm not going to get much better.
 
Soldato
Joined
16 Jun 2013
Posts
5,437
Is the cable long enough to go in the back?
Most headphones have long cables but I don't know about them.

The rear ones (normally better sound anyway) are usually close together

Sadly not :(. There's a nice bit of length on the other side of the USB inline helpfully :D.

I will have to look at an extension cable or I may just upgrade and get some designed for onboard use rather than USB soundcard.
 
Soldato
Joined
16 Jun 2013
Posts
5,437
Try updating them to their latest firmware, it solved a few issues for me.

I didn't even realise they had a firmware update. Unfortunately all it seemed to achieve was removing the beeps when clicking the soundcard controls :(.

Thanks for the suggestion though!
 
Associate
Joined
19 Nov 2010
Posts
1,931
I had a similar problem with mine and I did a few things to mitigate it, can't remember exactly what now, though. A hour or so spent face rolling my keyboard while drunk. What are you struggling with, TS3?
 
Associate
Joined
9 Feb 2011
Posts
476
Location
Central London
Check if microphone booster is enabled in you "playback devices":

1. Click on the small arrow on bottom right to open up a tab with other background apps.
2. Right click on 'volume'
3. Click on 'playback' devices
4. Click on "recording"
5. Right click on microphone (should be set as default device) and go into 'properties'
6. In the properties, find an option called "microphone boost" and enable it. It might be in 'custom' tab.
7. Also, this tab can allow you to turn up/down the volume of your microphone so its worth checking if its set too low. This setting should be under "levels"
 
Top