1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sound blaster z keeps going missing/uninstalling from device manager (Please remove thread)

Discussion in 'Sound City' started by caveman OCUK, Oct 8, 2018.

  1. caveman OCUK

    Gangster

    Joined: Sep 1, 2013

    Posts: 151

    Hi all, as title says i bought a soundblaster z soundcard, set it all up, works fine while the pc is on, but whenever i shut down and turn the pc back on the driver has magically gone/uninstalled, so far iv tried:
    *installing the latest win10 driver
    *disabling all other drivers for sound,
    *turning off on board sound
    *enabling legacy boot and legacy usb support (as told on another forum)
    *disabling fast boot

    and it STILL disappears and says no audio installed when i shut down and turn on again, i must have removed the drivers and card and reinstalled about 20 times now (no exaggeration) just to try and fix this ,
    getting to the point now were i might just return it and buy a different sound card as its beyond a joke now and its still under return to overclockers.

    thanks in advance for any help.
     
  2. caveman OCUK

    Gangster

    Joined: Sep 1, 2013

    Posts: 151

    Given up and bought a different sound card , so thread is now unneeded
     
  3. EsaT

    Mobster

    Joined: Jun 6, 2008

    Posts: 4,289

    Location: Finland

    Did you get Wintoys 10 updated to latest fiasco before MS pulled plug from it?
    Sound card problems have been quite common even in previous updates... Which at least didn't destroy people's files.
     
  4. caveman OCUK

    Gangster

    Joined: Sep 1, 2013

    Posts: 151

    Hey :) thanks for the response , I don’t think I updated , as I think I turned off automatic updates just in case there was a dodgy update like the recent one you mentioned, but it should be ok now as I orderd a different sound card and after doing a bit of googling it seems that the sound blaster z card is giving a lot of people hassle in various different ways , but I’ll jump back on the forum if I have any issues with the new sound card as it’s being delivered tomorrow :)
     
  5. EsaT

    Mobster

    Joined: Jun 6, 2008

    Posts: 4,289

    Location: Finland

    Well, in another forum one user had latest Wintoys 10 update causing some problems with motherboard's integrated sound card.
    And who knows how many other usual Wintoys upgrade sound card issues there's been, with main focus being on "slightly" bigger fish.

    XP time with all its security issues is starting to feel all the time better.
    At least then OS upgrades didn't destroy user data and you needed to get destructive virus for that.