TL-WA901ND - Access Point dropping connection on file transfer.

Associate
Joined
20 May 2006
Posts
1,066
Hey guys,

So I've recently bought this AP, and I've been having the below issues (I was going to submit the below to the company's tech support, however their ticket page is glitchy and doesn't work - neither do their forums.

If anyone has used this AP before and came accross a solution, I'd be pleased to know :3

-------------------------------------------------------------------------

I've just purchased the above product today, and was planning on using it in 'Client Mode'. However, when transferring large files (over 500MB roughly) to or from the device connected to the AP from another device on the same network, the wireless interface on the TL-WA901ND V2 will fail and stop responding.

I can successfully access webpages, and transfer smaller files without an issue, but as soon as a large file is starting to transfer, the wireless interface fails. I can still ping the AP from the client PC, and get a response - however when trying to ping the AP from another device on the network there is no response - indicating the wireless interface is what is failing because of the large transfer, the AP itself is fine and can still access the GUI via the LAN port. The wireless interface will come back online itself if left for 3 minutes, but the speeds are reduced severely.

My findings/troubleshooting are:
- I've tried turning every device off involved in the transfer of data (PC connected to AP, wireless laptop on the network sending the file to Client PC on AP, AP, and the router which hosts the DHCP). This didn't resolve the issue.

- If the AP is configured in 'Access Point' mode rather than 'Client' - I can connect to the wireless interface and transfer large files fine (5GB+) at a rate of 9MB/s

- In 'Client' mode - the transfer speed is 3MB/s - and the interface drops out after about 200MB has been transferred, sometimes instantly when trying to transfer a new file.

- I've tried all the available firmwares you have hosted for the AP, and discovered that the oldest firmware on your site available (wa901nv2_en_3_12_6_up(110214).bin) allows 'Client Mode' to work, and the files do transfer successfully, however the speed is half of what I would expect (3MB/s) - not to mention the 3 year old firmware, with all the previous bugs packaged into it.

- Just for clarification, I can transfer files over the same router on the network to another device which was on the same table at 6.5MB/s.
--------------------------------------------------------------------------
 
Top