1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB External Hard Drive Randomly Disconnects

Discussion in 'Storage Drives' started by Undying, Dec 31, 2019.

  1. Undying

    Associate

    Joined: Dec 31, 2019

    Posts: 2

    Location: UK

    I have recently upgraded my motherboard (second hand), CPU (second hand) and memory (new), however I am now having USB external hard drive problems which I didn't have before.

    I mostly use Teracopy to copy/move files, but since upgrading it fails most of the time on the verifying stage when I copy from internal hard drive AND external hard drive.

    I have the external USB3 hard drive in 2 partitions.

    I have tried 2 front USB ports (USB3 & USB2).

    I currently have it on the rear USB3.1 port and the problems of momentarily disconnecting happen on all 3 USB ports.

    I have run a surface scan for and there are no errors. I am currently running a bad sector scan which if the program is accurate reports 1 bad cluster. All my drives are in very good condition and although a few years old now still appear to be in very good health until now with a change of motherboard, CPU and memory.

    When I copy onto the external USB hard drive there are occasions some files will not be copied but mostly it seems to be when Teracopy is verifying, Bart Backupper program also reports errors sometimes.

    Winamp which I use for music sometimes reports that I have just plugged in my external hard drive and would I like to use with Winamp due to this error.

    The previous owner of the motherboard flashed the bios and it’s date is 13/11/19 (American Megatrends Inc. – Version = 1.NU AMD Agesa Combo-AM4 1.0.0.4).

    I did have a problem where my external USB hard drive didn’t show up in the boot menu but that was just once. Upon the first install on Windows 10 it hot to the stage of copying files and then aborted itself. when I booted Linux Mint (Live distro) it hung and I had to restart the computer.

    I have reinstalled Windows 10, I have updated the USB drivers and annoyingly the problem persists.

    Does anyone know what the problem is with my computer?

    Thanks.


    My system spec is:

    Operating System = Windows 10 Pro 64bit.

    CPU = AMD Ryzen 5 1600 – 6 core, 12 threads - (Recently upgraded, Second hand)
    Motherboard = MSI X370 Gaming Pro Carbon - (Recently upgraded, Second hand)
    RAM = Corsair Vengeance LPX 16GB (2x8gb) DDR4 3000 MHz C16 XMP 2.0 - (Recently upgraded, New)

    PSU = Corsair VX450W PSU
    Graphics Card = Nvidia GTX (Inno3D) 1060 6gb
    Audio = Sound Blaster Z


    Hard Drives:

    SAMSUNG SSD 830 (128gb) – Sata
    Samsung ST500LM012 HN-500MBB (500mb) - Sata
    Samsung M3 portable (1tb) - USB3

    Blu Ray Recorder = LG HL-DT-ST BD-RE BH16NS40 - Sata
     
  2. Undying

    Associate

    Joined: Dec 31, 2019

    Posts: 2

    Location: UK

    It disconnects very briefly. I never bad problems with the external hard drive before, I backed up gigabytes of files before replacing the motherboard, CPU and memory onto the external hard drive the day before without any problems. It's only when restoring my data that I had the problem with it.

    I have the ISO disc image files on the external hard drive, which I install Windows from and run Linux. I did a fresh install of Windows after upgrading.

    I have had the hard drive for about 7 years and it has been lightly used. I have used it more lately as I have music samples and VST's stored on it. Other than that, I have only used it for backup.

    There has been no computer crashes no blue screens, I can play games such as the Witcher 3 on it at very high settings.

    Temps are very reasonable, I don’t “stress” the computer much other than playing the occasional game which I have hardly done on this computer as I only built it 2 weeks ago.

    I have done hard drive self-tests (done on 2 programs), S.M.A.R.T health reports everything fine, not many programs can display external hard drive info.

    My computer case is the same. The front USB ports are on the top of the case, cables are properly connected. I have rarely moved the hard drive, cable and case are in excellent physical condition.

    I suspect it's the motherboard chipset, I know the memory controller is both on the X370 chipset and on the Ryzen CPU itself. The Asmedia chip is connected to the X370 chipset according to the MSI motherboard manual.

    It could possibly be a power issue from the motherboard. (MY PSU is plenty powerful enough.

    I have a USB2 hub (via my monitor) connected, a laser printer, and PCTV connected, all on the USB ports but they are very rarely used.

    In the last few days I have cleared everything off the external hard drive and reformatted it and it has made no difference. The problem remains. I am currently trying the hard drive on a forth rear USB port (3.2 generation).

    Device manager reports everything is working properly, there are no exclamation marks.

    I have tried “allow the computer to turn off this device to save power" disabling USB Selective Suspend in Windows Advanced power management but it made no difference and I never had to do this before with my previous builds.

    It’s frustrating.