Weird engine noise, please help

Associate
Joined
5 Jul 2021
Posts
16
Location
UK
Hi, not sure if this is the place for this type of post but here it is anyway. Bought a used 2010 Kia Ceed 1.6 diesel a few weeks back and I've noticed an odd clacking noise when accelerating at low speeds. I've uploaded a video of the noise here, it's best heard near the end of the video. Sometimes this noise is very loud, other times it's not as such. It doesn't make this noise at all when idling, only under load and even then it doesn't happen all the time. Any ideas of what it might be?
 
Associate
Joined
5 Jul 2021
Posts
16
Location
UK
I've taken it to a local garage and they've said it's most likely due to dirty fuel injectors. No engine light and it still seems to get pretty good mpg (60+ on motorway) so I'm dubious of this. Definitely coming from the engine bay though.
 
Associate
Joined
19 Dec 2002
Posts
1,536
after you have driven it and open the bonnet is there any mist above the engine? i know theres probably a engine cover but maybe worth removing it and seeing if anything is damp around the injectors? maybe when warm the injector is blowing had similar when injector clamps started to get loose on wifes honda managed to catch it before it popped the injector she stated it got noiser in the weeks before she mentioned it but again no lack of power or anything. just a thought,
 
Associate
Joined
5 Jul 2021
Posts
16
Location
UK
Had a look under the engine cover around the injectors and there's no smoke or dampness. Maybe something else worth mentioning is the car seems to judder a bit when accelerating at low speeds when the engine isn't warm. Runs just fine after warming up
 
Associate
Joined
5 Jul 2021
Posts
16
Location
UK
I only use the car for a 50 mile commute which is entirely motorway driving. There’s 93000 miles on the odo and 1 previous owner, not sure what they used the car for. The clacking only happens sometimes at low speeds when accelerating, after I put my foot down it goes away and the car runs fine. I bought an OBD reader and the car isn’t sending any codes
 
Man of Honour
Joined
13 Oct 2006
Posts
81,951
Sounds like what my sister had but I can't remember what the code was - basically throttle regulation wasn't getting feedback or something.
 
Soldato
Joined
18 Oct 2002
Posts
4,663
Location
Riding my bike
Hi, not sure if this is the place for this type of post but here it is anyway. Bought a used 2010 Kia Ceed 1.6 diesel a few weeks back and I've noticed an odd clacking noise when accelerating at low speeds.

If bought from a dealer, get them to sort it! Good luck, these things are frustrating!
 
Associate
Joined
16 Jan 2005
Posts
1,829
Location
UK
ASM Car Sales

I guess my approach would be, ask them if they're willing to accept the bill if you were to go to Kia to get it checked out and they found a fault. If so, pay for Kia to do the diagnostic and go from there. If they come back and say it's fine then you've only lost a few quid, if there's a fault then you get it nipped in the bud by the dealer you bought from.
 
Top Bottom