1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

970 EVO SSD - Windows driver / Samsung NVMe driver issue

Discussion in 'Storage Drives' started by Highlander123, Sep 15, 2018 at 9:51 AM.

  1. Highlander123

    Associate

    Joined: Saturday

    Posts: 2

    Hi,

    I've recently installed a Samsung 970 EVO M2 500GB NVMe drive into my ASRock Windows 10 DeskMini H110 PC, and have successfully installed the Samsung NVMe controller without any issues.

    My previous boot-SSD has been migrated successfully too, and everything boots up as I'd expect, but with two specific issues that I'd prefer to address if possible -

    1. When I look in the Device Manager at my 970 EVO, the driver stubbornly stays stuck at a 'Microsoft Driver' (version 10.0.17134.1 - date 21/06/2006). Would I not expect to see a Samsung NVMe driver detailed in the disk properties window, on the driver tab? When I try to carry out any sort of driver update, Windows 10 keeps telling me that I've got the best driver installed.

    2. When I install Samsung Magician, to try to use that utility, it installs fine but when I run it the utility hangs at the 'Scanning for Drive Information' stage. I've left it for over 30 minutes, and nothing changes, so I'm stuck as to what I can do to get the utility working. I've re-installed a number of times.

    Has anyone please got any experience with Samsung SSD issues similar to the above, and were you able to solve any of the two problems that I'm facing?

    I know that performance can be affected if the incorrect SSD configuration is being used by Windows, so given the outlay on my new SSD, I'm keen to ensure that it's set up in the most appropriate way, and the above issues tends to make me think that this might not be the case, so I thought I best check here to see if any of the more experienced people can help on these great forums.

    Thanks very much for any help or advice offered.

    Edit - I should add that having just checked all three of my SSD driver, (two SATA and one M2 NVMe), they all seem to be using the same 'Microsoft Driver' version 10.0.17134.1 - date 21/06/2006. This feels relevant to the above issue, as I'd expect the NVMe SSD driver to have a different one to the other two SATA ones, but perhaps I'm mistaken?

    Kind Regards,

    Highlander 123
     
    Last edited: Sep 15, 2018 at 10:03 AM
  2. mods1965

    Gangster

    Joined: Jul 10, 2014

    Posts: 474

    Location: Searching for dark energy...

    I have the same for mine in device manager, where it shows Windows driver,(same version as you see) rather then the Samsung one. I will investigate further.
    Magician is working for for me, but I had that installed before I installed the Samsung NVMe driver. Maybe uninstall the Samsung driver and check its working, then re-install?

    Edit - checking the install guide for the Samsung driver, it states that to confirm installation worked, look for Storage controllers in device manager and confirm the Samsung NVMe Controller is installed.
    I can see this, so it seems Disk drivers section is not the place to look.
     
    Last edited: Sep 16, 2018 at 7:03 AM
  3. Highlander123

    Associate

    Joined: Saturday

    Posts: 2

    Thanks for taking a look - good to know this isn't just my configuration then, but it's still not clear if it's the correct one.

    I'd certainly be interested to hear if anyone has a Samsung M2 NVMe SSD installed where the driver tab for the SSD states that it's actually 'using' the Samsung NVMe driver, rather than the Windows one we seem to have listed?

    Thanks again for your input - much appreciated.

    Cheers,

    Highlander123