Cisco Configuration help

Associate
Joined
18 Jul 2007
Posts
476
Location
England, Berkshire
Hey guys im going to need some help in a configuration im doing, im not quite sure on some things and will be doing things in steps. i want to get the lan all working first as the next step will be the wan.

Stage 1

I have a cisco 2620xm router and a 2950 switch

2 networks 2 vlans on the switch

Home: 192.168.0.0 vlan 2

Office: 192.168.1.0 vlan 3

current config

Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address 192.168.0.1 255.255.255.0
Router(config-subif)#interface f0/0.3
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#interface f0/0
Router(config-if)#no shutdown

Switch(config-if)#vlan 2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#exit
Switch(config)#interface f0/24
Switch(config-if)#switchport mode trunk

I can sucessfully ping the router from host on either home or office.

Now here is my problem i now need to go round to each of the hosts and set a static address. I dont want that so can i set dhcp on the switch? so each vlan can be set a dynamic ip? or do i have to enable the server to do this?
 
Assuming you have a server with DHCP server elsewhere on the network (ie in the OFFICE vlan), then you can set up scopes for both vlans in there, and set the "ip helper-address" variable on the vlans, eg:

int fa0/0.2
ip address 192.168.0.1 255.255.255.0
ip helper-address 192.168.0.10

int fa0/0.3
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.0.10

This will tell DHCP clients where to be looking for their lease.
 
Okay well right now there is no server, its something that will be ordered soon to go in the office for now i will just have to go with static ip's and then implement the DHCP when the server here.

So thats the lan all setup and happy with that. Now the wan.

Stage 2

I have a adsl wic1 card in the back, the business line is with o2 and i am now replacing the o2 router to the cisco router.

i found this config example (not mine)

version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname scw-gw
!
logging buffered 4096 debugging
logging rate-limit console 10 except errors
enable secret YOURPASSWORD
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
interface Ethernet0
ip address YOURIP YOURNETMASK
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bundle-enable
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp reliable-link
ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password YOURPASSWORD
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
!
ip nat inside source list 1 interface Dialer0 overload
access-list 1 permit YOURNETWORK 0.0.0.255
access-list 10 permit 195.12.1.35
access-list 10 permit YOURNETWORK 0.0.0.255
!
line con 0
transport input none
stopbits 1
line vty 0 4
access-class 10 in
password YOURTELNETPASSWORD
login
!
scheduler max-task-time 5000
end

I have never done a adsl config before so understanding this is going to need some help. I obviously now need to go into the o2 router and pull the details i need to eastablish a connection. can anyone tell me what details i need? obviously the username and password but what else?
 
Could you not set the router to be a dhcp server? is a external server needed?

conf t
service dhcp
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.5 192.168.1.6
exit
ip dhcp excluded-address 192.168.1.1 192.168.1.199
ip dhcp excluded-address 192.168.1.241 192.168.1.255
^Z

just set 2 dhcp pools? for the 2 vlans?
 
O2 is a complete PITA to get working on Cisco routers - I gave up in the end!

Great!... well after looking at the o2 router... its useless gave me no details at all. So went to the o2 website and pulled everything i needed to setup a router o2 has not provided and having them email me the radius username and password

Not sure if i should change any of this?

ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery


this is presume is

interface Ethernet0
ip address YOURIP YOURNETMASK
ip nat inside

interface f0/0.2
address 192.168.0.1 255.255.255.0
ip nat inside
interface f0/0.3
ip address 192.168.1.1 255.255.255.0
ip nat inside


This is to do the adsl, as far as i can see all i need to change is the chaps username and password

interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bundle-enable
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp reliable-link
ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password YOURPASSWORD
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server


Then this is where i add lan networks 192.168.0.1 255.255.255.0 and 192.168.1.1 255.255.255.0

But what is list 10 ip?

ip nat inside source list 1 interface Dialer0 overload
access-list 1 permit YOURNETWORK 0.0.0.255
access-list 10 permit 195.12.1.35
access-list 10 permit YOURNETWORK 0.0.0.255
!
 
For a start, O2 use MAC authentication so you'll need to clone the mac address of the O2 box to the ATM interface

They also dont use the standard 0/38, think it's 0/101
 
As far as i see this bit is near to correct, yet to try it out but until i get the ip addresses where needed ill wait.

interface ATM0 mac-address 0024171931c8
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no atm ilmi-keepalive
dsl operating-mode auto
no shut
interface ATM0.1 point-to-point
description Link to O2 Broadband
ip address 87.194.X.X 255.255.252.0 <----- IP/Mask of Be/O2 Broadband
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
no snmp trap link-status
atm route-bridged ip
pvc 0/101
encapsulation aal5snap
oam-pvc manage
!
create access-list
access-list 1 permit 192.168.0.0 255.255.255.0
access-list 1 permit 192.168.1.0 255.255.255.0
ip nat inside source list 1 interface ATM0.1 overload
!
ip route 0.0.0.0 0.0.0.0 87.194.0.0 <---awaiting broadband details


Im trying to understand bridging the following configuration is showing just one vlan being 2 but i also need to add vlan 3 what do i need to add to have both vlans bridged? also "interface BVI1" what is this?

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
interface BVI1
description my local range
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan2
no ip address
bridge-group 1
!
 
Back
Top Bottom