Hi Chaps,
I am having a problem with setting up a test VPN on a pix.
Ive been over the config and i cant seem to see any thing thats out of place, so i am going to post it here for a fresh set of eyes to look over. As i am getting a wee bit annoyed. LOL
From the log file on the Cisco VPN client i am seeing
del_reason_peer_not_responding errors & ISAKMP OAK AG
So i am guessing this is a problem with the client having problems getting a IPSEC link back to the pix.
Here is the Pix config.
PIX Version 6.1(3)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname aam-pix
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list 201 permit tcp any any eq www
access-list 201 permit tcp any any eq 443
access-list 201 permit udp any any eq domain
access-list 201 permit tcp any any eq smtp
access-list 201 permit tcp any any eq ftp
access-list 201 permit udp any any eq ntp
access-list 201 permit tcp any any eq 123
access-list 150 permit tcp any host x.x.x.x eq 443
access-list 150 permit tcp any host x.x.x.x eq www
access-list 150 permit tcp any host x.x.x.x eq smtp
access-list 150 permit tcp any host x.x.x.x eq 3389
access-list 150 permit tcp any host x.x.x.x eq ftp
access-list 150 permit tcp any host x.x.x.x eq 123
access-list 150 permit udp any host x.x.x.x eq ntp
access-list 101 permit ip 192.168.1.0 255.255.255.0 172.16.0.0 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap warnings
logging history warnings
logging host inside 10.0.0.16
logging host inside 192.168.0.1
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool aam-vpnip 172.16.0.1-172.16.1.254
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface ftp 192.168.1.2 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 192.168.1.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask 255.255.255.255 0 0
access-group 150 in interface outside
access-group 201 in interface inside
route outside 0.0.0.0 0.0.0.0 135.196.1.81 1
route inside 172.16.0.0 255.255.255.0 192.168.1.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set aamvpn esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set aamvpn
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup aam-vpn address-pool aam-vpnip
vpngroup aam-vpn dns-server 192.168.1.2
vpngroup aam-vpn wins-server 192.168.1.2
vpngroup aam-vpn default-domain aamtest.co.uk
vpngroup aam-vpn idle-time 3600
vpngroup aam-vpn password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
terminal width 255
Thanks
Andy
I am having a problem with setting up a test VPN on a pix.
Ive been over the config and i cant seem to see any thing thats out of place, so i am going to post it here for a fresh set of eyes to look over. As i am getting a wee bit annoyed. LOL
From the log file on the Cisco VPN client i am seeing
del_reason_peer_not_responding errors & ISAKMP OAK AG
So i am guessing this is a problem with the client having problems getting a IPSEC link back to the pix.
Here is the Pix config.
PIX Version 6.1(3)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname aam-pix
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list 201 permit tcp any any eq www
access-list 201 permit tcp any any eq 443
access-list 201 permit udp any any eq domain
access-list 201 permit tcp any any eq smtp
access-list 201 permit tcp any any eq ftp
access-list 201 permit udp any any eq ntp
access-list 201 permit tcp any any eq 123
access-list 150 permit tcp any host x.x.x.x eq 443
access-list 150 permit tcp any host x.x.x.x eq www
access-list 150 permit tcp any host x.x.x.x eq smtp
access-list 150 permit tcp any host x.x.x.x eq 3389
access-list 150 permit tcp any host x.x.x.x eq ftp
access-list 150 permit tcp any host x.x.x.x eq 123
access-list 150 permit udp any host x.x.x.x eq ntp
access-list 101 permit ip 192.168.1.0 255.255.255.0 172.16.0.0 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap warnings
logging history warnings
logging host inside 10.0.0.16
logging host inside 192.168.0.1
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool aam-vpnip 172.16.0.1-172.16.1.254
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface ftp 192.168.1.2 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 192.168.1.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask 255.255.255.255 0 0
access-group 150 in interface outside
access-group 201 in interface inside
route outside 0.0.0.0 0.0.0.0 135.196.1.81 1
route inside 172.16.0.0 255.255.255.0 192.168.1.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set aamvpn esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set aamvpn
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup aam-vpn address-pool aam-vpnip
vpngroup aam-vpn dns-server 192.168.1.2
vpngroup aam-vpn wins-server 192.168.1.2
vpngroup aam-vpn default-domain aamtest.co.uk
vpngroup aam-vpn idle-time 3600
vpngroup aam-vpn password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
terminal width 255
Thanks
Andy
Last edited: