1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Freecom Classic SL Network drive - not picked up by macbook

Discussion in 'Linux & Open Source' started by uchuff, 3 Jun 2006.

  1. uchuff

    Wise Guy

    Joined: 30 Jul 2003

    Posts: 2,264

    Hi all,
    A month or so ago I bought a 250GB Freecom Classic SL Network Drive which has been working fairly reliably with my XP PC since. A couple of weeks ago I got a shiny new Macbook and cannot seem to get the drive detected, has anyone purchased one of these drives and got them working with an intel Mac?

    Using the latest Tiger drivers from the Freecom site it just sits there with the progress disc spinning after entering the code in.
     
  2. uchuff

    Wise Guy

    Joined: 30 Jul 2003

    Posts: 2,264

    I realise this is a really old topic but I thought I'd post back just incase someone else has one of these. No response from Freecom to my email however I also contacted Ximeta, they hold the patent for the NDAS tech this drive uses - they very kindly gave me some Beta intel Mac drivers which seem to be working great.
     
  3. MagSafe

    Wise Guy

    Joined: 12 Aug 2004

    Posts: 1,009

    Location: Glasgow, Scotland

    is it formatted correctly? thats the only thing I can think of :confused:
     
  4. uchuff

    Wise Guy

    Joined: 30 Jul 2003

    Posts: 2,264

    Like I said it's sorted now thanks. Freecom don't seem to be in a hurry to release intel Mac drivers... or reply to my emails.
     
  5. MagSafe

    Wise Guy

    Joined: 12 Aug 2004

    Posts: 1,009

    Location: Glasgow, Scotland

    oh ok, guess i didn't see that bit :p

    glad to hear its working now :)