Networking question. Cisco and 3com / VLANS

Soldato
Joined
17 Oct 2002
Posts
2,956
Location
Cold Scotland :(
Got a quick question, hope someone can verify my thoughts and correct me if I am wrong! :)

We have a Cisco 3560 at the core of one of our networks, doing L3 etc. There is a VLAN for servers on VLAN 100 (10.220.0.0).

I have a need to build another segment of servers but on a different subnet to VLAN 100 servers. These are in VLAN 300 (10.225.0.0) and are a Hyper-V cluster.

What I would like to do is have the Hyper-V guest VM's to be on VLAN100 network, without needing a separate switch just for it.

I think the following would work, can anyone confirm?

Code:
On Cisco 3560X:

interface gi0/16
description Trunk Link to Cabinet RS4 g1/0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk native vlan 300

On 3com 5500:

interface g1/0/24
description Trunk Link to Core Cisco gi0/16
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 300


For individual ports on 3com 5500:

interface g1/0/1
description Link to HyperV Server 1
port link-type hybrid
port hybrid pvid vlan 300
port hybrid vlan 300 untagged
port hybrid vlan 100 tagged

This should allow all VLANs over the connection (Trunk) between the two switches, with the Native VLAN set to 300 so that any traffic sent over that is not tagged to a VLAN will be in VLAN 300.

Traffic that leaves port g1/0/1 (for example) on the 3com switch that is not tagged by the server will be on VLAN 300. This port will also allow traffic to leave the port that has been tagged by the server to be on VLAN 100 specifically.

I was reading up and Hyper-V virtual networks are in "trunking mode" by default, and we just need to specify per-VM what VLAN it should be on.
http://social.technet.microsoft.com...hyper-v-configure-vlans-and-vlan-tagging.aspx

Edit: I realise I might be able to just do a port link-type trunk on the 3com g1/0/1 interface as well, rather than a Hybrid.

Cheers
Dave
 
Best practice is to keep your VM storage on separate switching to your data networks. (If I've read it correctly, I've been over your post a few times but I think that's what you're trying to do?)

It will work, but you will have problems.
 
Last edited:
Sorry, it was late, perhaps I didn't explain it good :D

Our storage network is completely separate switches. This setup is for normal IP traffic to our Hyper-V guest virtual machines. Basically I want to be able to create new Virtual Machines and have them on either the 10.225.0.0 network by default or be able to VLAN TAG (VLAN100) them onto 10.220.0.0 network using the Hyper-V VLAN TAG feature for each VM.
 
Assuming you want VLAN300 as the native VLAN then that looks fine as far as the switch goes, though I am not familar with tagging in Hyper-V.

You could use a trunk, though one of the benefits of a hybrid port is that you can have multiple VLANs untagged on that port, whereas on a trunk you can only have 1 VLAN untagged.In saying that, I have yet to encounter a situation where I would actually want to do this.

Personally I prefer not to use "port trunk permit vlan all" - rather "port trunk permit vlan 100 300" in your case...IE, permit only the VLANs you have/want over the link. Can make it easier at a later date if you end up with more VLANs than that and not wanting them all to pass over the trunk.

Personally I stick to only using trunk for switch to switch comms and hybrid for edge devices (phones and PCs mostly where i'm concerned)
 
Last edited:
Back
Top Bottom