1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible display issue?

Discussion in 'Windows & Other Software' started by slipd, 13 Sep 2021.

  1. slipd

    Mobster

    Joined: 26 Feb 2004

    Posts: 4,426

    Location: Hampshire

    Hi guys,

    Fairly new monitor/gpu set up here, so I'm not sure if I've got faulty kit... I hope not! A Dell S2721DGFA and a 3060ti FE pairing.



    It's also only something that I notice in Windows? On the taskbar, mostly when I'm closing an app or window. It feels like something is glitching? I've not noticed a thing whilst gaming.

    Thoughts?
     
  2. IC3

    Sgarrista

    Joined: 3 Dec 2011

    Posts: 9,566

    Uninstall drivers with DDU and reinstall them, make sure you use stable release of the drivers. I had this issue before, you can also try changing the drivers version.

    Another thing to try is to try a different cable.
     
  3. slipd

    Mobster

    Joined: 26 Feb 2004

    Posts: 4,426

    Location: Hampshire

    Thanks! Yep, the issues is definitely graphics driver related... I came from an AMD card but only ran the Catalyst uninstaller before installing the Nvidia drivers.

    My rig is completely clean now, thanks to DDU. Just need to reinstall the Nvidia drivers tonight.
     
  4. slipd

    Mobster

    Joined: 26 Feb 2004

    Posts: 4,426

    Location: Hampshire

    I've gone back to a May '21 driver and all is well... I used DDU - what a great little app :)

    I've not installed the Nvidia Experience app, could that have been the issue?
     
  5. IC3

    Sgarrista

    Joined: 3 Dec 2011

    Posts: 9,566

    Nope, it was the AMD ***** leftover that Catalyst never uninstalls...
     
  6. slipd

    Mobster

    Joined: 26 Feb 2004

    Posts: 4,426

    Location: Hampshire

    Ha, you're probably right! I'm half tempted to reinstall the latest drivers then, less Nvidia Experience?