Replacing the BT OpenReach Modem with Cisco 800 (TalkTalk fibre)

Associate
Joined
28 May 2015
Posts
27
Location
London
Hi,

I want to replace an OpenReach fibre modem and a TalkTalk Huawei (HG533) router with a Cisco 877VA. Replacing just the TalkTalk router was easy enough and it worked fine but I also want to get rid of the modem. Whenever I put the DSL line into the Cisco I cannot get an external IP, although 'show controllers vdsl 0' shows the line information correctly (VDSL2, sync speed etc).

Debugging PPP suggests that authentication is failing but I do not have a username and password to use. Leaving this blank or putting in dummy information does not work. See below for the debug output.

Does anyone have any idea what else I can try?

Code:
May 28 20:59:02.515: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
May 28 20:59:02.519: PPPoE: cannot get sb in ethernet set vectors
May 28 20:59:02.523: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May 28 20:59:02.523: Vi1 PPP: Using dialer call direction
May 28 20:59:02.523: Vi1 PPP: Treating connection as a callout
May 28 20:59:02.523: Vi1 PPP: Session handle[CC000009] Session id[9]
May 28 20:59:02.523: Vi1 PPP: No remote authentication for call-out
May 28 20:59:02.547: Vi1 PPP: No authorization without authentication
May 28 20:59:02.559: Vi1 CHAP: I CHALLENGE id 1 len 31 from "npe001.bre"
May 28 20:59:02.559: Vi1 PPP: Sent CHAP SENDAUTH Request
May 28 20:59:02.559: Vi1 PPP: [B]Received SENDAUTH Response FAIL[/B]
May 28 20:59:02.559: Vi1 CHAP: Using hostname from interface CHAP
May 28 20:59:02.559: Vi1 CHAP: Using password from interface CHAP
May 28 20:59:02.559: Vi1 CHAP: O RESPONSE id 1 len 46 from "[email protected]"
May 28 20:59:02.595: Vi1 CHAP: I FAILURE id 1 len 41 msg is "CHAP authentication failure, unit 270"
May 28 20:59:02.731: PPPoE: Failed to add PPPoE switching subblock
May 28 20:59:02.731: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
May 28 20:59:02.735: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
May 28 20:59:02.735: PPPoE: Unexpected Event!. PPPoE switching Subblockdestroy called

Appreciate any help.
 
I've not had experience of this Cisco unit but have had trouble with other fibre modem/routers and BT lines. The 877 is quite old isn't it (now discontinued) it's possible BT have made changes that means it won't work.

Andi.
 
Can you paste up your config (remove anything sensitive)?

I'll take a looksie.

Sure, see below for any bits I believe are relevant. VLAN2 and Fa3 are not used in this configuration and yes I know my NAT is overloading the wrong interface but I don't believe that's the problem.

And yep, meant 887VA :)

Code:
!
controller VDSL 0
!
!
interface Ethernet0
 no ip address
 no fair-queue
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 switchport access vlan 2
 no ip address
!
interface Vlan1
 ip address 10.11.12.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan2
 description outside
 ip address dhcp
 ip virtual-reassembly in
!
interface Dialer0
 mtu 1492
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp ipcp address accept
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface Vlan2 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 1 permit 10.11.12.0 0.0.0.255
!
!
 
Ok, well I think you are at least missing the "ip address negotiated" from your Dialer0 interface, the "no ip address" might be a bit of a giveaway as to why you aren't getting an IP :p

And I can't see any ppp authentication configuration anywhere?
 
I have been in the process of creating a config for my 1921, this should get it up and running for you:

Code:
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outisde
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname [I]ADD HOSTNAME HERE[/I]
 ppp chap password [I]ADD PASSWORD HERE[/I]
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
!

EDIT:

To find out your broadband credentials for authentication, take a look here:

http://help2.talktalk.co.uk/check-your-broadband-password
 
Last edited:
Doh, not sure why 'no ip add' is in that output, I'm sure I was testing it with the 'ip address negotiated' command.

I removed the 'ppp chap username/password' commands as the dummy entries I had in there weren't working.

So that site gives me a username but I don't have a analogue phone to call the number with :) I called TalkTalk and they told me because i'm on fibre there is no username and password.
 
Doh, not sure why 'no ip add' is in that output, I'm sure I was testing it with the 'ip address negotiated' command.

I removed the 'ppp chap username/password' commands as the dummy entries I had in there weren't working.

So that site gives me a username but I don't have a analogue phone to call the number with :) I called TalkTalk and they told me because i'm on fibre there is no username and password.

Try the commands I have posted but instead of actually having a username or password have you tried them as blanks?

So keep the commands but don't put a username or a password.
 
IOS won't accept those commands. By default I believe PPP uses the router name as the hostname anyway.

Code:
router(config-if)#ppp chap hostname
% Incomplete command.

router(config-if)#ppp chap password
% Incomplete command.
 
IOS won't accept those commands. By default I believe PPP uses the router name as the hostname anyway.

Code:
router(config-if)#ppp chap hostname
% Incomplete command.

router(config-if)#ppp chap password
% Incomplete command.

Try just a blank (empty string) for each. To see if that works.
 
No luck, commands not accepted :) I'll try using my TalkTalk username and password but need to wait until I can take down the Internet, so will confirm later tonight.

Thanks for your help so far.
 
So I put in the following config.

Code:
controller VDSL 0
!
!
interface Ethernet0
 no shut
 no ip address
 no fair-queue
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname [email protected]
 ppp chap password 0 Password123
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
!

And got the same result.

Code:
May 29 23:28:51.911: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
May 29 23:28:51.919: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May 29 23:28:52.151: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
May 29 23:28:52.155: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

Code:
May 29 23:36:55.946: Vi1 PPP: Using dialer call direction
May 29 23:36:55.946: Vi1 PPP: Treating connection as a callout
May 29 23:36:55.946: Vi1 PPP: Session handle[5B000019] Session id[25]
May 29 23:36:55.982: Vi1 PPP: No authorization without authentication
May 29 23:36:55.994: Vi1 CHAP: I CHALLENGE id 1 len 31 from "npe001.bre"
May 29 23:36:55.998: Vi1 PPP: Sent CHAP SENDAUTH Request
May 29 23:36:55.998: Vi1 PPP: Received SENDAUTH Response FAIL
May 29 23:36:55.998: Vi1 CHAP: Using hostname from interface CHAP
May 29 23:36:55.998: Vi1 CHAP: Using password from interface CHAP
May 29 23:36:55.998: Vi1 CHAP: O RESPONSE id 1 len 46 from "[email protected]"
May 29 23:36:56.034: Vi1 CHAP: I FAILURE id 1 len 40 msg is "CHAP authentication failure, unit 59"

And here is the output of 'show controller vdsl 0'.

Code:
Controller VDSL 0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'BDCM'
Chip Vendor Specific:   0x0000                   0xA459
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    FCZ162492M0 887VA-SE 15.1(4)M
Serial Number Far:
Modem Version Near:    15.1(4)M
Modem Version Far:     0xa459

Modem Status:            TC Sync (Showtime!)
DSL Config Mode:         AUTO
Trained Mode:            G.993.2 (VDSL2) Profile 17a
TC Mode:                 PTM
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running
Trellis:                 ON                       ON
Line Attenuation:         0.0 dB                  0.0 dB
Signal Attenuation:       0.0 dB                  0.0 dB
Noise Margin:            16.6 dB                 29.6 dB
Attainable Rate:        79704 kbits/s            23526 kbits/s
Actual Power:            14.2 dBm                - 6.7 dBm
Per Band Status:        D1      D2      D3      U0      U1      U2      U3
Line Attenuation(dB):   5.8     12.8    19.7    2.6     10.3    15.3    N/A
Signal Attenuation(dB): 5.8     12.8    19.7    2.6     9.6     13.8    N/A
Noise Margin(dB):       16.6    16.7    16.5    29.7    29.5    29.6    N/A
Total FECS:             0                        0
Total ES:               0                        0
Total SES:              0                        0
Total LOSS:             0                        0
Total UAS:              0                        0
Total LPRS:             0                        0
Total LOFS:             0                        0
Total LOLS:             0                        0
Bit swap:               0                        1

Full inits:             1
Failed full inits:      0
Short inits:            0
Failed short inits:     0

Firmware        Source          File Name (version)
--------        ------          -------------------
VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:      110506_1916-4.02L.03.A2pv6C032b.d23i
Modem PHY Version:      A2pv6C032b.d23i


                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            39999             0              1999
Previous Speed:           0                0             0                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Interleave (ms):       0.00             0.00          0.00              0.00
Actual INP:            2.01            47.00          0.00              0.00

Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

I'm starting to wonder if this is at all possible with TalkTalk :)
 
Can you show the output of:

show ip int brief
show version

EDIT:

Ok two more options, first of all try:

Code:
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outisde
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname [email protected]
 ppp chap password [B]ADD BLANK SPACE HERE[/B]
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
!

If that doesn't work I'm just making a guess here but try this:

Scrap the Dialer interface completely. Remove it from the config and then change the Ethernet sub interface to this:

Code:
!
interface Ethernet0
 no shut
 no ip address
 no fair-queue
!
interface Ethernet0.101
 encapsulation dot1Q 101
 ip address dhcp
 ip nat outside
!

Cheers :)
 
Last edited:
Genius, the second option worked! The relevant bits of the final config are.

Code:
interface Ethernet0
 no ip address
 no fair-queue
 no shut

interface Ethernet0.101
 encapsulation dot1Q 101
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in

ip nat inside source list 1 interface Ethernet0.101 overload

Thanks for your help, much appreciated!

So does this mean this is not a PPP connection? And all you need to do is encapsulate the right VLAN and you're good to go?
 
Genius, the second option worked! The relevant bits of the final config are.

Code:
interface Ethernet0
 no ip address
 no fair-queue
 no shut

interface Ethernet0.101
 encapsulation dot1Q 101
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in

ip nat inside source list 1 interface Ethernet0.101 overload

Thanks for your help, much appreciated!

So does this mean this is not a PPP connection? And all you need to do is encapsulate the right VLAN and you're good to go?

No problem mate, I know what a nightmare Cisco gear can be for residential uses (coming from someone that has worked for Cisco lol). I am still having on-going issues getting the right config for my setup.

You are correct though it isn't using PPP at all which I think is relatively unusual for VDSL connections. And yes it's just a matter of obtaining the public IP through DHCP and encapsulating the VLAN correctly.

Thanks :)
 
Back
Top Bottom