3600mhz ram shows as 2666mhz

Associate
Joined
4 Feb 2021
Posts
1
Hi,
I've just build a new pc.

Specs:

GPU: RTX 3070 ASUS STRIX
CPU: ryzen 5 5600x
RAM : PATRIOT viper gaming 2x16gb 3600mhz
Motherboard: aorus b550 elite v2
Ssd 250gb Samsung evo ssd and adata 1tb ssd



The problem is the ram shows as 2666 instead of 3600mhz.

I've tried to set it in bios for XMP but after save and exit when I get to windows mainscreen screen starts to blink and after like 20sec it's black and I have to restart it then same thing happen again .


Did some research online and tried to adjust voltage of DRAM and SOC but no luck, same thing happened.


I wonder if I should return ram memory and get different brand? Never had such problem before. Would you be able to help folks? Would appreciate

Cheers
 
Soldato
Joined
6 Jan 2012
Posts
3,815
Hi,
I've just build a new pc.

Specs:

GPU: RTX 3070 ASUS STRIX
CPU: ryzen 5 5600x
RAM : PATRIOT viper gaming 2x16gb 3600mhz
Motherboard: aorus b550 elite v2
Ssd 250gb Samsung evo ssd and adata 1tb ssd



The problem is the ram shows as 2666 instead of 3600mhz.

I've tried to set it in bios for XMP but after save and exit when I get to windows mainscreen screen starts to blink and after like 20sec it's black and I have to restart it then same thing happen again .


Did some research online and tried to adjust voltage of DRAM and SOC but no luck, same thing happened.


I wonder if I should return ram memory and get different brand? Never had such problem before. Would you be able to help folks? Would appreciate

Cheers
Have you disabled XMP and set manually to 3600? Then run Memtest.
 
Soldato
Joined
22 Jun 2006
Posts
5,234
Try manually setting frequency to 2933 (use board defaults for timings) and DRAM voltage to 1.35v, then go up from there.
 
Soldato
Joined
18 May 2010
Posts
21,568
Location
London
What I would do is set the XPM/DOCP profile and then slowly up the dram voltage until it works.

If your ram is rated at 1.35v increment this value by one until it works.
 
Top Bottom