• Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

4870x2 problem? urgent help

Soldato
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
Hello, when I first got my 4870x2 I had no problems with it. It would happily sit with fan speed set to 35% and cruise around 48 degress. It seems to have got a lot worse over the last few weeks where now one core idles at 65 degrees with fan speed at 50%, the other at 48degrees. This I can tolerate.

What I can't tolerate is that when its put on load, this temperature rapidly shoots up to 95 degrees and this by just going through the menu screens on Cod4!!! The auto cooling kicks in and whacks the fan speed up and cools it to 90degrees, and thus the cycle continues.

Is my card just set up wrong? Also (noob question) does running dual monitors affect my card performance? Any advice to lower the temperatures would be greatly appreciated as I am quite worried about it thanks.
 

RJC

RJC

Don
Joined
29 May 2005
Posts
28,932
Location
Kent
Mine idles at 60c ~ with load temps of 89c ~ with the fan pretty much full wack.

Mind you I do have a slight problem now though, might need to do a thread.

On with your help :) does your heatsink need blowing out due to dust, any filters on your case need blowing out.
 
Associate
Joined
1 Dec 2007
Posts
1,471
Mines on idle at 69 at 27%fan speed...its the 9.9 drivers i think...it ramps up ok when gaming and i get no graphic problems...don't worry!
 
Soldato
OP
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
Blown all the dust out and everything. Still at 50% fan speed im getting 60 degrees and I dont want to put the fan any quicker as its quite loud!
 
Permabanned
Joined
18 Feb 2008
Posts
266
Hello, when I first got my 4870x2 I had no problems with it. It would happily sit with fan speed set to 35% and cruise around 48 degress. It seems to have got a lot worse over the last few weeks where now one core idles at 65 degrees with fan speed at 50%, the other at 48degrees. This I can tolerate.

What I can't tolerate is that when its put on load, this temperature rapidly shoots up to 95 degrees and this by just going through the menu screens on Cod4!!! The auto cooling kicks in and whacks the fan speed up and cools it to 90degrees, and thus the cycle continues.

Is my card just set up wrong? Also (noob question) does running dual monitors affect my card performance? Any advice to lower the temperatures would be greatly appreciated as I am quite worried about it thanks.


make sure you got good ventilation in the tower.

if your confident enough remove the cooler and stick some mx2 paste on.
 
Soldato
OP
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
Its an Antec 900 case and all the fans are working and it seems fairly cool air coming out. Also why is one GPU considerably hotter than the other?
 
Associate
Joined
1 Dec 2007
Posts
1,471
Because one is closer to the fan i think..i have an antec 900 to..50% fan gives me 34 degrees.
 
Associate
Joined
18 Oct 2002
Posts
379
Location
London
I found that the standard ATI drivers didn't do a very good job of auto-controlling the fan, allowing the card to run too hot. I switched to Rivatuner to control the fan and it was a lot better. Check out this guide for Rivatuner and ATI 48xx cards

http://www.hardforum.com/showthread.php?t=1345181

I now have an Arctic Cooling Accelero Xtreme cooler on it and it's even better, quieter and cooler.
 
Permabanned
Joined
18 Feb 2008
Posts
266
I found that the standard ATI drivers didn't do a very good job of auto-controlling the fan, allowing the card to run too hot. I switched to Rivatuner to control the fan and it was a lot better. Check out this guide for Rivatuner and ATI 48xx cards

http://www.hardforum.com/showthread.php?t=1345181

I now have an Arctic Cooling Accelero Xtreme cooler on it and it's even better, quieter and cooler.

great cooler
 
Soldato
OP
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
Ok, I've just had a go on Cod4, activity hovers around 40% and the temps climb all the way too 100 degrees and the fan switches to 90%. It never used to do this yet its got slowly worse since I bought it.
 
Soldato
Joined
24 Aug 2009
Posts
2,927
hmmm the gpu will be hotter because its 2 gpu's. Also, gpu tend to be higher than other parts in your pc. One last thing, whats the temperature like in your room as that can have a massive effect. My 8800gt idle's at 45 then when the heating is on, idles at 55 c
 
Soldato
Joined
24 Aug 2009
Posts
2,927
hmmm, 100 is to high for that card. I think compressing the dust out of it would help, and mabey removing the head sink and adding artic paste 5.
 
Soldato
OP
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
There doesnt seem to be a lot of air flow coming out of the back of the card (out the back of the pc when the cables plug in), and the flow rate doesn't noticably change with fan speed. could that be clogged? I assumed the air was merely blown onto the GPU and didn't realise it vented out the back too. Is that right?
 
Associate
Joined
14 Jun 2008
Posts
2,363
Hello, when I first got my 4870x2 I had no problems with it. It would happily sit with fan speed set to 35% and cruise around 48 degress. It seems to have got a lot worse over the last few weeks where now one core idles at 65 degrees with fan speed at 50%, the other at 48degrees. This I can tolerate.

What I can't tolerate is that when its put on load, this temperature rapidly shoots up to 95 degrees and this by just going through the menu screens on Cod4!!! The auto cooling kicks in and whacks the fan speed up and cools it to 90degrees, and thus the cycle continues.

Is my card just set up wrong? Also (noob question) does running dual monitors affect my card performance? Any advice to lower the temperatures would be greatly appreciated as I am quite worried about it thanks.

I would suggest opening up the card and cleaning out the heatsinks. ATI use comically small heatsinks on the x2, so even a mild dust build-up will cause things to get toasty. http://homepages.nildram.co.uk/~layte/pics/IMG_0065.JPG

I replaced the stock cooler with the Arctic Cooling part, an amazing diffrerence in heat and noise. http://homepages.nildram.co.uk/~layte/pics/furmark.png
 
Caporegime
Joined
26 Dec 2003
Posts
25,675
I had same problem with 4870x2 when gaming with v-sync on, fan speed was up and down like a yoyo.
 
Soldato
OP
Joined
22 Sep 2008
Posts
9,835
Location
Burscough
Hmmm it may well be the heat sinks. There doesn't appear to be much air flowing out of the back at all to be honest although on looking at the face of it and shining a torch in, there doesnt appear to be a lot. Does anyone have any advice for taking the cover off the back etc? Just dont wanna unscrew things only to have bits "fall out" and me not know where they go back etc, things like that.

I am useless with computers, apologies for noobness. The pics you show fo the heat sinks looks like what I can see through the vent out the back (cant see much). that one is the heat sink near the gpu furthest away from the fans, which gets hottest. Maybe the dust has clogged the one near the fan preventing air flowing through the second heat sink and out the back? Hence why I cant feel much air venting out the back?

Can anyone else feel much airflow through the vent? Also, I can feel a lot of air coming from the fan, seemingly blowing away from the gpu. This seems to indicate that there may be a dust clog near the heat sink near the fan......hmmmmm.....
 
Top Bottom