Advice Please?

Soldato
Joined
13 Dec 2006
Posts
6,882
Location
On the forest moon Endor
Good mate of mine's got himself a 5 series Beemer and tell's me he's just had the abs and asc lights light up on the dash on the way home tonight, they dont go out and are still on after restarting the car. comon thing seems to be wheel sensor as he had that issue before with the car braking randomly itself lol.

So is it best to get a diag on a computer at our local garage?

Also while he was driving home tonight he heard a beeping coming from what sounded like the back right speaker (put the window down and realised it was the car alarm)

As you can aprreciate problems with brakes on a car this big would cause some concern - it needs to stop :p
 
Soldato
Joined
18 Jan 2004
Posts
9,306
Location
Sunny Scotland
well its in the garage just now, they seem to think the alarm going off is a seperate issue even though its only started with abs thing.

few hours to find out and run full diagnostics :( shall update later with how much this is going to cost me
 
Man of Honour
Joined
17 Oct 2002
Posts
159,613
Issue I have heard on with these is that the intensive wash fluid reservoir can leak fluid onto the DSC control unit which sits below it..
 
Soldato
Joined
18 Jan 2004
Posts
9,306
Location
Sunny Scotland
Just got back, Cost total £86 quid

Found 3 Fault codes present

  • 32 wheel speed sensor O/S/F
  • 06 wheel speed signal O/S/F
  • 67 Cont. Control due to interference

The alarm was bad, it had built up so many errors over time it thought all the sensors was faulty, all are fine according to garage. 8 found so he cleared the memory and the other faults, taken for 2 extended test drives no issues and no lights and alarm is working and no further faults reported.

He did say if it comes up again we need to replace sensor cost £115 inc vat and labour does that sound reasonable?
anyone any idea what the interference issue is and was that a good price for what I had done? cheers.
 
Back
Top Bottom