AMD Chipset Drivers Not Installing?

Associate
Joined
4 Jul 2008
Posts
1,609
Location
Belfast, N.Ireland
Hello Folks,

I have tried to install the AMD Chipset drivers numerous times and for some reason they aren't installing fully. They install everything bar the Power Plan.

But the Chipset Drivers don't show up on my Apps & Features area on Windows 11. So I gather they are not being installed at all. Does anyone know a fix for this?


5osMW2p.jpg

cltYgoQ.jpg
 
Soldato
Joined
18 May 2010
Posts
21,566
Location
London
Try disabling your antivirus and then try to install.

This was a known issue a while ago, which I also had experience with. But I thought this was now fixed.

---

What CPU are you running?

The power plan is for everything other than the 5000 series.

When installing the drivers with a 5000 series chip the power plan is now part of the default windows balanced plan.
 
Soldato
Joined
31 Jul 2003
Posts
3,644
Location
Somewhere far.
I can't seem to get the power plans to install on Windows 11 either. I've not checked if it's actually installing the drivers actually, will have a look tonight.

edit: that's on a 3700x
 
Associate
Joined
9 Aug 2016
Posts
186
Same here. It won't install the AMD Power plan or PSP driver. Everything else it says OK but not sure if it actually installed anything. I have a 3800X
 
Associate
Joined
15 Feb 2017
Posts
1,401
Location
the ghetto
I'm pretty sure i had AI Suite 3 prevent me from installing the amd chipset drivers, from what i remember it also took over power plans and had options inside AI suite.

Try doing it after you (good luck) fully uninstall AI suite 3.
 
Soldato
Joined
13 Mar 2007
Posts
11,310
Location
South Yorkshire
Didn't AMD get rid of their power plans several years ago after the 2 series launch as it was no longer required? I can't remember the last time I saw AMD power plans on my Windows 10 pc and have installed every chipset update since.
 
Top Bottom