Blue-Youtube

Associate
Joined
14 Jun 2010
Posts
737
Afternoon,

I did a system update yesterday and installed lots of new packets onto my Arch install, but I think one of them has bugged out Youtube.

It is a very strange bug, all colours turn towards blue, but only if I am watching it fullscreen or in the "Main window." The thumbnails of related videos to the right all have normal colours- until I click on them, at which point their colours turn blue. I have tried the usual suspect of re-installing flash, and a google around but no one seems to have this problem.

This problem also only seems to happen on Youtube as other video sites are fine, as is my normal browsing.

Would be great if anyone could help, I don't fancy watching "Smurf-O-Vision" all the time. :)
 
Associate
OP
Joined
14 Jun 2010
Posts
737
Just had a look through that post, there seem to be mixed opinions- some have applied a "Patch" created by a developer but it doesn't seem to work for everyone.

Seemingly the best option is to downgrade from 11.2 (beta) to 11.1- but now I need to find a package containing it.

The problem seems to be very much on Adobe's end. :(
 
Soldato
Joined
7 Jul 2009
Posts
16,234
Location
Newcastle/Aberdeen
I got this too.

IqACSl.png


Can't remember if i was using HTML5 at the time, maybe it doesn't do it for every video. I think the blue tint was related to a certain upload file format? Since even when i knew i was using HTML5 or flash it wasn't for every video, but it was the same videos each time.

The simplest fix i came up with is to right click a video, go to settings and uncheck "enable hardware acceleration". You might not actually be able to click on the box in chrome, but if you switch to Firefox or another browser and do it then it will still work.
 
Soldato
Joined
7 Jul 2009
Posts
16,234
Location
Newcastle/Aberdeen
Well considering they've dropped support for Linux after the latest release i don't really think they give a ****, to put it bluntly. I just hope that HTML5 can fill the gap before the outdated release starts to become a problem.
 
Associate
OP
Joined
14 Jun 2010
Posts
737
Disabling hardware acceleration through the options menu no longer seems to work, as soon as I bring up the settings page on the video the settings don't respond- I have to refresh the page. :(
 
Soldato
Joined
7 Jul 2009
Posts
16,234
Location
Newcastle/Aberdeen
You mean it went back? That shouldn't happen, you should only have to to it once... have you tried in a different browser? As i said it didn't work for me in Chrome but it did in Firefox.
 
Associate
OP
Joined
14 Jun 2010
Posts
737
Seemingly it is a bit random as to when I can or can't change the option.

After a system restart the option to not use hardware acceleration is reset to using it.

I'm on Chromium. Hopefully a patch will come around soon.
 

SMN

SMN

Associate
Joined
2 Nov 2008
Posts
2,487
Location
The ether
Just a bump on this guys, its been peeing me off so i did some tinkering this morning and ive found a stable fix. I tried all the suggestions on bbs.archlinux.org, changing hwaccel to 1 in /etc/adobe/mms.cfg, etc which fixed the blue issue but then my "shockwave flash player" crashed every time i tried to run a video pretty much.

So did the following (64 bit system):
1. "sudo pacman -R flashplugin"
2. "yaourt flashplugin"
3. "11" (which is aur/lib32-flashplugin10 10.3.183.15-1)

This gave me a much better looking /etc/adobe/mms.cfg for a start. I then uncommented EnableLinuxHWVideoDecode=1 and voila, stable and not blue. Give it a go if you have the same issues.
 
Top Bottom