Cisco 1921 with EHWIC-VA-DSL-A on FTTC

Had a closer look at mine, seems it ramps up to medium fan speed around 30 degrees. Using my phone meter suggests it is about ~50dB within 3" of the intake. 2 feet away this falls to ~35dB.

Here is the environment output for my unit.

Code:
SYSTEM POWER SUPPLY STATUS
==========================
 Power Supply Type: AC
 External Power Supply POE -48V Voltage Status: Not Present

SYSTEM FAN STATUS
=================
 Fan 1 OK, fan level 2, Medium speed setting, 4064 RPM, 47% PWM

SYSTEM TEMPERATURE STATUS
=========================
 Intake Right temperature: 28 Celsius, Normal
 Intake User temperature: 32 Celsius, Normal
 Exhaust Fan temperature: 36 Celsius, Normal
 Intake Right(Bezel) temperature: 31 Celsius, Normal

REAL TIME CLOCK BATTERY STATUS
==============================
 Battery OK (checked at power up)

SYSTEM ALARMS SETTINGS
======================
 System fan failure results in warning
 Intake Right Over Temperature Alarm = 42C
 Intake User Over Temperature Alarm = 42C
 Exhaust Fan Over Temperature Alarm = 75C
 Intake Right(Bezel) Over Temperature Alarm = 42C

SYSTEM VOLTAGES
===============
 12V voltage = 12.228 V, Normal
 5V voltage = 5.125 V, Normal
 3.3V voltage = 3.318 V, Normal
 2.5V voltage = 2.480 V, Normal
 1.8V voltage = 1.808 V, Normal
 1.2V voltage = 1.199 V, Normal
 CPU/ASIC voltage = 1.023 V, Normal

SYSTEM POWER
===============
 Motherboard Components Power consumption = 21.9 W
 Total System Power consumption is: 21.9 W

 Environmental information last updated 00:00:01 ago

ENVIRONMENTAL STRESS EVENTS
===========================
Critical Temperature: Maxium = 0
                      Total Duration = 0
 Exceed Fan Tray Removal Time: Maximum Time= 0
                               Total Time = 0
Total MCU access error count: 0

From the images I have found online, it looks like the fan is just a normal 60x12.5mm 4 pin PWM part

Current config for mine:

Code:
version 15.2
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco-1921
!
boot-start-marker
warm-reboot
boot-end-marker
!
!
enable secret *****
enable password *******
!
no aaa new-model
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.50 192.168.0.51
!
ip dhcp pool main_dhcp_pool
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server ****
 lease 0 2
!
ip dhcp pool Kei-PC
 host 192.168.0.2 255.255.255.0
 client-identifier ***
 client-name Kei-PC
!
ip dhcp pool Humax
 host 192.168.0.4 255.255.255.0
 client-identifier ***
 client-name Humax
!
ip dhcp pool Kei-NAS
 host 192.168.0.3 255.255.255.0
 hardware-address ***
 client-name Kei-NAS
!
ip dhcp pool Server
 host 192.168.0.100 255.255.255.0
 hardware-address ***
!
ip dhcp pool Marantz
 host 192.168.0.5 255.255.255.0
 client-identifier ***
!
!
!
ip name-server 8.8.8.8
ip name-server 194.72.0.114
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn ********
!
!
archive
 path ftp:/********@192.168.0.3/Cisco-1921
 write-memory
 time-period 10080
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 no mop enabled
!
interface Dialer1
 ip address negotiated
 ip access-group 101 in
 no ip unreachables
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp chap hostname [email protected]
 ppp chap password 7 1415060303092F23312A1337361115190205545856571A0D0C15
 ppp pap sent-username [email protected] password ********
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
!
logging history errors
access-list 1 remark INTERNET-ACCESS
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password *******
 login
 transport input all
!
scheduler allocate 20000 1000
!
end
 
Last edited:
I used this as my guide when i first got my router last year and it was a godsend having had little cisco experience before.
 
Cheers, I will have a read. Although I think my issue is the Sky MER bit, but I'll keep trying. Although I may give up till the WIC gets here.
 
Unless I'm missing something, that guide gets you to enable password login for con0 before specifying any users. But of a schoolboy mistake.
 
finally swapped over to the 887VA as the 1921 was about 3 times louder than my PC with the fan today.

DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 68573 0 19999
SRA Previous Speed: 0 0 0 0
Previous Speed: 0 0 0 0
Reed-Solomon EC: 3 0 0 5
CRC Errors: 0 0 2 2
Header Errors: 0 0 0 0
Interleave (ms): 3.00 0.00 0.00 0.00
Actual INP: 4.01 44.00 0.00 0.00

happy with that plus its virtually silent.
 
Had another go last night, not connecting again. Did debug dialer all and there was no output. I'll give it a rest till the WIC turns up and then try it that way and see how I get on.
 
Unless I'm missing something, that guide gets you to enable password login for con0 before specifying any users. But of a schoolboy mistake.
Looks that way, though I think once you type "login local" it would say if you don't have any users .... I think :p
 
I've managed to get it connected, it then drops off about 10 seconds later.

Anything that looks wrong?

Code:
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname internet_router
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 ###########
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef    
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!
ip dhcp pool home
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254 
 dns-server 90.207.238.97 8.8.8.8 
!
!
no ip domain lookup
ip domain name home
ip name-server 90.207.238.97
ip name-server 8.8.8.8
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FCZ163591RB
license boot module c1900 technology-package datak9
!         
!
!
redundancy
!
!
controller VDSL 0/0/0
!
ip ssh version 2
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1350
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0/0/0
 mac-address ####.####.####
 no ip address
!
interface Ethernet0/0/0.101
 encapsulation dot1Q 101
 ip dhcp client request classless-static-route
 ip dhcp client client-id hex ##################
 ip dhcp client hostname ##################
 ip address dhcp
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip flow egress
 ip nat outside
 no ip virtual-reassembly in
!
interface Dialer1
 no ip address
 shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list INTERNET_ACCESS interface Ethernet0/0/0.101 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0.101
ip route 192.168.1.0 255.255.255.0 GigabitEthernet0/1
!
access-list 1 remark INTERNET-ACCESS
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 255.0.0.0 0.255.255.255 any
access-list 101 deny   ip 224.0.0.0 7.255.255.255 any
access-list 101 deny   ip host 0.0.0.0 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   udp any any range 33400 34400
access-list 101 permit icmp any any net-unreachable
access-list 101 permit icmp any any host-unreachable
access-list 101 permit icmp any any port-unreachable
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any source-quench
access-list 101 permit tcp any any established
access-list 101 permit udp any any
control-plane
!         
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

Config does need tidying but I want the link up first so I can sit and do it later on.

The hostname is the bit I got from the SR102 to work with my N66U (how I'm online now), and client-id is a HEX code of it all.
 
Last edited:
I'm a bit confused, how are you connecting this if you don't have the vdsl HWIC yet?
 
No. It connects for a few seconds and then nothing. Vdsl shows everything up including IP address from ISP, just no internet comms.
 
The issue was both NAT, ACL and the default route. It seems the router automatically default routes to Sky's next hop so the default route to the WIC sub interface was mucking up the connection. Once I've tidied up the config I'll post it up for anyone else with the same issues or setup.

Upload has gone from 12/13 to around 18. :D
 
Bit of a strange one, and I have literally no idea how this has happened. On my RT-N66U there was a bit under WAN settings for MAC address spoofing, basically this would be the MAC address of the SR102 so that you can authenticate and get an IP from Sky.

Great I thought, so I grabbed this MAC, and I put it on my eth 0/0/0 interface, and I get working internet from Sky. If this MAC address is not there, I get no IP from Sky. If I use another address, again no internet.

Which is all well and good till I noticed that my iMac was having issues when using cat5 to my switch. Had a look on the router at the arp table and the MAC address of the iMac is the same as the one I'm passing to Sky. How odd. So I dug out my SR102 and put its MAC address onto my router config, no comms.

How on earth has this happened? I'm having to use the Thunderbolt port to get online (or wireless) with my Mac which is less than ideal, as I only have one adaptor and tend to use it on my MacBook.
 
Bit of a strange one, and I have literally no idea how this has happened. On my RT-N66U there was a bit under WAN settings for MAC address spoofing, basically this would be the MAC address of the SR102 so that you can authenticate and get an IP from Sky.

Great I thought, so I grabbed this MAC, and I put it on my eth 0/0/0 interface, and I get working internet from Sky. If this MAC address is not there, I get no IP from Sky. If I use another address, again no internet.

Which is all well and good till I noticed that my iMac was having issues when using cat5 to my switch. Had a look on the router at the arp table and the MAC address of the iMac is the same as the one I'm passing to Sky. How odd. So I dug out my SR102 and put its MAC address onto my router config, no comms.

How on earth has this happened? I'm having to use the Thunderbolt port to get online (or wireless) with my Mac which is less than ideal, as I only have one adaptor and tend to use it on my MacBook.
I assume when you check the MAC on your imac in the settings, it's different to the address in the arp table?
I'd say it's more the MAC address table you need to check though the interface on the switch, what address is showing on that interface.
 
Well I changed it on the router from the iMac's address to the one on the SR102 and then went on the lash. Took about two hours but the connection came back up. Odd. :D
 
Back
Top Bottom