Configuring a Cisco 857...

Bes

Bes

Soldato
Joined
18 Oct 2002
Posts
7,318
Location
Melbourne
Well I got a S/H Cisco 857 but cannot configure the thing, as the Cisco software cannot find the router :(

Does anyone have an idiot's guide to getting this thing up and running? as the docs I have looked at (including Cisco's own) haven't helped much so far

Thanks
 
If you are not 100% on the IP address it's time to crack out the console cable.

Setup a terminal session on COMx (whatever you serial port is) and set it up as 9600,n,1,n and you should get into the router.

You might need to login at this point, you might not. If it prompts you to login, then enter the username and password.

You then need to go into enable mode - type EN and hit return, then it'll ask for the enable password. Enter this and then the prompt should change to a #.

Type "sh run" and it'll start outputting the running config. Scroll through until you see a reference to the ethernet interface (probably Ethernet0 or FastEthernet0 or FE0....something like that) and check the IP address. Also check that it's enabled (NO SHUTDOWN). If it's not the same as you expected then you can either setup your PC to match the routers subnet and SDM in and set it up that way, or change the interface address.

Sorry if there is an easier way - I'm no Cisco expert (I've had a 837, 1721 and 1841 in the past) - but I didn't really have to do much on them.
 
Console is the only true way.

Pretty much all Ciscos have one and it's much easier than trying to connect via network stuff, plus saves frustration when you change something that causes the connection to drop.

Usually they ship with a "light blue cable of win" in the box. Though i couldn't say for sure as I only really deal with enterprise stuff; 1800/ 2650 /2800 and so on, but it's unlike cisco to break the habit of a lifetime.

If you're unsure on serial settings, putty.exe works on it's default settings.
 
Yeah I have had a play with the console before, but to be honest, I don't really know Cisco gear... ANyway, no IP assigned:

interface FastEthernet0
!
 
If you need help there's plenty on here who can. Just let us know what you want to do and we can tell you how.
first steps would be adding an enable password, ip address and telnet password via
enable
conf t
enable secret <your-chosen-password>
int Fa0
Ip address <desired ip> <subnet mask>
no shutdown
line vty 0
password <desired password>
login
end
service password-encryption
copy run start


Quickest way is to copy that into notepad, replace the values with the ones you want, copy it then do a "paste to host" in hyperterminal.
Then you can connect to it via telnet on it's ethernet interface and possibly with the software.
 
You don't configure the VLANs on the router itself, only the trunking which is done with sub-interfaces I believe.

The actual VLAN setup is done on the switch.
 
Ok I tried following your commands, but I get:

Router(config-if)#ip address 10.10.0.1 255.255.255.0

% IP addresses may not be configured on L2 links.

This is my config:

Router#sh run
Building configuration...

Current configuration : 973 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$AHXI$peFglSsAjNQKRoPXNmlZW1
!
no aaa new-model
!
resource policy
!
no ip dhcp use vrf connected
!
ip dhcp pool stdhcppool
import all
network 10.10.0.0 255.255.255.0
default-router 10.10.10.10
dns-server 87.194.0.52
domain-name re-vu.net
!
!
ip cef
ip domain name re-vu.net
ip name-server 87.194.0.52
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0
password ********
login
line vty 1 4
login
!
scheduler max-task-time 5000
end
 
ahh right, this router has an integrated managed swtich. You will need to apply the IP address to VLAN1

config t
int VLAN1
ip address 10.10.10.1 255.255.255.0
 
Hi,

Thread resurrection, but I am unable to get my ADSL working. It just cannot connect to anything (i,e, the DNS server, all connection tests fail when pinging, etc)

I am on O2 and using a fixed IP- any ideas?

Config:

Code:
Building configuration...

Current configuration : 3108 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 512000 warnings
!
no aaa new-model
!
resource policy
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.9
!
ip dhcp pool sdm-pool1
   network 10.10.10.0 255.255.255.0
   dns-server 87.194.255.155 
   default-router 10.10.10.1 
!
!
ip cef
ip name-server 87.194.255.155
!
!
crypto pki trustpoint TP-self-signed-27577287
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-27577287
 revocation-check none
 rsakeypair TP-self-signed-27577287
!
!
crypto pki certificate chain TP-self-signed-27577287
 certificate self-signed 01
xxxx
  quit
username sam privilege 15 password 0 xxxxxx
!
! 
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto 
!
interface ATM0.10 point-to-point
 ip address 87.194.149.7 255.255.248.0
 ip nat outside
 ip virtual-reassembly
 no snmp trap link-status
 pvc 0/101 
  oam-pvc manage
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 87.194.144.1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface ATM0.10 overload
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Thanks!
 
Hey got it now, never mind :D

I will post my config up in a bit in case others need help with this in the future
 
Usually they ship with a "light blue cable of win" in the box. Though i couldn't say for sure as I only really deal with enterprise stuff; 1800/ 2650 /2800 and so on, but it's unlike cisco to break the habit of a lifetime.

Actually, ironically, the enterprise stuff seems often to ship without console cables. I've had quite a few 6500s and 7300s which have shipped without a console cable seemingly. All the low end stuff always has it though...
 
My working config is here... This is for O2 Broadband with a fixed IP on a Cisco 857 if it is any use to anyone in the future.

Thanks for the help all- Only took nearly 10 months, two broken O2 modems, and lots of irate phone calls to said ISP for me to pull my finger out and get this working! :D

Code:
Building configuration...

Current configuration : 4055 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local 
!
aaa session-id common
!
resource policy
!
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.9
!
ip dhcp pool sdm-pool1
   network 10.10.10.0 255.255.255.0
   dns-server 87.194.255.155 
   default-router 10.10.10.1 
!
!
ip cef
ip tcp synwait-time 10
no ip bootp server
ip name-server 87.194.255.155
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
crypto pki trustpoint TP-self-signed-27577287
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-27577287
 revocation-check none
 rsakeypair TP-self-signed-27577287
!
!
crypto pki certificate chain TP-self-signed-27577287
 certificate self-signed 01
  3082023A 308201A3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32373537 37323837 301E170D 30393130 30323137 31383336 
  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53 
  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D323735 37373238 
  3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100AF94 
  A75D7565 5787F2C6 034CCDC5 24E6D28F FF4FB95A 5A078E01 D523AEEF 56BBD74F 
  12F4D398 3F20B17A 71854168 204D474F 2D68A003 9D5C630E C0274599 F810D908 
  70F82419 FD9CDA42 08B1AE93 F011DD02 8394C4C6 AB139B47 2EEC0D88 F0C93738 
  BDB7268A 94750BBB 09FA0DD2 6DC4372A 0FDE86AC DA223C4E 962D8946 4AD50203 
  010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603 551D1104 
  0A300882 06526F75 74657230 1F060355 1D230418 30168014 62D83D6F 3CFDEF45 
  9EDC6BB7 8AFDAF16 BB444726 301D0603 551D0E04 16041462 D83D6F3C FDEF459E 
  DC6BB78A FDAF16BB 44472630 0D06092A 864886F7 0D010104 05000381 810074C9 
  CEEC5ACF 86C13177 7BE83865 1E6952DA A5B2042F 901183AB 071F4FAE 343CE939 
  48BA070E 505DAE96 8D225898 F433F6C1 C8C3785C D01541CE 2867C711 A51CE412 
  AEC31DBC 6B7FA12F 0FFDDD2F 72E24339 E01A92C8 74382EAA 0B43AC6F 9A355286 
  BCE6621B 2F6B237C 3464B271 3B49AE0D 3CBB4FBB A56D549B E18B006A 18E4
  quit
username sam privilege 15 password 7 :)
!
! 
!
bridge irb
!
!
interface Null0
 no ip unreachables
!
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no atm ilmi-keepalive
 dsl operating-mode auto 
!
interface ATM0.1 point-to-point
 ip address xx.xx.xx.xx 255.255.248.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 no snmp trap link-status
 atm route-bridged ip
 pvc 0/101 
  oam-pvc manage
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
!
ip route 0.0.0.0 0.0.0.0 87.194.144.1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface ATM0.10 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!
^C
!
line con 0
 login authentication local_authen
 no modem enable
line aux 0
 login authentication local_authen
line vty 0 4
 authorization exec local_author
 login authentication local_authen
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
 
All the stuff I've gotten recently had a naff quality RJ45-RJ45 cable and a RJ45-DB9 adaptor - Not seen a blue cable since I bought my 1841 about 3 years ago
 
I didnt think the 857 supported ADSL2? Or are you only on the access package?

Yeah I can't get anything better on this line :(

But the router is a great bit of kit- and I actually thought ADSL 2 was supported :confused:
 
I think ADSL2+ support came with the 877, hence why i got one :)

*EDIT* It seems it does, if you have the correct firmware! Learn something new everyday!
 
Back
Top Bottom