1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Couple of car fixes- Need help!

Discussion in 'Motors' started by Morthoseth, 5 Jun 2006.

  1. Morthoseth

    Wise Guy

    Joined: 13 May 2004

    Posts: 1,491

    Location: Wales, Wrexham

    Right, after a trip out the other day a few problems have arisen.

    #1 - Speedo sometimes decides to stop working, i.e. 55mph indicated at 0mph, then resets eventually (Loose speedo cable afaik)

    #2 - Squeaking wheels, generally when i turn the wheel, which is worrying me a bit

    #3 - Squeaking brakes (generally at low speeds - after Fox' post im not so worried about this, but still..)

    Help! what could be wrong with #2 more than anything?

    and how much are these likely going to cost to fix?
     
  2. Bug One

    Capodecina

    Joined: 18 Oct 2002

    Posts: 11,168

    Location: Sandwich, Kent

    What car?

    First sounds like the speedo cable is knackered. Could be rounded off where if meets the gearbox, at the joint in the middle, or behind the speedo. Dead easy job. Only took me a minute, once I'd sourced the replacement cable.

    For the squeeling brakes, first thing to check is that you dont need new pads. They often have a wear indicator which will make a sqeel to let you know they need changing.

    If you have new brakes, and you're getting a noise when you turn, it could be the brake heat sheild rubbing on the disk. Check underneath and pull it away a bit to make sure.

    It it is the brake pads, the general solution is plenty of copper grease, then if that doesn't work, anti squeel shims.
     
    Last edited: 5 Jun 2006
  3. Morthoseth

    Wise Guy

    Joined: 13 May 2004

    Posts: 1,491

    Location: Wales, Wrexham

    Hyundai coupe F2 Evolution