1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dark and Light?

Discussion in 'PC Games' started by n3crius, 6 Jun 2006.

  1. n3crius

    Mobster

    Joined: 2 Aug 2004

    Posts: 2,941

    Location: London, UK.

    anyone tried this new mmorpg? think it's just been released.

    ( reading forums etc, it's not looking like a terrific launch! ).
     
  2. kola

    Mobster

    Joined: 2 Oct 2003

    Posts: 2,652

    Location: MI5 | Thames House

    I would prefer to waste my money on rf online

    Animations are a joke :mad:
    Every 1 looks the same :eek:
    No Mobs No Quests :rolleyes:
    People who paid months ago get to be lvl 35 from the start :confused:
    loads more crap too :D
     
    Last edited: 6 Jun 2006
  3. Sleepery

    Sgarrista

    Joined: 4 Jun 2003

    Posts: 9,941

    Location: Fraggle Rock

    Looks like it's been absolutely terrible, had a read of their forums a day after launch and it was full of complaints. Not just the usual launch day stuff either, things like missing tutorials, there being only one quest live in the whole game, no dungeons, really slow performance on top end systems.

    One guy did a montage of all the forum titles, really gives you an idea what it's like :

    http://img267.imageshack.us/img267/2342/badlaunch1pc.jpg
     
    Last edited: 6 Jun 2006
  4. Wyrdo

    Capodecina

    Joined: 19 Feb 2004

    Posts: 15,055

    Location: Darlington, UK

    I'd pre-ordered this and managed to get a refund last week as the game is an absolute joke.

    For people who pre-ordered you could play the Settles of Ganareth? part of the game It was shockingly bad.
     
    Last edited: 6 Jun 2006
  5. Mp4

    Sgarrista

    Joined: 21 Apr 2006

    Posts: 8,460

    Location: Eastbourne

    ah thats a shame :/ i got an email saying it was released guess i wont be going there then. :E
     
  6. Noxis

    Banned

    Joined: 26 Jul 2003

    Posts: 6,348

    Location: Surrey

    I tried really REALLY hard to like this game as the concept is quite nice... however it fails :( I couldnt get a tutorial of any sort to work (some kinda questy crap that instantly failed for me on its first task) so gave up.