Disable GPU for video playback?

Associate
Joined
20 Oct 2002
Posts
1,127
Location
Redcar
;tldr
How can you set media players (MCP-HC, MPC-BE ) to FORCE CPU usage rather than GPU usage when rendering video?
--

I’m helping my brother out over Teamviewer as he has got a rather odd situation with trying to get media playback to work smoothly.

He has a fairly old i7-4770 tower which he had connected to his screen via display port. He’s gone and “upgraded” to a bigger screen, but it only has HDMI, the tower (Dell) only has display port built in. From somewhere he’s gotten a GeForce GT710 to give him a HDMI connection.

The problem is, with the GT 710 in, his machine will no longer play back 1080p video smoothly. The GPU usage in task manager goes to 100% and the video stutters and the sound chops in and out. CPU usage at this point is 2%

Pulling the GT 710 out again, 1080p content works no problem being decoded on the i7, CPU usage is about 65%

However, he can’t now use his bigger screen which is how this all started in the first place.

I am at a loss to help him. Windows and media players all default to using GPU rendering where in this case, sadly, the GPU is less powerful than the CPU.

What settings in either MCP-HC, MPC-BE or using LAV filters can you set to FORCE the CPU to take the load, leaving the graphics card as a glorified HDMI converter?

He doesn’t have the money / space (it’s a sff) or time before Xmas to get another card / device in

Thanks!
 

ALD

ALD

Associate
Joined
18 Oct 2002
Posts
422
Location
Devon
What settings in either MCP-HC, MPC-BE or using LAV filters can you set to FORCE the CPU to take the load, leaving the graphics card as a glorified HDMI converter?

Just set hardware decoder to none in the dropdown list.
 
Soldato
Joined
11 Oct 2009
Posts
15,362
Location
Greater London
Alternative option, wouldn't a Displayport to HDMI adapter work?

As above, in the LAV filter settings, there's an option to set the hardware decoder to none. You can try force it to Intel's QuickSync to see if that works as well, or force Nvidia CUVID to see if that does better than DXVA. DXVA2 copyback generally works best from my experience.
 
Associate
OP
Joined
20 Oct 2002
Posts
1,127
Location
Redcar
Just set hardware decoder to none in the dropdown list.

Thats what we thought, but selecting none does...nothing! The GPU still maxes out at 100% making videos unwatchable


Alternative option, wouldn't a Displayport to HDMI adapter work?

As above, in the LAV filter settings, there's an option to set the hardware decoder to none. You can try force it to Intel's QuickSync to see if that works as well, or force Nvidia CUVID to see if that does better than DXVA. DXVA2 copyback generally works best from my experience.

He has a Neet branded Display Port to HDMI adaptor, it shows a picture but it suffers from awful screen breakup, lots of black screen moments.

To be honest, we've been through every option in the LAV video hardware decoder options and with the GT 710 installed nothing works as smoothly as when the card is not installed and it's set to DXVA2 (via the CPU?)
 
Soldato
Joined
11 Oct 2009
Posts
15,362
Location
Greater London
To be honest, we've been through every option in the LAV video hardware decoder options and with the GT 710 installed nothing works as smoothly as when the card is not installed and it's set to DXVA2 (via the CPU?)

Just to make sure, are all the internal filters in MPC disabled, and under external filters, LAV Splitter, LAV Splitter Source, LAV Video decoder and LAV Audio decoder is set as preferred in external filters?
 
Associate
OP
Joined
20 Oct 2002
Posts
1,127
Location
Redcar
I apricate the continued follow-up from people.

I got him to send me the screen shot below.
  • All MPC internal filters disabled
  • LAV splitter, LAV splitter source, LAV video decoder and LAV audio decoder added as external filters
  • Hardware Acceleration decoder set to None

Yet as you can see the GT 710 he is using for the HDMI port is maxxed out!
RJ46CjS.jpg
 
Soldato
Joined
11 Oct 2009
Posts
15,362
Location
Greater London
What does the external filters look like? It should be set like this, all set to preferred: https://i.imgur.com/THLI3wS.png

I just tested it myself, setting hardware acceleration to none does stop the GPU video decoder from doing nothing, but MPC itself is still using the GPU to render the video. I couldn't work out how to switch to software rendering.

Is it possible to enable the IGP in the BIOS, and in LAV, set the hardware device to the Intel IGP? Not sure if that will significantly help but it might be worth trying.

Also, you might want to uncheck H.264 MVC. RGB Output could also be changed to 0-255 or untouched.
 
Associate
Joined
12 May 2005
Posts
1,767
Change the "output" video renderer to overlay / Enhanced Video Renderer / system default. EVR uses the GPU but is very fast and low quality.
 
Top Bottom