Do i need a new psu ?

Associate
Joined
17 Jul 2008
Posts
430
Ok where do i start, my 13 yr old son has my old pc a amd 3800 x 2 socket 939 running at 2500mhz on a dfi sli lanparty expert. Problem is son was using it the other night when smart gardian started sounding off so he shut it down. Found that the chipset fan was on the way out so have replaced that with a thermaltake hr 05 sli passive cooler, but since putting everything back together the 3.3voltage from psu is only 1volt if that. The pc boots fine into windows temps are ok, could this just be psu or is the motherboard damaged ? Psu is a targan tg480-u15 modular 480watt psu. Also what wouls be a good replacement?
 
Caporegime
Joined
17 Jan 2010
Posts
66,804
Location
weston-super-mare
Associate
Joined
17 Jul 2008
Posts
430
Psu is over six yrs old, bios says same lower than 1 volt and also hardware monitor says the same all other voltages are within atx specs. Do not want to ignore readings from bios or hardware monitor. forgot gpu is a 8800gt, running three hdd + few fans. Guess something like 500 - 650 watt will do.
 
Caporegime
Joined
17 Jan 2010
Posts
66,804
Location
weston-super-mare
That PSU I suggested is plenty for that spec.

What if its the device reading the voltage that faulty? thats why a multimeter reading/PSU tester reading is more quantifiable.
 
Last edited:
Associate
Joined
17 Jul 2008
Posts
430
Have no problem testing with multimeter, back probing method right in just orange wire parts of atx 24 pin, pins 1,2,12, 13,right? if reports less than 2.97 volts take it psu faulty? Anyothers to check?
 
Associate
Joined
17 Jul 2008
Posts
430
Ok many thanks will do, still have a soft spot for my old system those were the days when amd ruled.
 
Associate
Joined
17 Jul 2008
Posts
430
What do you think of ocz 500watt mod extreme pro, can get this for around £50 more connectors and modular.
 
Associate
Joined
17 Jul 2008
Posts
430
Ok update, tested with digi volt meter and have a healthy 12v, 5v, & 3v. Tested across a spare molex connector and all orange wires on 24pin power supply connector. So can i safely ignore the dodgy reading of the 3.3v supply in the bios and all other monitoring software. Is this a sign that the motherboard is starting to fail or just a broken sensor on the board. Will let son loose on it again if you think this is all fine.Starting thinking of cheap amd upgrade for him i guess.
 
Associate
Joined
17 Jul 2008
Posts
430
PC was running windows xp and sat on desk top at the time. Tested 5v and 12v from spare molex and 3.3v from the 24 pin atx connector buy pushing probes into orange cable sockets tested all 4. Did pc need be under more load?
 
Associate
Joined
17 Jul 2008
Posts
430
Will running a game do as a stress test, could get son to play something while i recheck voltages.
 
Associate
Joined
17 Jul 2008
Posts
430
Ok thx, will retest tomorrow when i'm back from work. How long would you run test for? enough to raise temps and get things nice and warm.
 
Soldato
Joined
23 Mar 2007
Posts
2,553
Location
Essex
The nzxt hale90 650 is supposed to be a very nice psu at 80% gold efficiany. Seems to get fab reviews and is more a less fully modular bar the 24pin and 4+4 cpu pin
 
Associate
Joined
17 Jul 2008
Posts
430
Ok thxs again, fingers crossed will test and report back tomorrow. Hopefully just a duff sensor.
 
Top Bottom